An ActiveX object is an instance of a class that exposes properties, methods, and events to ActiveX clients.

are actions that an object can perform. For example, the Document object in your labeling software provides a Close method that closes the current document.

are functions that access information about the state of an object. The Application object’s Visible property determines whether the labeling software is visible or not.

are actions recognized by an object, such as clicking the mouse or pressing a key. You can write code to respond to such actions. In Automation, an event is a method that is called, rather than implemented, by an object.

ActiveX Object Definition

What is an ActiveX object?

ActiveX objects support the COM (Component Object Model) - Microsoft technology. An ActiveX component is an application or library that is able to create one or more ActiveX objects. In this case, your labeling software publishes many objects that you can use to create new applications and programming tools. Within your labeling software, objects are organized hierarchically, with an object named Application at the top of the hierarchy.

Each ActiveX object has its own member function definition. When the member functions are published, it makes the object programmable by an ActiveX client. Three types of members can be published for an object:

  • Methods

  • Properties

  • Events

Your labeling software often works with several instances of an object which together make up a Collection object.

For example, since your labeling software is a multiple-document interface (MDI), it might have multiple documents. To provide an easy way to access the documents, your labeling software publishes an object named Documents, which refers to all of the already opened document objects. Documents is a collection object.

A Collection object lets you work as a group with the objects it manage.


Type Library Definition

What is the type library?

The type library does not store objects, it stores Automation Interface information. By accessing the type library, your application can determine the characteristics of an object, such as the interfaces supported by the object and the names and parameters.

This library helps you to write your program because it contains all the definitions of object methods and properties that you can access. Using this library you optimize your job.

The name of this type library is LabelManager2 with the TK Labeling Interface reference.

The procedures below show how to install and use the type library with Visual Basic 6.0.

To install the type library

  1. Choose Project References.

  2. Activate TK Labeling Interface in the list of available references then validate the dialog box.

To display the methods and properties

  1. Use the Object Explorer by pressing the F2 key.

  2. In the library list, select LabelManager2.

To use the type library

  • While writing code, you have just to enter a period ”.” after an object to get the associated methods and properties, or an opening parenthesis "(" after a method to get the associated properties.


Mechanisms

Your labeling software offers you two main objects: the Application object that is at the top of the hierarchy and the Document object.

These main objects provide access to the subordinated objects (see the hierarchy diagram).

The first step to activate the server is the main object creation, in this case, the Application object.

The last step is the deactivation of the server with the Quit method.


CreateObject Function

This function creates and returns a reference to the Application object.

Syntax CreateObject("server name")

Defines an object variable. This object variable is meant to contain the object reference. Dim as Object creates a link at execution.

Dim MyApp as Object
Set MyApp = CreateObject("Lppx2.Application")

This code launches the application that creates the object. In this case, the labeling software. As soon as the object is created, you reference it in the code with the object variable that you have defined, i.e. MyApp.

Note:
If you define an object variable with ''As Object'', a variable containing a reference for any object type is created. However, the access to an object via this variable is realized by a late bind, i.e. the link is created during the execution of your program. To create an object variable that induces an early bind, i.e. a link during the compilation of your program, define the object variable with a specific identifier.

For example, you can define and create the reference using the code below:

Dim MyApp As LabelManage2Application
Set MyApp = CreateObject(Lppx2.Application)

The variable reference creating an early bind increases the performance and allows VB syntaxe control but must only contain one reference.

Note:
In some specific use cases, when running the Label Designer in automation mode, performance can be optimized by renewing its instance on regular basis.


GetObject Function

This function returns a reference to an ActiveX object from a file.

Syntax GetObject([pathname],[server name])

The syntax of the GetObject function includes the following arguments:

Item | Description
Pathname | Optional. Variable of Variant type (String). Complete pathname with the name of the file containing the object to get. If you don't define the pathname, you have to define the server name.
Servername | Optional. Variable of Variant type (String). Name of the application that gives the object.

Note:
Use the GetObject function to access an ActiveX object from a file and to assign this object, an object variable. Use the Set instruction to assign the object that is returned by the GetObject function at the object variable.

Below are several examples showing the variations of the GetObject syntax.

Dim MyDoc As Object
Set MyDoc = GetObject("c:\ProgramFile\document.lab")

When this code is executed, the application associated with the pathname argument is launched and the object included in the file is activated.

Note:
In the case where the server automation is already loaded in the system memory, the ActiveX mechanism selects it, then the document is activated.

Note that in the example below the Visual Basic for Application expression GetObject(,”Lppx2.Application") will fail unless the Application (the labeling software) is already running.

If the Application is not already running, a new instance will not be launched.

Dim MyApp As Object
Set MyApp = GetObject (,"Lppx2.Application")

In this example, the variation of the GetObject syntax varies from the previous example in that a new instance of the application will always be launched even if the application is already running. This variation is equivalent to a CreateObject statement.

Dim MyApp As Object
Set MyApp = GetObject ("","Lppx2.Application")


New Function

The key word New can only be used if you work with the Type Library (see What is the type library).

New assigns an object reference to a variable or to a property.

Syntax Set MyApp = {[New] objectexpression }

This example demonstrates reation of the MyApp object that represents Application. This is the standard access to get the subordinated objects of Application.

Dim MyApp As LabelManager2.Application
Set MyApp = New LabelManager2.Application

or

Dim MyApp As New LabelManager2.Application

The syntax of the Set instruction contains the following items:

Item | Description
objectvar | Name of the variable or property.
New | Optional. This key word is generally used in the declarations to allow the implicit creation of an object. Used with Set, the New key word creates a new instance of the class. If the objectvar argument contains a reference to an object, this reference is lost when a new association is created.

Note:
The objectvar must have an object type compatible with the object to which it is assigned.


Quit Method

The Quit method is used to end the process. Before using this method, it's recommended to close all the documents. You must disconnect Events.

The following example shows how to deactivate the server. Use the CloseAll method on the Documents collection to close all the documents. Then, use the Quit method on the Application object to end the process. The Quit instruction delete the Application from the system memory.

MyApp.Documents.CloseAll False
MyApp.EnableEvents = False

MyApp.Quit
Set MyApp = Nothing


Application Object Definition

The Application object represents the labeling software. The Application object contains the properties and the methods that return the first level objects. For example, the ActiveDocument property returns a Document object.

Using the Application object

To return the Application object, use the Application property. The following sample shows how to display the path defined for the labeling software.

Dim MyApp As LabelManager2.Application
Set MyApp = New LabelManager2.Application

MsgBox MyApp.Path

Most of the properties and methods that return the common user interface objects, such as the active document (ActiveDocument property), can be used without the identifier of the Application object by using the With keyword.

Dim MyApp As LabelManager2.Application
...
With MyApp
.ActiveDocument
end With


Document Object Definition

The Document object represents an open document. Each open document in the labeling software is represented by a Document object. This object has members (properties, methods, and events) that you can use to manipulate the document.

You can access the current document if there is an open document by using the ActiveDocument property of the Application object.

All open documents that belong to the documents collection are represented by the Documents object. You can find a particular document by moving through this collection.


Collection Object Definition

A Collection object is an ordered set of items that can be referred to a unit.

Note:
The Collection object provides a convenient way to refer to a related group of items as a single object. The items, or members, in a collection need only be related by the fact that they exist in the collection. Members or items of a collection don’t have to share the same data type.

A collection can be created the same way other objects are created.

For example:

Dim X As New Collection

Once a collection is created, members can be added using the Add method and removed using the Remove method. Specific members can be returned from the collection using the Item method whereas the entire collection can be browsed using the For Each...Next statement.

Collection methods

Methods for collection are described in the following table. The Item method is required; other methods are optional.

Method name | Return type | Description
Add | VT_DISPATCH or VT_EMPTY | Adds an item to a collection. Returns VT_DISPATCH if object is created (object cannot exist outside the collection) or VT_EMPTY if no object is created (object can exist outside the collection).
Item | Varies with type of collection | Returns the indicated item in the collection. Required. The Item method may take one or more arguments to indicate the element within the collection to return. This method is the default member for the collection object.
Remove | VT_EMPTY | Removes an item from a collection. Uses indexing arguments in the same way as the Item method.

The Item method takes one or more arguments to indicate the index. Indexes can be numbers or strings.

Because Item is the default method, you could write either:

MyObject.Item(3).Name

-Or-

MyObject(3).Name

Count Property

Returns a Long (long integer) containing the number of objects in a collection. Read-only.


Handling an Object’s Events

An object that triggers events is called an event source.

To handle the events triggered by an event source, you can declare a variable of the object’s class using the WithEvents keyword.

For example, to handle the ProgressPrinting event of a Document, place the following code in the Declarations section:

Private WithEvents MyDoc As LabelManager2.Document
Private mblnCancel As Boolean

In this case, the client application must set the EnableEvents property of the application to True in order to trigger the events.

Warning:
The WithEvents keyword specifies that the variable MyDoc will be used to handle an object’s events. You specify the kind of object by supplying the name of the class from which the object will be created.

The variable MyDoc is declared in the Declarations section because WithEvents variables must be module-level variables. This is true regardless of the type of module you place them in.

The variable mblnCancel will be used to cancel the LongTask method.

Limitations on WithEvents variables

You should be aware of the following limitations on the use of WithEvents variables:

  • A WithEvents variable cannot be a generic object variable. That is, you cannot declare it As Object - you must specify the class name when you declare the variable.

  • You cannot declare a WithEvents variable As New. The event source object must be explicitly created and assigned to the WithEvents variable.

  • You cannot declare WithEvents variables in a standard module. You can declare them only in class modules, form modules, and other modules that define classes.

  • You cannot create arrays of WithEvents variables.

Writing code to handle an event

As soon as you declare a variable WithEvents, the variable name appears in the left-hand drop down of the module’s code window. When you select MyDoc, the Document class events will appear in the right-hand drop down, as shown in Figure below:

An event associated with a WithEvents variable

Selecting an event will display the corresponding event procedure, with the prefix MyDoc_. All the event procedures associated with a WithEvents variable will have the variable name as a prefix.

For example, add the following code to the MyDoc_ProgressPrint event procedure:

Private Sub MyDoc_ProgressPrinting (ByVal Percent as integer,Cancel as integer)
lblPercentDone.caption = CInt (100 * Percent) & "%"
DoEvents
If mblnCancel Then Cancel = True
End Sub

Whenever the ProgressPrinting event is raised, the event procedure displays the percent complete in a Label control. The DoEvent statement allows event processing to occur. The module-level variable mblnCancel is set to True, and the MyDoc_ProgressPrinting event then tests it and sets the ByRef Cancel argument to True.


Connecting a WithEvents variable to an object

When you declare a variable WithEvents at design time, there is no object associated with it.

A WithEvents variable is just like any other object variable. You have to create an object and assign a reference to the object to the WithEvents variable.

Add the following code to the Form_Load event procedure to create the LabelManager2.Application.

Private Sub Form_Load()
Set MyApp = New LabelManager2.Application
Set MyDoc = MyDoc.Documents.Add ("My Document")
MyApp.EnableEvents = True
End Sub

When the code above is executed, Visual Basic creates a LabelManager2.Application and a new document called ”My Document” then connects its events to the event procedures associated with MyDoc. From that point on, whenever the MyDoc raises its ProgressingPrinting event, the MyDoc_PrintProgressing event procedure will be executed.

Add the cleaning code in the Form_Unload event procedure:

Private Sub Form_Load()
MyApp.Documents.CloseAll False
 MyApp.EnableEvents = False

MyApp.Quit
Set MyApp = Nothing
End Sub


Compatibility with different versions

  • This version is compatible with the previous version of the label design software. However, the labeling software includes new features and certain processes have changed.
    To ensure your program can be executed with this version, verify your code by referring to the Help online of your labelling software and to this help for information on the functions that have changed.

  • If you have a RunTime version, you will only be able to access to the RunTime functions


BlockField Object

Properties | Methods
DataType | (none)
Flags |
Index |
LinkedObjectName |
MaxDataLength |
Name |
Rules |
Size |
SupportedDataTypes |
Value |
ValueEx |

Object Properties

BlockField.DataType

Returns or sets the data type.

Access Read/Write.

Type EnumRfTagBlockDataType

BlockField.Flags

Returns or sets the flags.

Access Read/Write.

Type EnumRfTagFieldFlags

BlockField.Index

Returns or sets the ordinal position.

Access Read/Write.

Type VT_I4 or Long.

BlockField.LinkedObjectName

Returns or sets the linked object name.

Access Read/Write.

Type VT_BSTR or String

BlockField.MaxDataLengh

Returns the maximum number of characters that can be set in the data (depending on DataType).

Access Read-Only.

Type VT_BSTR or String

BlockField.Name

Returns or sets the name.

Access Read/Write.

Type VT_BSTR or String

BlockField.Rules

Returns or sets the rules applied for the data field encoding (now only "Dod64Cage" and "Dod96Cage" are available on the field DODACC/CAGE with DOD64 or DOD96 structured fields and "RestrictedDigits" for each fields depending on a master partition field).

Access Read/Write.

Type VT_BSTR or String

BlockField.Size

Returns or sets the size in bits.

Access Read/Write.

Type VT_I4 or Long

BlockField.SupportedDataTypes

Returns or sets the supported data types.

Access Read/Write.

Type EnumRfTagBlockDataType

BlockField.Value

Returns or sets the value.

Access Read/Write.

Type VT_BSTR or String

BlockField.ValueEx

VT_BSTR or String ValueEx(DataType as EnumRfTagBlockDataType)

Returns or sets the value converted with the specified datatype format.


DevMode Sample

This page shows how to use the printer methods: GetDevMode and SetDevMode.

First, call the GetDevMode with an uninitialized variant parameter, initialize it with a correct array (VT_ARRAY, VTI1, Size returned), and call again the GetDevMode method.

If the variant does not have the correct size, the server clears and reallocs the variant with the valid size before it is returned with the data.

To set the DevMode it is the same process. The array passed through the variant parameter must have the type VT_ARRAY and VTI1, and the size reflects the dmSize of the devmode!

This example gets and sets the same devmode, but with visual basic it is more difficult to cast the byte array referenced through the variant in the LPDEVMODE structure:

Dim oCS As LabelManager2.Application

Dim oDoc As LabelManager2.Document

Dim ISize As Long

Dim devmode As Variant

Set oCS = GetObject(, "lppx2.Application")

Set oDoc = oCS.ActiveDocument

ISize = oDoc.Printer.GetDevMode(devmode)

ISize = oDoc.Printer.GetDevMode(devmode)

ISize = oDoc.Printer.SetDevMode(devmode)


Hierarchy diagram

The diagrams below show the object hierarchy:


Application Object

Properties | Methods
ActiveDocument ActivePrinterName | DocumentStatus ErrorMessage
Application C aption C lientWindow DefaultFilePath D ialogs | FormatSystem GetLastError LabelArchive Lock M ove
Documents EnableEvents | PrinterSystem Quit
FullName | Resize
Height | ShowHelp
IsEval Left | Unlock
Locked |
LogFile |
MainWndHandle |
Name (Default) |
Options |
Parent |
Path |
PID |
ProgramCode |
RecentFiles |
SharedOwner Top |
UserControl UseUserInterface |
Version |
Visible Width |

Object Properties

Application.ActiveDocument

This property allows you to access the document object interface (refer to the document which has the focus in the main application).

Returns an error if no document in application.

Access Read-Only.

Type VT_DISPATCH or Document.

Application.ActivePrinterName

Returns the current pair <Printer, Port> of the active document, if any, empty string if none.

Access Read-only.

Type VT_BSTR or String.

Application.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-only.

Type VT_DISPATCH or Application.

Application.Caption

Returns or sets the caption text for the application window. To change the caption of the application window into the default text, set this property to an empty string (””).

Access Read/Write.

Type VT_BSTR or String.

Application.ClientWindow

Sets or retrieves the window handle Use in case of print to file.

Access Read/Write.

Type VT_I4 or Long.

Application.DefaultFilePath

Sets or returns the default path specification used by the application for opening document files.

Access Read/Write.

Type VT_BSTR or String.

Application.Dialogs

Returns the Dialogs collection that represents all the built-in dialog boxes of the application.

Access Read-only.

Type VT_DISPATCH or Dialogs.

Application.Documents

Returns the Documents collection that represents all the open documents.

Access Read-only.

Type VT_DISPATCH or Documents.

Application.EnableEvents

Enables or disables Automation events notification (Default: False) (see Appendix).

Access Read/Write.

Type VT_BOOL or Boolean.

Application.FullName

Returns the file specification for the application, including path. (Ex : c:\drawdir\scribble).

Access Read-Only.

Type VT_BSTR or String.

Application.Height

Returns or sets the height of the main window of the application (in pixel unit).

Access Read/Write.

Type VT_I4 or Long.

Application.IsEval

True if the application is a demo version.

Access Read-only.

Type VT_BOOL.

Application.Left

Returns or sets the distance between the left edge of the main window of the application and the left edge of the screen (in pixel unit).

Access Read/Write.

Type VT_I4 or Long.

Application.Locked

Locks the User Interface if True.

Access Read/Write.

Type VT_BOOL or Boolean.

Application.LogFile

Returns a LogFile Object.

Access Read Only

Type VT_DISPATCH

Application.MainWndHandle

Returns the main window handle of the labelling application.

Access Rea-Only

Type VT_I4

Application.Name

Returns the name of the application (for example, ''Microsoft Word''). Default property.

Access Read-Only.

Type VT_BSTR or String.

Application.Options

Represents application and general document options. Many of the properties for the Options object correspond to items in the Options dialog box (Tools menu). Use the Options property to return the Options object.

The following example sets two application options:

With Options

.LoadPrinterSetup = True

.MeasureSystem = lppxInch

End With

Access Read-only.

Type VT_DISPATCH or Options.

Application.Parent

Returns the parent object of the specified object.

Access Read-only.

Type VT_DISPATCH.

Application.Path

Returns the path of the Application ( with « \ » character at the end).

Access Read-only.

Type VT_BSTR or String.

Application.PID

Returns the current process identifier.

Access Read-Only.

Type VT_I4 or Long.

Application.ProgramCode

Returns the program code.

1 - Enterprise

2 - RunTime

3 - Pro.

Access Read-Only.

Type VT_I4 or String.

Application.RecentFiles

Returns the RecentFiles collection that represents the list of last recent files used (File menu in UI).

Access Read-only.

Type VT_DISPATCH or RecentFiles.

Application.SharedOwner

Retrieves shared owner.

Access Read-only.

Type VT_DISPATCH.

Application.Top

Returns or sets the distance between the top edge of the main window of the application and the top edge of the screen (in pixel unit).

Access Read/Write.

Type VT_I4 or Long.

Application.UserControl

True if the application was created by the user.

False if the application was created in programming (with the CreateObject or GetObject method in Visual Basic).

Access Read-Only.

Type VT_BOOL or Boolean.

Application.UseUserInterface

Show or hide the dialog boxes interfaces that are masked in ActiveX invisible mode.

Access Read/Write.

Type VT_BOOL or Boolean.

Application.Version

Returns the software version number.

Access Read-Only.

Type VT_BSTR or String.

Application.Visible

True if the application is visible. (Default: False, if application was launched with CreateObject).

Access Read/Write.

Type VT_BOOL or Boolean.

Application.Width

Returns or sets the width of the main window of the application (in pixel unit).

Access Read/Write.

Type VT_I4 or Long.

Object Methods

Application.DocumentStatus

VT_BSTR or String DocumentStatus (DocName)

Returns the date of last version of the document (stored on hard drive or LabelArchive database)

Application.ErrorMessage

VT_BSTR or String ErrorMessage( intErrorCode )

Returns the string message error associated with the error code parameter.

Return value: Message associated.

Parameters: intErrorCode Required VT_I2 or Integer. Error code to process.

Application.FormatSystem

VT_DISPATCH or FormatSystem

Return the FormatSystem.

Application.GetLastError

VT_I2 or Integer GetLastError()

Returns the last error code generated.

Return value: Error code (see Error code table below).

Parameters: None.

Error code table

No error | 0
Can't open TXT file | 1100
Can't open QRY file | 1101
Can't open DSC file | 1102
Can't open LAB file | 1103
Can't open POC file | 1104
Can't open LOG file | 1105
Can't open data file | 1200
Can't open query file | 1201
Can't open descriptor file | 1202
Can't open label file | 1203
Can't open POC file | 1204
Can't open log file | 1205
Can't open BACKGROUND file | 1208
Printer not found | 1300
Driver not found | 1301
Printlabel not supported with several document. | 1302
Incorrect Datasource enum value | 1400
Incorrect Rotation enum value | 1401
Incorrect HRAlign enum value | 1402
Incorrect HRPosition enum value | 1403
Incorrect HR check digit enum value | 1404
Incorrect Anchor point enum value | 1405
Incorrect counter base enum value | 1406
Incorrect Label object enum value | 1407
Incorrect view size enum value | 1408
Incorrect view mode enum value | 1409
Incorrect MeasureSystem enum value | 1410
Incorrect dialog type enum value | 1411
Incorrect language enum value | 1412
Incorrect symbology enum value | 1413
Incorrect built in document property enum value | 1414
Incorrect view orientation enum value | 1415
Incorrect form prompt mode enum value | 1416
Object not found | 1500
Can't create object | 1501
Variable not found | 1502
Can't create variable | 1503
Invalid font object | 1504
Invalid variable object | 1505
Name of item already used | 1506
Property dependency failed | 1507
Database not connected | 1600
Database connection failed | 1601
TableLookup DSN not found | 1602
Input mask not empty | 1700
Invalid data | 1701
Your counter value is outside of the allowed value range | 1702
Superimposing is not allowed for some objects. | 1703
Error during the change of base. | 1704
Shared variable violation | 1800
Can't generate POC file | 1900
Number must be positive | 2000
Data type must be a boolean | 2001
Invalid path | 2002
File already exists | 2003
Can't prompt dialog box (no active document) | 2100
Not sufficient access rights to perform this operation | 3000

Application.LabelArchive

VT_DISPATCH LabelArchive()

Returns an LabelAchive interface.

Application.Lock

VT_BOOL or Boolean Lock(Key)

P arameters:

Key Required VT_BSTR or String

If ''Lock'' mode is activated, then Load, Save and Print (a label) will be disabled by default.

If no key is found, the new key locks the application and return TRUE.

If a key exists, this method returns FALSE.

Application.Move

VT_NONE Move( longposLeft, longposTop)

Moves the application window to the specified position (posLeft, posTop), in pixel unit.

Parameters:
longposLeft Required VT_I4 or Long. Sets the distance between the left edge of the main window of the application and the left edge of the screen(in pixel unit).

longPosTop Required VT_I4 or Long. Sets the distance between the top edge of the main window of the application and the top edge of the screen (in pixel unit).

Application.PrinterSystem

Returns the PrinterSystem object that represents all printers in the system.

Access Read-only.

Type VT_DISPATCH or PrinterSystem.

Application.Quit

VT_NONE Quit( )

Quits the current application. No effect if the application has been launched manually. First executes a Document.CloseAll (False) then releases the application.

Note : If events notification is enabled, it should be disabled before quitting:

Application.EnableEvents(False)

Application.Resize

VT_NONE Resize( longWidth, longHeight)

Resizes the application window (Width, Height), in pixel unit.

Parameters:
longWidth Required VT_I4 or Long. Sets the width of the main window of the application (in pixel unit).

longHeight Required VT_I4 or Long. Sets the height of the main window of the application (in pixel unit).

Application.ShowHelp

VT_NONE ShowHelp(strHelpFile, longHelpContext)

This method activates a help file.

Parameters:
strHelpFile Optional VT_BSTR or String. Specifies the help file to open (.HLP or .CHM). If not specified, associated help file is opened.

longHelpContextOptional VT_I4 or Long. Specifies the id context to jump to. If not specified, general index is prompted.

Application.Unlock

VT_BOOL or Boolean Lock(Key)

P arameters:

Key Required VT_BSTR or String

If the key does is not the last key word, the method returns FALSE and the application stays locked.

If the key matches the last key word, the method returns TRUE and the application is unlocked (print/save/load are activated).


Application Events

Properties | Methods
(None) | Close
 | DocumentClosed
 | DocumentOpened
 | Quit

Object Methods

ApplicationEvent.Close

VT_NONE Close ().

Informs that a user has closed the application.

ApplicationEvent.DocumentClosed

VT_NONE DocumentClosed (strDocTitle ).

Informs that the document with title strDocTitle has been closed.

Parameters:
strDocTitle VT_BSTR or String Title of the document closed.

ApplicationEvent.DocumentOpened

VT_NONE DocumentOpened (strDocTitle ).

Generates the name of the document opened (strDocTitle ).

Parameters:
strDocTitle VT_BSTR or String Title of the document opened.

ApplicationEvent.Quit

VT_NONE Quit ().

Informs users when someone quits the application with Application.Quit method or if the user has manually closed the application.


Background Object

Properties | Methods
Alignment | LoadFromStream
Enabled | (Stream As IUnknown)
FileName |
Linked |
Printed |
Rotation |
Stretched |

Object Properties

Background.Alignment

Return or set the alignment mode for label background picture :

- 0 : Left or Top

- 1 : Centered

- 2 : Right or Bottom

Access Read/Write.

Type VT_I4 or Long.

Background.Enabled

Return or set the enabled state of the label background.

Access Read/Write.

Type VT_BOOL or Boolean.

Background.FileName

Return or set the file name of the label background.

Access Read/Write.

Type VT_BSTR or String.

Background.Linked

Return or set the linked mode for label background picture, if TRUE the picture is embedded in the document and it

increases her size.

Access Read/Write.

Type VT_BOOL or Boolean.

Background.Printed

Return or set the printed state for label background picture.

Access Read/Write.

Type VT_BOOL or Boolean.

Background.Rotation

Return or set the rotation for label background picture (0-900-1800-2700).

Access Read/Write.

Type VT_I4 or Long.

Background.Stretched

Return or set the stretched mode for label background picture.

Access Read/Write.

Type VT_BOOL or Boolean.

Object Methods

Background.LoadFromStream(Stream As IUnknown)

Loads a picture stored in an IStream object, in this case the picture is systematically embedded.

Type VT_BOOL or Boolean.


Barcodes Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

Barcodes.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Barcodes.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Barcodes.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Barcodes.Add

VT_DISPATCH or Barcode Add( strBarcodeName ).

Adds a new Barcode object to the collection.

Return value: Returns a Barcode object.

Parameters:
strBarcodeName Optional VT_BSTR or String. The name of the object to add.

Barcodes.Item

VT_DISPATCH or Barcode Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note: If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note: If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. The following two lines of code are equivalent.
Object.Barcodes (1)
Object.Barcodes.Item(1)

Barcodes.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Barcode Object

Properties | Methods
DocObject object properties | DocObject object methods
AllowSuperimposing | Is2D
BarHeight Backmode |
CheckMode |
CheckValue |
Code2D |
Device |
HRAlignment |
HRCheckCharacter |
HRDevice |
HRGS1Norm |
HRFont |
HRFreeTextObject |
HRGap |
HROutputMask |
HRPosition |
Layers |
NarrowBarWidth |
NarrowBarWidthDot |
Ratio |
Symbology |
Value |
VariableName |
VariableObject Visible |

Object Properties

Barcode.AllowSuperimposing

Returns or sets the AllowSuperimposing option.

Access Read/Write.

Type VT_BOOL or Boolean.

Barcode.BarHeight

Retrieves or sets the bar height of the barcode (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Shape.Backmode

Allows for the transparency of the Background

Transparent = 1

Opaque = 2

Barcode.CheckMode

Retrieves or sets the check control of the barcode (in enumCheckMode type).

Access Read/Write.

Type VT_I2 or Long or enumCheckMode type.

Barcode.CheckValue

Retrieves the check digit value.

Access Read-Only.

Type VT_BSTR.

Barcode.Code2D

Retrieves the Code2D object for 2D barcodes.

Access Read-Only.

Type VT_DISPATCH or Code2D object.

Barcode.Device

Determines if the barcode is graphical or generated by the printer.

Access Read/Write.

Type VT_BOOL or Boolean.

Barcode.HRAlignment

Retrieves or sets the current human readable alignment.

Access Read/Write.

Type VT_I2 or Long or enumAlignment type.

Barcode.HRCheckCharacter

Includes or not the check character control in the human readable.

Access Read/Write.

Type VT_BOOL or Boolean.

Barcode.HRDevice

Determines if the human readable is printer generated or not.

Access Read/Write.

Type VT_BOOL or Boolean.

Barcode.HRFont

Retrieves or sets the font of the human readable.

Access Read/Write.

Type VT_FONT or StdFont object.

Barcode.HRFreeTextObject

Retrieves the Text object representing the text of the human readable.

Access Read-Only.

Type VT_DISPATCH or Text object.

Barcode.HRGS1Norm

Returns or sets the HRGS1Norm option.

Access Read/Write.

Type VT_BOOL or Boolean.

Barcode.HRGap

Retrieves or sets the gap between the barcode and its human readable (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Barcode.HROutputMask

Defines the format of the Output mask for the human readable.

Access Read/Write.

Type VT_BSTR.

Barcode.HRPosition

Sets or retrieves the position of the human readable.

Access Read/Write.

Type VT_I2 or Long or enumHRPosition type.

Barcode.Layers

This property allows to define the layers where the barcode object is visible.

Access Read/Write.

Type VT_I4 or EnumLayer.

Barcode.NarrowBarWidth

Retrieves or sets the narrow bar width of the barcode (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Barcode.NarrowBarWidthDot

Retrieves or sets the narrow bar width of the barcode in dot unit.

Access Read/Write.

Type VT_I4 or Long.

Barcode.Ratio

Retrieves or sets the ratio of the barcode (between 20 and 35).

Access Read/Write.

Type VT_I2 or Long.

Barcode.Symbology

Retrieves or sets the symbology of barcode.

Access Read/Write.

Type VT_I2 or Long or enumSymbology type.

Note:
Depending on the product, not all symbologies are available.

Barcode.Value

Retrieves or sets the value of the barcode.

Access Read/Write.

Type VT_BSTR or String.

Barcode.VariableName

Retrieves or sets the current variable name associated with the barcode.

Access Read/Write.

Type VT_BSTR or String.

Barcode.VariableObject

Retrieves or sets the current Variable object associated with the barcode.

Access Read only

Type VT_DISPATCH or Variable object.

Barcode.Visible

Allows to have object Visible or Not on the label.

This was made for internal use of Wizard : when you start create an object with the wizard, it is not visible on user interface.

Access Read/Write.

Type VT_BOOL or Boolean.

Object Methods

Barcode.Is2D

True if the barcode is 2D else returns False.

Access Read-Only

Type VT_BOOL or Boolean


Code2D Object

Properties | Methods
Columns | GetOption
ECC | SetOption
ModuleX |
ModuleXdot |
ModuleY |
ModuleYdot |
OptionsAvailable |
Rows |

Object Properties

Code2D.Columns

Sets or retrieves the column count of the following current 2D code: MicroPDF, PDF, Datamatrix, Codablock A and F (available only when ConstructionMode = 1).

Access Read/Write.

Type VT_I4 or Long.

Code2D.ECC

Sets or retrieves the Security attribute of the following current 2D code: PDF, Datamatrix and QR Code (see annexes).

For PDF: 0 to 8.
For Datamatrix: 0, 50, 80, 100, 140, 200.
For QR Code: L, M, Q, H.

Access Read/Write.

Type VT_BSTR or String.

Code2D.ModuleX

Sets or retrieves the thickness of the ModuleX attribute of the following current 2D code: MicroPDF, PDF, Datamatrix, QR Code,Codablock A and F, RSS and Composite (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Code2D.ModuleXDot

Sets or retrieves the thickness in dot of the ModuleX attribute of the 2D code.

Access Read/Write.

Type VT_I4 or Long.

Code2D.ModuleY

Sets or retrieves the thickness of the ModuleY attribute of the following current 2D code: MicroPDF, PDF, Codablock A and F (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Code2D.ModuleYDot

Sets or retrieves the thickness in dot of the ModuleY attribute of the 2D code.

Access Read/Write.

Type VT_I4 or Long.

Code2D.OptionsAvailable

Returns a Strings collection of options available for this 2D barcode.

A ccess Read-Only.

Type VT_DISPATCH or IDispatch.

Code2D.Rows

Sets or retrieves the row count of the following current 2D code: MicroPDF, PDF, Codablock A and F (available only when ConstructionMode = 1).

Access Read/Write.

Type VT_I4 or Long.

Object Methods

Code2D.GetOption

VT_VARIANT Code2D.GetOption( strOptionName).

Option | StrOptionName | Type | Code 2D | Comment
Space Correction (Width) | SpaceCorrectionWidth | VT_I2 | micro PDF PDF RSS Composite |
Space Correction (Height) | SpaceCorrectionHeight | VT_I2 | micro PDF PDF RSS Composite | For RSS: available only for RSS 14 Stacked, stacked Omnidirectional and Expanded.
Construction Mode | ConstructionMode | VT_I2 | micro PDF PDF Datamatrix QRCode CodaBlock A-F (01) | In enumonstructionMode type For Maxicode: 0 : 2 1 : 3 2 : 4 3 : 5 4 : 6 For the others: 0: Automatic sizing 1: Set size 2: Automatic density
Width (mm) | WidthDensity | VI_I4 | micro PDF PDF Datamatrix | Available only when ConstructionMode = 2
Height (mm) | HeightDensity | VI_I4 | micro PDF PDF Datamatrix | Available only when ConstructionMode = 2
Truncated Mode | TruncatedMode | VT_BOOL | PDF |
Aspect Ratio | AspectRatio | VT_I2 | PDF | In enumAspectRatio type 0:”1/1” 1:”1/2” 2:”1/3” 3:”1/4” 4:”1/5” 5:”2/1” 6:”2/3” 7:”3/1” 8:”3/2” 9:”3/4” 10:”4/1” 11:”4/3”
CharaterSet | DataFormat | VT_I2 | Datamatrix | In enumDataFormat type 0:[1] 1..9 ’ ’ (500c) 1:[2] A..Z ’ ’ (500c) 2:[3] A..Z 1..9 ’ ’ , . - / (500c) 3:[4] A..Z 1..9 ’ ’ (500c) 4:[5] ASCII 128 Keyboard (500c) 5:[6] ISO 8-Bit International (500c)
Model | Model | VT_I2 | QR Code | In enumModel typeFor QRCode : 0: Model 1 1: Model 2 For RSS: 0=RSS_14, 1=RSS_14STACKED 2=RSS_14STACKEDOMNI 3=RSS_14LIMITED 4=RSS_EXTENDED 5=RSS_14TRUNCATED For COMPOSITE: 0=RSS_14, 1=RSS_14STACKED 2=RSS_14STACKEDOMNI 3=RSS_14LIMITED 4=RSS_EXTENDED 5=RSS_14TRUNCATED 6 = UPC-E 7 = EAN-13 8 = EAN-8 9 = UCC EAN128 CC-A , CC-B 10 = UCC EAN128 CC-C 11 = UPC-A 12 = EAN-13 EXT2 13 = EAN-13 EXT5 14 = EAN-8 EXT2 15 = EAN-8 EXT5 16 = UPC-A EXT2 17 = UPC-A EXT5 18 = UPC-E EXT2 19 = UPC-E EXT5 For TLC39 : 0: AUTO 1: MICRO_4x4 2: MICRO_4x6 3: MICRO_4x8 4: MICRO_4x10 5: MICRO_4x12 6: MICRO_4x15 7: MICRO_4x20 8: MICRO_4x26 9: MICRO_4x32 10: MICRO_4x38 11: MICRO_4x44
Start Mode | StartMode | VT_I2 | QR Code | In enumStartMode type 0:Automatic 1:Numeric 2:Alpha 3:Kanji 4:Binary
Segment per row | SegmentPerRow | VT_I2 | RSS Composite | Available only for RSS Expanded
Separator Row Height | SeparatorRowHeight | VT_I4 | RSS Composite | RSS: only available if stacked, Omnidirectionnal or Expanded.
Reader Initialisation Symbol | ReaderInitialisationSymbol | VT_BOOL | Aztec Aztec Mesa |
Barrier Symbol | BarrierSymbol | VT_BOOL | Aztec Mesa |
Symbology host | SymbologyHost | VT_I2 | Aztec Mesa | For Aztec Mesa 0 : CODE 39 1 : CODE 93 2 : CODE 128 3 : INTERLEAVED 2/5 4 : INTERLEAVED 2/5 with barrier 5 : EAN/JAN-13
Symetry Configuration | SymetryConfiguration | VT_BOOL | Aztec Mesa | 0: One sided 1: Two sided
Compression | Compression | VT_I4 | Vericode | For Vericode 0: None 1: 4 bits 2: 6 bits
Left Oriented | LeftOriented | VT_BOOL | Pharmacode |
Vertically Flip | VerticallyFlip | VT_BOOL | Pharmacode |

See Also 2D Code Appendix

Note:
For Maxicode, options ZipCode, ZipCodeExtend, CountryCode, Segment per row must be included in the data.
Constructing a Maxicode in modes 2 and 3.
If you wish to create a Maxicode, the data must follow the structure below.
Concatenation of the four data:
ZipCode&CountryCode&ServiceClass&.ServiceClass, with:
ZipCode: nine characters long (completed with spaces if the length is less than nine characters).
CountryCode: three characters long.
ServiceClass: three characters long.
Data: 84 characters long max.

Code2D.SetOption

VT_NONE Code2D.SetOption( strOptionName, varOptionValue).

Sets option of the current 2D code.

Parameters:
strOptionName Required VT_BSTR or String. Name of the option to set.

varOptionValue Required VT_VARIANT or Variant. Value of the option to set.


2D Barcode properties Appendix

This board defines the existing 2D barcode properties depending the barcode symbology

Properties | Type | µPDF | PDF | DATA MATRIX | QR CODE | MAXI CODE | Coda BlocK A - F | RSS | Composite | Aztec & Aztec Mesa | TLC39 |
ModuleY | VT_I2 | X | X | - | - | - | X | - | - | - | X | In MeasureSystem unit
ModuleX | VT_I2 | X | X | X | X | - | X | X | X | X | X | In MeasureSystem unit
ModuleYDot | VT_I2 | X | X | - | - | - | X | - | - | - | X | In printer dots
ModuleXDot | VT_I2 | X | X | X | X | - | X | X | X | X | X | In printer dots
Columns | VT_I2 | X | X | X | - | - | X | - | - | - | - | Available only when ConstructionMode = 1
Rows | VT_I2 | X | X | - | - | - | X | - | - | - | - | Available only when ConstructionMode = 1
ECC (Security level) | VT_BSTR | - | X | X | X | - | - | - | - | X | - | PDF : 0 to 8 Datamatrix : 0,50,80,100,140,200 QR Code : L,M,Q,H AZTEC : Default Percent 1 to Percent 99 : 1 to 99 Percent Compact 1 to Compact 4 : 1 to 4 compact layers Range 1 to Range 32: 1 to 32 Range layers Rune : Rune AZTEC MESA : Default Percent 1 to Percent 99: 1 to 99 Percent Range 1 to Range 32: 1 to 32 Range layers

This board defines the strOptionName available to use with the SetOption and GetOption methods.

Option | StrOption Name | Type | PDF | PDF | Data matrix | QR Code | Maxi Code | Coda BlocK A - F | RSS | Composite | Aztec | Aztec Mesa | TLC39 | Code One | Comment
Symbols | Symbols | VT_I2 | - | - | - | - | - | - | - | - | X | X | - | - |
Version | Version | VT_I2 | - | - | - | - | - | - | - | - | - | - | - | X | Available for Code One barcode. Possible values: 0÷13 (versions A,…,H, S-10, S-20, S-30, T-16, T-32, T-48).
Space Correction (Width) | Space CorrectionWidth | VT_I2 | X | X | - | - | - | - | X | X | - | - | - | - |
Space Correction (Height) | Space CorrectionHeight | VT_I2 | X | X | - | - | - | - | X | X | - | - | - | - | For RSS : Available only for RSS 14 Stacked , stacked Omnidirectional and Expanded.
Construction Mode | ConstructionMode | VT_I2 | X | X | X | X | - | X (01) | - | - | - | - | - | - | In enumConstructionMode type For maxicode : 0 : 2 1 : 3 2 : 4 3 : 5 4 : 6 For the others : 0:Automatic sizing 1:Set size 2:Automatic density
Width (mm) | Width Density | VI_I4 | X | X | X | - | - | - | - | - | - | - | - |  | Available only when ConstructionMode =2
Height(mm) | Height Density | VI_I4 | X | X | X | - | - | - | - | - | - | - | - |  | Available only when ConstructionMode =2
Truncated Mode | TruncatedMode | VT_BOOL | - | X | - | - | - | - | - | - | - | - | - | - |
Aspect Ratio | Aspect Ratio | VT_I2 | - | X | - | - | - | - | - | - | - | - | - | - | For PDF : In enumAspectRatio type 0: "1/1"; 1: "1/2"; 2: "1/3"; 3: "1/4"; 4: "1/5"; 5: "2/1"; 6: "2/3"; 7: "3/1"; 8: "3/2"; 9: "3/4"; 10: "4/1"; 11: "4/3";
Character Set | DataFormat | VT_I2 | - | - | X | - | - | - | - | - | - | - | - | - | In enumDataFormat type 0:[1] 1..9 ' ' (500c) 1:[2] A..Z ' ' (500c) 2:[3] A..Z 1..9 ' ' , . - / (500c) 3:[4] A..Z 1..9 ' ' (500c) 4:[5] ASCII 128 Keyboard (500c) 5:[6] ISO 8-Bit International (500c)
Model | Model | VT_I2 | - | - | - | X | - | - | X | X | - | - | X | - | In enumModel type For QRCode : 0 : Model 1 1 : Model 2 For RSS : 0=RSS_14, 1=RSS_14STACKED 2=RSS_14STACKEDOMNI 3=RSS_14LIMITED 4=RSS_EXTENDED 5=RSS_14TRUNCATED For COMPOSITE : 0=RSS_14, 1=RSS_14STACKED 2=RSS_14STACKEDOMNI 3=RSS_14LIMITED 4=RSS_EXTENDED 5=RSS_14TRUNCATED 7 = EAN13 8 = EAN8 9 = UCC EAN128 CC-A , CC-B 10 = UCC EAN128 CC-C For TLC39 : 0: AUTO 1: MICRO_4x4 2: MICRO_4x6 3: MICRO_4x8 4: MICRO_4x10 5: MICRO_4x12 6: MICRO_4x15 7: MICRO_4x20 8: MICRO_4x26 9: MICRO_4x32 10: MICRO_4x38 11: MICRO_4x44
Start Mode | StartMode | VT_I2 | - | - | - | X | - | - | - | - | - | - | - | - | In enumStartMode type 0:Automatic 1:Numeric 2:Alpha 3:Kanji 4:Binary
Segment per row | Segment per row | VT_I2 | - | - | - | - | - | - | X | X | - | - | - | - | Available only for RSS Expanded.
Separator Row Height | Separator Row Height | VT_I4 | - | - | - | - | - | - | X | X | - | - | - | - | RSS : Only available if stacked , Omnidirectionnal or Expanded.
Reader Initialisation symbol | ReaderInitialisationSymbol | VT_BOOL | - | - | - | - | - | - | - | - | X | X | - | - |
Barrier symbol | BarrierSymbol | VT_BOOL | - | - | - | - | - | - | - | - | - | X | - | - |
Symbology host | SymbologyHost | VT_I2 | - | - | - | - | - | - | - | - | - | X | - | - | 0 : CODE 39 1 : CODE 93 2 : CODE 128 3 : INTERLEAVED 2/5 4 : INTERLEAVED 2/5 with barrier 5 : EAN/JAN-13
Symetry configuration | SymetryConfiguration | VT_BOOL | - | - | - | - | - | - | - | - | - | X | - | - | 0 : One sided 1 : Two sided

Note: for Maxicode , options ZipCode, ZipCodeExtend, CountryCode, Segment per row must be include in the data.

Constructing a Maxicode in modes 2 and 3

If you wish to create a Maxicode, the data must respect the following structure: concatenation of the four datas

ZipCode: nine characters long (completed with spaces if the length is less than nine characters)
CountryCode: three characters long
ServiceClass: three characters long
Data: 84 characters long

ZipCode&CountryCode&ServiceClass&Data


Counters Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

Counters.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Counters.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Counters.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Counters.Add

VT_DISPATCH or Counter Add( strCounterName ).

Adds a new Counter object to the collection.

Return value: Returns a Counter object.

Parameters:
strCounterName Optional VT_BSTR or String. The name of the object to add.

Counters.Item

VT_DISPATCH or Counter Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.Counters(1)
Object.Counters.Item(1)

Counters.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Counter Object

Properties | Methods
Variable object properties | Variable object methods
AccumulatorFile | DisplayValue
BaseType |
CustomSet |
DecimalSeparator |
DecimalUse |
IncludeInLogFile |
Increment |
ISO |
LabelCopies |
MaxValue |
NumberOfDecimals |
OutputMask |
PadCharacter |
Prefix |
ResetToValue |
SharedCounter |
Suffix |
ThousandSeparator |
TriggerMode |
TriggerParameter |
ValuesInDecimalBase |

Object Properties

Counter.AccumulatorFile

Sets or retrieves the "Accumulator file" name inherited from counter.

Access Read/Write.

Type VT_BSTR or String.

Counter.BaseType

Sets or retrieves the counting base used for counting.

Access Read/Write.

Type VT_I2 or Integer or enumCounterBase type.

Counter.CustomSet

Sets or retrieves the characters list of the custom counter
(ex: « 0123456789ABCD »).

The first element must be the neutral element.

Access Read/Write.

Type VT_BSTR or String.

Counter.DecimalSeparator

Sets or retrieves the decimal separator.

Access Read/Write.

Type VT_BSTR or String.

Counter.DecimalUse

Uses or not decimal formatting.

Access Read/Write.

Type VT_BOOL or Boolean.

Counter.IncludeInLogFile

True if this object is stored in the report file.

Access Read/Write.

Type VT_BOOL or Boolean.

Counter.Increment

Sets or retrieves the increment.

Access Read/Write.

Type VT_VARIANT or Variant.

Counter.ISO

Uniquely numbers each copy of a label.

Access Read/Write.

Type VT_BOOL or Boolean.

Counter.LabelCopies

Sets or retrieves the number of label to be printed before to increment the counter.

Access Read/Write.

Type VT_BOOL or Boolean.

Counter.MaxValue

Sets or retrieves the Max value of the current object.

When reached, this value will trigger a reset of the counter.

Access Read/Write.

Type VT_VARIANT or Variant.

Counter.NumberOfDecimals

Sets or retrieves the number of digits after the decimal point.

Access Read/Write.

Type VT_I2 or Integer.

Counter.OutputMask

Sets or retrieves the "output format"

Access Read/Write.

Type VT_BSTR or String.

Counter.PadCharacter

Sets or returns the character used to pad the left of variable value.

Access Read/Write.

Type VT_BSTR or String.

Note:
For remove PadCharacter set NULL value.

Counter.Prefix

Sets or retrieves the prefix string added to the variable.

Access Read/Write.

Type VT_BSTR or String.

Counter.ResetToValue

Sets or retrieves the reset value.

Access Read/Write.

Type VT_VARIANT or Variant.

Counter.SharedCounter

True if the object value is shared.

Access Read/Write.

Type VT_BOOL or Boolean.

Counter.Suffix

Sets or retrieves the suffix string added to the variable.

Access Read/Write.

Type VT_BSTR or String.

Counter.ThousandSeparator

Sets or retrieves the thousand separator.

Access Read/Write.

Type VT_BSTR or String.

Counter.TriggerMode

Sets the Increment method:

Access Read/Write.

Type VT_I4 or Long or enumTriggerMode type.
(Default set to lppxNumberOfPrintedLabels)

Counter.TriggerParameter

Sets the parameter for the trigger mode.

Access Read/Write.

Type VT_VARIANT or Variant.

Note:
Can be the number of labels printed or the name of an other counter.

By default, it is the number of labels printed with a value set to 1.

Counter.ValuesInDecimalBase

Sets or retrieves if counter is in Decimal base

Access Read/Write.

Type VT_BOOL or Boolean.

Object Methods

Counter.DisplayValue

VT_BSTR (R only)

Returns the display value


DatabaseVariables Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

DatabaseVariables.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

DatabaseVariables.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

DatabaseVariables.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

DatabaseVariables.Add

VT_DISPATCH or Free Add( strFreeName ).

Adds a new Free object to the collection with database attribute.

Return value: Returns a Free object.

Parameters:
strFreeName Optional VT_BSTR or String. The name of the object to add.

DatabaseVariables.Item

VT_DISPATCH or Free Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.DatabaseVariables(1)
Object.DatabaseVariables.Item(1)

DatabaseVariables.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Database Object

Properties | Methods
Application | Close
ConnectionString | MoveFirst
CreatingVariables | MoveLast
BOF | MoveNext
EOF | MovePrevious
IsOpen | OpenASCII
Parent | OpenODBC
QueryFileName | OpenQuery
QueryString | Refresh
 | Find

Object Properties

Database.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Database.ConnectionString

Returns the string describing the current database connection.

Access Read-Only.

Type VT_BSTR or String.

Database.CreatingVariables

Automatic creation of database variables when database connects. (Default: True).

Access Read/Write.

Type VT_BOOL or Boolean.

Database.BOF

Returns a value that indicates whether the current row position is before the first row in the current recordset.

Return value:
True The current row position is before the first row.
False The current row position is on or after the first row.

Access Read-Only.

Type VT_BOOL or Boolean.

Database.EOF

Returns a value that indicates whether the current row position is after the last row in the current recordset.

Return value:
True The current row position is after the last row.
False The current row position is on or before the last row.

Access Read-Only.

Type VT_BOOL or Boolean.

Database.IsOpen

Tests if the Database object has been open successfully.

Access Read-Only.

Type VT_BOOL or Boolean.

Database.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Database.QueryFileName

Returns the name of the query file used.

Access Read-Only.

Type VT_BSTR or String.

Database.QueryString

Returns the string defining the current query.

Access Read-Only.

Type VT_BSTR or String.

Object Methods

Database.Close

VT_NONE Close().

Closes an open database.

Database.MoveFirst

VT_BOOL or Boolean MoveFirst().

Repositions the current row pointer in the first row of the current recordset and makes that row the current row.

Database.MoveLast

VT_BOOL or Boolean MoveLast().

Repositions the current row pointer in the last row of the current recordset object and makes that row the current row.

Database.MoveNext

VT_BOOL or Boolean MoveNext().

Repositions the current row pointer in the next row of the current recordset object and makes that row the current row.

Database.MovePrevious

VT_BOOL or Boolean MovePrevious().

Repositions the current row pointer in the previous row of the current recordset object and makes that row the current row.

Database.OpenASCII

VT_BOOL or Boolean OpenASCII( strTextFileName, strDescriberFileName ).

Opens ASCII database.

Return value: Returns a boolean that indicates whether the opening fails or not.

Parameters:
strTextFileName Required VT_BSTR or String. The database text file.

strDescriberFileName Required VT_BSTR or string. Describer associated with the text file.

Database.OpenQuery

VT_BOOL or Boolean OpenQuery( strQueryFileName ).

Opens a CSQ query file.

Return value: returns a boolean that indicates whether the opening fails or not.

Parameters:
strQueryFileName Required VT_BSTR or String. The file which contains the query.

Database.OpenODBC

VT_BOOL or Boolean OpenODBC( strDatasourceConnexion, strQueryString ).

Opens an ODBC database.

Return value: Returns a boolean that indicates whether the opening fails or not.

Parameters:
strDatasourceConnexion Required VT_BSTR or String. The database string connection.

For the strDatasourceConnexion, only these parameters are available:"DSN=Identity;USER=Scott;PWD=tiger;Type=ODBC;Type=OLEDB;". If you need more information about these parameters, refer to Microsoft ODBC documentation .

Note: if the DSN type is not specified, ODBCis applied by default.

strQueryString Required VT_BSTR or String. SQL query.

Database.Refresh

VT_BOOL or Boolean Refresh( )

Refreshes the database.

Database.Find

VT_I4 or long Find(DatabaseFind As enumDatabaseFind, Field As String, Value As String)

Searches for a record in a database

Parameters:

DatabaseFind Required enumDatabaseFind. Specifies the search mode

Field Required VT_BSTR or String. The field to search.

Value Required VT_BSTR or String. The value of the field to serch.


Dates Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

Dates.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Dates.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Dates.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Dates.Add

VT_DISPATCH or Date Add( strDateName ).

Adds a new Date object to the collection.

Return value: Returns a Date object.

Parameters:
strDateName Optional VT_BSTR or String. The name of the object to add.

Dates.Item

VT_DISPATCH or Date Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.Dates(1)
Object.Dates.Item(1)

Dates.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Date Object

DateTime Object

Properties | Methods
Variable object properties | Variable object methods
Device | DisplayValue
IncludeInLogFile |
Format |
OffsetUnit |
OffsetValue |
OffsetVariableName |
OffsetVariableObject |
Type |

Object Properties

DateTime.Device

Determines if the date is generated by the printer or not.

Access Read/Write.

Type VT_BOOL or Boolean.

DateTime.IncludeInLogFile

True if this object is stored in the report file.

Access Read/Write.

Type VT_BOOL or Boolean.

DateTime.Format

Sets or retrieves the format of the value.

Access Read/Write.

Type VT_BSTR or String.

Can contain a prefix code which indicates country code:

Prefix Code | Country
(UK) | English(default)
(GE) | German
(IT) | Italian
(FR) | French
(SW) | Swedish
(SP) | Spanish
(CH) | Chinese
(DK) | Danish
(JP) | Japanese

Followed by the real format:

Commands | Value
'm' | month as 1...12
'mm' | month as 01¼12
'mmm' | month as Jan...Dec
'mmmm' | month as January...December
'd' | day of month as 1.31
'dd' | day of month as 01..31
'ddd' | day of week as 0..6 (0=Sunday, 1=Monday,...)
'dddd' | day of week as Sun...Sat
'ddddd' | day of week as Sunday...Saturday
'j' | Julian day as 1¼366
'jj' | Julian day as 001...366
'y' | year as 0...9
'yy' | year as 00¼99
'yyyy' | year as 1900...2040
'w' | week number as 1...53
'ww' | week number as 01...53
'h' | hour as 0...23
'hh' | hour as 00...23
'hhh' | hour as 0...12
'hhhh' | hour as 00..12
am|pm | am or pm
'n' | Minutes as 0¼59
'nn' | Minutes as 00...59
'c' | Separator (c = any non ambiguous character)
'ccc' | Separator string
's' | second as 0...59
'ss' | second as 00...59

DateTime.OffsetValue

Sets or retrieves the number of offset unit to add to the date.

Access Read/Write.

Type VT_I4 or Integer.

DateTime.OffsetVariableName

Sets or retrieves the name of the variable defining the number of Offset unit to add to the date (if OffsetType = 1).

Access Read/Write.

Type VT_BSTR or String.

DateTime.OffsetVariableObject

Sets or retrieves the variable defining the number of the Offset unit to add to the date (if OffsetType = 1).

Access Read/Write.

Type VT_DISPATCH.

DateTime.OffsetUnit

Sets or retrieves the unit:

0: minute

1: hour

2: day

3: month

Access Read/Write.

Type VT_I2 or Integer.

DateTime.Type

Sets or retrieves the Date Type

Access Read-Only.

Type VT_I2 or Integer or enumDateType type.

Object Methods

DateTime.DisplayValue

VT_BSTR (Read only)

Returns the display value


Dialogs Collection

Properties | Methods
Application | Item (Default)
Count |
Parent |

Object Properties

Dialogs.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only

Type VT_DISPATCH or Application object.

Dialogs.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Dialogs.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Dialogs.Item

VT_DISPATCH or Dialog Item( intIndex ).

Returns a member of a collection, by position.

Note: I f the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
intIndex Required VT_I2 or Integer or enumDialogType. The index number of a member of the collection.

The index must be a numeric expression (a number from 1 to the value of the collection’s Count property, or a constant.

Note: If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.Dialogs(1)
Object.Dialogs.Item(1)


Dialog Object

Properties | Methods
Application | Show
Attributes |
Parent |
Type |

Object Properties

Dialog.Application

Returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Dialog.Attributes

Sets extended options. Available for the LppxLasCheckout dialog box. One attribute can be set: LppxReadOnly.

Access Read and Write.

Type VT_I4 or Long or enumDialogType type.

Dialog.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Dialog.Type

Returns the type of the prompted dialog box.

Access Read-Only.

Type VT_I2 or Integer or enumDialogType type.

Object Methods

Dialog.Show

VT_I2 or Integer Show(VT_VARIANT varParent).

Prompts the dialog box associated.

Return value 1 if the user has clicked on OK.
2 if the user has clicked on Cancel.

Parameters:

HWND of parent

Note:
If application is not visible, dialog box is prompted at the top level of all windows.

If there is no document open, the dialog boxes (except Options dialog box) can’t be displayed because they depend on the document.


DocObjects Collection

Properties | Methods
Application | Add
Barcodes | Item (Default)
Count | Remove
Images |
OLEObjects |
Parent |
Shapes |
Texts |

Object Properties

DocObjects.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

DocObjects.Barcodes

Returns the Barcodes collection that represents all the created Barcode objects in the document.

Access Read-Only.

Type VT_DISPATCH or Barcodes collection.

DocObjects.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

DocObjects.Images

Returns the Images collection that represents all the created Image objects in the document.

Access Read-Only.

Type VT_DISPATCH or Images collection.

DocObjects.OLEObjects

Returns the OLEObjects collection that represents all the created OLEObject objects in the document.

Access Read-Only.

Type VT_DISPATCH or OLEObjects collection.

DocObjects.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

DocObjects.Shapes

Returns the Shapes collection that represents all the created Shape objects in the document.

Access Read-Only.

Type VT_DISPATCH or Shapes collection.

DocObjects.Texts

Returns the Texts collection that represents all the created Text objects in the document.

Access Read-Only.

Type VT_DISPATCH or Texts collection.

Object Methods

DocObjects.Add

VT_DISPATCH or DocObject Add( longDocObjectType, strDocObjectName ).

Adds a new DocObject object to the current document.

Return value: Returns a DocObject object.

Parameters:
longDocObjectType Required VT_I4 or Long or enumDocObject. The type of object to add.

strDocObjectName Optional VT_BSTR or String. The name of the object to add.

DocObjects.Item

VT_DISPATCH or DocObject Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note: If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note: If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.DocObjects (1)
Object.DocObjects.Item(1)

DocObjects.Remove

VT_NONE Remove( varIndex ).

Removes a member from the DocObjects object.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a collection member.

If numeric expression: index must be a number from 1 to the value of the collection’s Count property. If a string expression: index must correspond to the key argument specified when this member reffered to was added to the collection.


DocObject Object

Properties | Methods
AllowSuperimposing | Bound
AnchorPoint | GetFont
Application | Move
BackColor | ShowDialog
Data |
DataSourceNames |
ForeColor |
GetProperty |
GetPropertyID |
Height |
Layers |
Left |
LinkedBarcode |
Locked |
MarginLeft |
MarginRight |
MarginTop |
MarginBottom |
Name |
Parent |
Printable |
PropertyCount |
Refresh |
Rotation |
Top |
Type Visible |
Width |

Object Properties

DocObject.AllowSuperimposing

Returns or sets the AllowSuperimposing option

Access Read/Write.

Type VT_BOOL or Boolean.

DocObject.AnchorPoint

Returns or sets the anchor point of the current object.

Access Read/Write.

Type VT_I4 or Long or enumAnchorPoint type.

DocObject.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

DocObject.BackColor

This property returns or sets the backcolor of the Object.

Access Read/Write.

Type VT_I4 or long.

DocObject.Data

This property returns or sets the data of the Object.

Access Read/Write.

Type VT_BSTR or String.

DocObject.DataSourceNames

This property returns or sets the data source name of the Object.

Access Read/Write.

Type VT_BSTR or String.

DocObject.ForeColor

This property returns or sets the forecolor to the Object.

Access Read/Write.

Type VT_I4 or long.

DocObject.GetProperty (long nIndex)

Returns the DocObjectProperty object at the nIndex position or nothing if the nIndex is out of range.

Access Read-Only.

Type DocObjectProperty.

DocObject.GetPropertyID (long nID)

Returns the DocObjectProperty object referenced by the nID identifier or nothing if the identifier does not exist.

Access Read-Only.

Type DocObjectProperty.

DocObject.Height

Returns or sets the height of the object (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

DocObject.Layers

This property allows to define the layers where the object is visible (barcode, text, image, OLE, shape).

Access Read/Write.

Type VT_I4 or EnumLayer.

DocObject.Left

Returns or sets the distance between the left edge of the anchor point of the object and the left edge of the document (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

DocObject.LinkedBarcode

Returns the name of the barcode which contains a human readable free/advanced variable.

Access Read only.

Type VT_BSTR or String.

DocObject.Locked

True if the DocObject is locked (False by default).

Access Read/Write.

Type VT_BOOL or Boolean.

DocObject.MarginLeft

This property returns or sets the internal left margin of the Object.

Access Read/Write.

Type VT_I4 or long.

DocObject.MarginRight

This property returns or sets the internal right margin of the Object.

Access Read/Write.

Type VT_I4 or long.

DocObject.MarginTop

This property returns or sets the internal top margin of the Object.

Access Read/Write.

Type VT_I4 or long.

DocObject.MarginBottom

This property returns or sets the internal bottom margin of the Object.

Access Read/Write.

Type VT_I4 or long.

DocObject.Name

Returns or sets the name of the DocObject.

Access Read/Write.

Type VT_BSTR or String.

DocObject.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

DocObject.Printable

Sets or not whether the object is printable.

Access Read/Write.

Type VT_BOOL or Boolean.

DocObject.PropertyCount

Returns the count of the properties.

Access Read-Only.

Type VT_DISPATCH

DocObject.Refresh

Forces an update of the object aspect to reflect the new values properties.

Access Read/Write.

Type VT_EMPTY.

DocObject.Rotation

Sets or retrieves the rotation of the object.

Access Read/Write.

Type VT_I2 or Integer.

The value can be one of the following: 0, 900, 1800, 2700.

DocObject.Top

Returns or sets the distance between the top edge of the anchor point of the object and the top edge of the document. (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

DocObject.Type

Returns the type of the object (in enumDocObject type).

Access Read-Only.

Type VT_I2 or Integer.

DocObject.Visible

Allows to have object Visible or Not on the label. This was made for internal use of Wizard : when you start create an object with the wizard, it is not visible on user interface

Access Read/Write.

Type VT_BOOL or Boolean.

DocObject.Width

Returns or sets the width of the object (in enumMeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Object Methods

DocObject.Bound

VT_NONE Bound ( longLeftPosition, longTopPosition , longRightPosition , longBottomPosition).

Sets the bounding rectangle of an object.

Parameters:
longLeftPosition Required VT_I4 or Long. Distance between the left edge of an object
and the left edge of the document (in MeasureSystem unit).

longTopPosition Required VT_I4 or Long. Distance between the top edge of an object
and the top edge of the document (in MeasureSystem unit).

longRightPosition Required VT_I4 or Long. Distance between the right edge of an object
and the left edge ofthe document (in MeasureSystem unit).

longBottomPosition Required VT_I4 or Long. Distance between the bottom edge of an object
and the top edge of the document (in MeasureSystem unit).

DocObject.GetFont

VT_DISPATCH GetFont (Index)

Sets the default internal font for TextArt, ListField and RtfField objects.

Note: this font is totally different from the default text font or default barcode font!

Parameter:

Index Required VT_I4 or Long. The nIndex parameter can only be 0. The method returns a standard interface IFont (see MSDN).

The font size returned by the property "Size" of the interface is IFont expressed as "HiMetric" and not as "points".

DocObject.Move

VT_NONE Move (longLeftPosition, longTopPosition ).

Moves an object in its window.

Parameters:
longLeftPosition Required VT_I4 or Long. Distance between the left edge of an object
and the left edge of the document (in MeasureSystem unit).

longTopPosition Required VT_I4 or Long. Distance between the top edge of an object
and the top edge of the document (in MeasureSystem unit).

DocObject.ShowDialog

VT_BOOL ShowDialog(VT_VARIANT varParent).

Displays the DocObject dialog box with the current DocObject properties.


Documents Collection

Properties | Methods
Application | Add
Count | CloseAll
DefaultExt | Import
Parent | Item (Default)
 | Open
 | SaveAll SelectOpen

Object Properties

Documents.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Documents.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Documents.DefaultExt

This property returns the default document filename extension for the application.

Access Read-Only.

Type VT_BSTR or String.

Documents.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Documents.Add

VT_DISPATCH or Document Add(strDocumentName).

Adds a new Document to the collection.

Return value: Returns a Document object if succeeded.

Parameters:
strDocumentName Optional VT_BSTR or String. Specifies the name of the new document to add.
If none, system automatically assigns one.

Documents.CloseAll

VT_NONE CloseAll ( boolSaveChanges ).

Closes all documents.

Parameters:
boolSaveChanges Optional VT_BOOL or Boolean. Specifies the save action for all documents. (default: True).

If boolSaveChanges is True and a document has not been previously saved, the Saves As dialog box is automatically prompted.

NOTE: This method is asynchronous. A message is sent to document(s) to ask them to close. For this reason, the document(s) may not be closed right after the call of the method. A temporization could be used if necessary to wait that the document(s) are closed.

Documents.Import

VT_DISPATCH or Document Import(BSTRstrDocName, BSTR strFileExt).

Returns a dispatch on the converted document.

Parameters:
strDocName contains the full path and name of the document to be converted.
strFileExt contains the converter extension (for example : dpl, epl, zpl, ...).

Documents.Item

VT_DISPATCH or Document Item( varIndex ).

Returns a Document of a collection, either by position or by name.

Note: I f the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note: If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.Documents(1)
Object.Documents.Item(1)

Documents.Open

VT_DISPATCH or Document Open( strFileName, boolReadOnly ).

Opens the specified document and adds it to the Documents collection.

Uses the syntax "@:\Desktop\LaberlArchive\CategoryName\DocName.lab" to specify a stored document.

Using the syntax ”r;DocName.lab_1” you can also specify the version number 1 of the document.

For all documents protected with a password, you must enter a password to open the document. The syntax is : Open( " FileName= <label document path filename> ;Password= <admin or print only>", ReadOnly ). If this function succeeds, it return an IDocument interface.

Note: the password defines which account is being used.

Return value: Returns a Document object.

Parameters:
strFileName Required VT_BSTR or String. The name of the document (paths are accepted).

boolReadOnly Optional VT_BOOL or Boolean. True to open the document as read-only. By default, set to False.

Documents.SaveAll

VT_NONE SaveAll( boolAlwaysPrompt ).

Saves all the documents in the Documents collection.

If a document hasn’t been previously saved, the Save As dialog box is prompted even if the Prompt parameter is assigned to False.

Parameters:
boolAlwaysPrompt Optional VT_BOOL or Boolean. True if user wants to prompt the save dialog box (default: False).

Documents.SelectOpen

VT_DISPATCH or Document Select Open(PathName, hParent).

Parameters:

hParent Required VT_I4 or OLE_HANDLE

PathName Required VT_BSTR or String

Prompt a selection dialog box to precises whever the label must be open from file disk or LabelArchive.

Depending of the user choice, the system file dialog box or LabelArchive selection box is shown.

If this function succeeds, it return an IDocument interface.


Document Object

Properties | Methods
Application | Activate
AutoPageIncrement | AddHistory
Background | AddWatermark
BuiltInDocumentProperties | CheckIn
CauseForApproval | Close
Database | C opyImageToFile
DocObjects | CopyImageToFileEx
Format | CopyToClipboard
FullClippingMode | CopyToClipboardEx
FullName | EndPrintingReport
HorzprintOffset | FormFeed
IsModified | GetMetaFilepreview
KeepPrinterObjects | GetPreview
LayerPrinted | Insert
LayerShown | Merge
Name (Default) | PrintDocument
NeedsApproval | PrintLabel
NewRfTag | ReadVariables
Parent | Rotate
Printer | Save
PrintingOptimizationMode | SaveAs
ReadOnly | SelectDatabase
RefreshDatabaseBeforePrinting | WriteVariables
RefreshTableLookupBeforePrinting |
RfTag |
RfTagList |
SelectedDocObjects |
TriggerForm |
Variables |
Version |
VertPrintOffset |
ViewMode |
ViewOrientation |
ViewZoom |
Visible |
WindowsGraphicalEmulation |
WindowState |

Object Properties

Document.Application

Returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application Object.

Document.AutoPageIncrement

True by default

If False, allows to print the last label of a page without incrementing the page (switch to next page).

Access Read/Write.

Type VT_BOOL or Boolean.

Document.Background

Returns the Background object associated with the document.

Access Read-Only.

Type VT_DISPATCH or Background.

Document.BuiltInDocumentProperties

Returns the DocumentProperties collection that represents document properties.

Access Read-Only.

Type VT_DISPATCH or DocumentProperties collection.

Document.CauseForApproval

Returns the cause for approval message.

Access Read-Only.

Type VT_BSTR or String.

Document.Database

Returns the Database object associated with the document.

Access Read-Only.

Type VT_DISPATCH or Database object.

Document.DocObjects

Returns the DocObjects collection that represents all the created objects in the document.

Access Read-Only.

Type VT_DISPATCH or DocObjects object.

Document.Format

Returns the Format object that represents the format of the document.

Access Read-Only.

Type VT_DISPATCH or Format object.

Document.FullClippingMode

Allows graphic Text and Barcode to be clipped when partially outside of the label.

Access Read / Write

Type VT_BOOL or Boolean

Document.FullName

Returns the file specification for the document, including the path.

Access Read-Only.

Type VT_BSTR or String.

Ex : c:\drawdir\scribble.

Document.HorzPrintOffset

Sets or returns the horizontal Print offset.

Access Read/Write.

Type VT_I4 or Long.

Document.IsModified

Tests that the document has been modified since the last save operation.

Access Read-Only.

Type VT_BOOL or Boolean.

The possible modifications are : creating, deleting and editing DocObjects; creating and deleting variables...

Document.KeepPrinterObjects

Valid only when WindowsGraphicalEmulation is enabled, when this property is TRUE, texts and barcodes printer objects are sent with printer's commands.
Access Read/Write.
Type VT_BOOL or Boolean.

Document.LayerPrinted

Returns the printed layer mask. Each printed layer will generate one label.

Access Read/Write.

Type VT_I4 or EnumLayer.

Document.LayerShown

Returns the layer(s) displayed in the view.

Access Read/Write.

Type VT_I4 or EnumLayer.

Note: OR is used to display two or more layers.

Document.Name

Returns the document name. Default property.

Access Read-Only.

Type VT_BSTR or String.

Document.NeedsApproval

Controls the approval flag.

Access Read-Only.

Type VT_BOOL or Boolean.

Document.NewRfTag (IDRfTag As enumRfTagID, Reserved As long)

Creates new RfTag object defined by the IDRfTag parameter, the parameter reserved must be null (reserved for the future use).

Access Read/Write.

Type VT_BOOL or Boolean.

Document.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Document.Printer

Returns the Printer object that represents the associated printer.

Access Read-Only.

Type VT_DISPATCH or Printer object.

Document.PrintingOptimizationMode

Sets or retrieves the optimization mode

Access Read / Write

Type VT UI4 or enumPrintingOptimizationMode

Document.ReadOnly

True, if the changes of the current document cannot be saved to the original document.

Access Read-Only.

Type VT_BOOL or Boolean.

Document.RefreshDatabaseBeforePrinting

True, if table lookup is refreshed before printing. In this case, your table lookups are always synchronized with the database.
Access Read / Write

Type VT_BOOL or Boolean

Document.RefreshTableLookupBeforePrinting

Sets or retrieves if update database at print time for table lookup fields.

Access Read / Write

Type VT_BOOL or Boolean

Document.RfTag (Reserved As long)

Returns the current RfTag object used in the document, the parameter Reserved must be null (reserved for future use).

Access Read-Only.

Type VT_DISPATCH or RfTagObject.

Document.RfTagList

Sets or returns the list of RfTag lds available.

Access Read/Write.

Type VT_BSTR or String.

Document.SelectedDocObjects

Retrieves the Collection of selected Objects.

Access Read-Only.

Type VT_DISPATCH.

Document.TriggerForm

Sets or returns the TriggerForm in a printing situation.

Access Read/Write.

Type VT_I2 or Integer or enumTriggerForm type.

Document.Variables

Returns the Variables collection that represents all the created Variable objects in the document.

Access Read-Only.

Type VT_DISPATCH or Variables collection.

Document.Version

Retrieves the serialization version of document file.

Access Read-Only.

Type VT_I4 or Long.

Document.VertPrintOffset

Sets or returns the vertical Print offset.

Access Read/Write.

Type VT_I4 or Long.

Document.ViewMode

Sets or retrieves the current mode of visual display.

Access Read/Write.

Type VT_I2 or Integer or enumViewMode type.

Document.ViewOrientation

Sets or retrieves the orientation of the view of the document.

Access Read/Write.

Type VT_I2 or Integer or enumRotation type.

Document.ViewZoom

Returns the Zoom factor of the designer in percent.

Access Read.

Type VT_I4 or Long.

Document.Visible

Allows to have the document Visible or Not.

Access Read/write.

Type VT_BOOL or Boolean.

Document.WindowState

Sets or retrieves the current size of the visual display of the document.

Access Read/Write.

Type VT_I2 or Integer or enumWindowState type.

Document.WindowsGraphicalEmulation

Retrieves or sets the "windows printing mode", in this case with a thermal printer, the label is printed as a single image to give the same printing output.

Access Read/Write.

Type VT_BOOL or Boolean.

Object Methods

Document.Activate

VT_NONE Activate ().

Causes the document object to be activated, being the ActiveDocument.

Document.AddHistory

VT_BOOL or Boolean AddHistory (Type, Comment, HistData)

Appends a new History event (just the HistoryPrinting is refused).

The parameter HistData is reserved for a futur use.

Parameters

Type required VT_I4 or EnumLAHistory

Comment required VT_BSTR or String

HistData required VT_DISPATCH

Document.AddWatermark

VT DISPATCH or Text AddWatermark(strWatermark, nFlags);

Returns the new text object that represents the watermark on the document.

Parameters

strWatermark required VT_BSTR or String and cannot be an empty string.

nFlags required VT I4 or Long. It is not used (reserved for future use), must be set to zero.

Note: To remove the watermark, strWatermark parameter must be empty.

Document.CheckIn

VT_BOOL or Boolean CheckIn (ByRef DocName, Mode, State, Comment)

Closes an checkin the document and return through the DocName string the new document name (including the version number in the extension file).

The parameter DocName is used only when the checkin mode "SaveAs" is set, in all other case the new document named is returned.

Parameters

ByRef DocName required VT_BSTR or String

Mode required VT_I4 or EnumLACheckInMode

State required VT_I4 or EnumLADocStates

Comment required VT_BSTR or String

Document.Close

VT_I2 Close( boolSave ).

Closes document.

Parameters:
boolSave Optional VT_BOOL or Boolean.(default True) If True, saves document.

NOTE: This method is asynchronous. A message is sent to the document to ask it to close. For this reason, the document may not be closed right after the call of the method. A temporization could be used if necessary to wait that the document is closed.

Document.CopyImageToFile

VT_BSTR or String CopyImageToFile(Colors, Extension, Rotation,Percent, Filename).

Generates a file that contains the Image of the document.

Return value: Returns a string that represents the full name of the generated Bitmap file. Returns an empty string if the function fails.

Parameters:
Colors Optional VT_I2 or Integer. (Default 0). Specifies the number of bits-per-pixel. Depending of the generated file the value must be : 1, 4, 8 or 24.

Extension Optional VT_BSTR or String (Default BMP). Specifies the type of Image file by the extension. The value must be : "bmp", "pcx", "dcx", "eps", "tif", "jpg" or "png".

Rotation Optional VT_I2 or Integer (Default 0). Specifies the rotation of the label in geometrical degree.
Rotation is counterclockwise, the values must be between 0 and 360.

Percent Optional VT_I2 or Integer (Default 100). Specifies the scaling factor in percent. The value must be between 10 and 1000.

FileName Optional VT_BSTR or String (Default ). Specifies the name of the image file without extension. The extension is added to the filename by the function. If it is empty the file name is the temp file name allowed by the system (for example "c:\windows\temp\Img58.bmp").

Document.CopyImageToFileEx

VT_BSTR or String CopyImageToFileEx(Colors, Extension, Rotation,Percent, Filename, Border, NonPrintObj).

Generates a file that contains the Image of the document.

Return value: Returns a string that represents the full name of the generated Bitmap file. Returns an empty string if the function fails.

Parameters:
Colors Optional VT_I2 or Integer. (Default 0). Specifies the number of bits-per-pixel. Depending of the generated file the value must be : 1, 4, 8 or 24.

Extension Optional VT_BSTR or String (Default BMP). Specifies the type of Image file by the extension. The value must be : "bmp", "pcx", "dcx", "eps", "tif", "jpg" or "png".

Rotation Optional VT_I2 or Integer (Default 0). Specifies the rotation of the label in geometrical degree.
The values must be between 0 and 360.

Percent Optional VT_I2 or Integer (Default 100). Specifies the scaling factor in percent. The value must be between 10 and 1000.

FileName Optional VT_BSTR or String (Default ). Specifies the name of the image file without extension. The extension is added to the filename by the function. If it is empty the file name is the temp file name allowed by the system (for example "c:\windows\temp\Img58.bmp").

Border Optional VT_BOOL or Boolean (Default true). If True, draw the label border.

NonPrintObj Optional VT_BOOL or Boolean (Default true). If True, draw the non-printable objects.

Document.CopyToClipboard

VT_BOOL CopyToClipboard().

Copies an image of the document to the Clipboard.

Return value: true if the function succeeded.

Document.CopyToClipboardEx

VT_BOOL CopyToClipboardEx(Border, Method, Colors, Rotation, Percent).

Copies an image of the document to the Clipboard.

Return value: true if the function succeeded.

Parameters:

Border Optional VT_BOOL or Boolean (Default true). If True, paint of the label border.

Method Optional VT_I2 or Integer. (Default 2). Specifies the algorithm of the reduction color palette. The value must be :

0: none

1: Bayer

2: Burkes

3: Floyd

8: Grayscale

Colors Optional VT_I2 or Integer. (Default 0). Specifies the number of bits-per-pixel. Depending of the generated file the value must be : 1, 4, 8 or 24.

Rotation Optional VT_I2 or Integer (Default 0). Specifies the rotation of the label in geometrical degree.

The values must be between 0 and 360.

Percent Optional VT_I2 or Integer (Default 100). Specifies the scaling factor in percent. The value must be between 10 and 1000.

Document.EndPrintingReport

VT_I4 EndPrintingReport (nPages, nLabels)

Infoms the user at the end of the printing process about Number of Pages and labels printed.

Parameters:

nPages VT I4 or Long. Specifies the number of pages printed.

nLabels VT I4 or Long. Specifies the Number of labels printed.

Document.FormFeed

VT_I2 FormFeed ().
Ends the process job.

Note: "PrintLabel" and "FormFeed" methods have to be used consequently on a single document. The "FormFeed" method needs to be called before any "PrintLabel" call on an other document is performed.

Document.GetMetaFilepreview

V T_VARIANT GetMetaFilePreview (VT_I4 flags, VT_BSTR previewObjectName)

Return value: Returns an enhanced metafile preview of the document as an array of bytes.

Parameters:

flags VT I4 or Long. Combination of enumPreviewFlags

previewObjectName VT_BSTR or String. Specifies the name of a specific label object. See enumPreviewFlags for details.

Document.GetPreview

VT VARIANT GetPreview (Border, Color, Percent)
Returns a DIB (Device Independent Bitmap) format through a variant array.
Parameters:
Border Required VT Bool or Boolean. If True, draw the label border.
Color Required VT Bool or Boolean. Returns 24 bits DIB or a monochrome DIB.

Percent Required VT I4 or Long. Specifies the scaling factor in percent. The value must be between 10 and 1000.

Document.Insert

VT_I2 Insert ( strDocumentFileName ).

Inserts a document in the current document.

Parameters:
strDocumentFileName Required VT_BSTR or String. Name of the document to insert.

Document.Merge

VT_I2 Merge (longLabelQuantity, longLabelCopy, longInterCut, longPageCopy, longLabelNoPrintedFrom, strFileName).

Merges document with the associated Database.

Parameters:
longLabelQuantity Required VT_I4 or Long.

longLabelCopy Optional VT_I4 or Long (default 1)

longInterCut Optional VT_I4 or Long (default 1)

longPageCopy Optional VT_I4 or Long (default 1)

longLabelNoPrintedFrom Optional VT_I4 or Long (default 1)

strFileName Optional VT_BSTR or String (default empty string)

Document.PrintDocument

VT_I2 PrintDocument ( longLabelQuantity ).

Prints document and executes an automatic FormFeed.

Parameters:
longLabelQuantity Optional VT_I4 or Long. Quantity of labels to print (Default : 1)

Document.PrintLabel

VT_I2 PrintLabel (longLabelQuantity, longLabelCopy, longInterCut, longPageCopy, longLabelNoPrintedFrom, strFileName).

Prints document.

Parameters:

longLabelQuantity Required VT_I4 or Long

longLabelCopy Optional VT_I4 or Long (default 1)

longInterCut Optional VT_I4 or Long (default 0)

longPageCopy Optional VT_I4 or Long (default 1)

longLabelNoPrintedFrom Optional VT_I4 or Long (default 0)

strFileName Optional VT_BSTR or String (default empty string)

Note: If the value of the longLabelNoPrintedFrom parameter is 0, then the position of the current PrintLabel is calculated according to the position of the last printed label using the last PrintLabel (in the event that no other FormFeed has been executed in the meantime).

Note: If the value of the current's PrintLabel longLabelNoPrintedFrom parameter is equal to or less than the position of the last printed label, then a FormFeed will be automatically executed to prevent the superimposition of the labels

Note: "PrintLabel" and "FormFeed" methods have to be used consequently on a single document. The "FormFeed" method needs to be called before any "PrintLabel" call on an other document is performed.

Document.Rotate

VT_I4 Rotate (iRotate).
Rotate label using lRotate.
lRotate can equal 0, 900, 1800 or 2700 corresponding to 0, 90, 180 or 270 degrees.

Document.Save

VT_I2 Save ().

Saves the document.

If the document has not been saved, a dialog box is prompted automatically only if the application is visible.

Document.SaveAs

VT_I2 SaveAs ( strDocumentFileName ).

Saves the document under a new name.

Parameters:
strDocumentFileName Required VT_BSTR or String

Document.SelectOpen

VT_I4 or OLE_HANDLE

Document.ReadVariables

VT_VARIANT ReadVariables (iType)

Get variables ( name and value ) collection from type iType.

Return value: Returns bidimensional arrays containing for each entry the name and the value of the variable.

Parameters:

iType enumdatasource. Specifies the data source type of the variables depending on the value affected, 1 to 7.

Document.SelectDatabase

VT_BOOL or Boolean SelectDatabase (Name As String)

Selects Database.

Document.WriteVariables

VT_I2 WriteVariables (varArray)

Sets a collection of variables ( name and Value ).

Parameters:

varArray VT_VARIANT


Document Events

Properties | Methods
(None) | BeginPrinting
 | Change
 | Close
 | EndPrinting
 | PausedPrinting
 | ProgressPrinting

Object Methods

Document.BeginPrinting

VT_NONE BeginPrinting ( strDocName ).

Informs the user when the printing process begins for document strDocName.

Parameters:
strDocName VT_BSTR or String Name of the document starting to print.

Document.Change

VT_NONE Change ( ).

Informs the user of a change in the document.

User is invited to save or save as the current document.

Document.Close

VT_NONE Close ( ).

Informs the user that the current document has been closed.

Document.EndPrinting

VT_NONE EndPrinting ( Reason ).

Infoms the user of the end of the printing process for current document with anotification code.

Reason VT_I2 or Integer or enumEndPrinting type. Code for the reason for the end of the process.

Document.PausedPrinting

VT_NONE PausedPrinting ( Reason, refCancel ).

Informs the user of a problem during printing process for the current document.

Reason VT_I2 or Integer or enumPausedReasonPrinting type. Reason for the end of the process.

Parameters:
refCancel VT_I2 or Integer. User must assign this parameter to 1 to abort process.

Document.ProgressPrinting

VT_NONE ProgressPrinting ( LabelPercent, refCancel ).

Informs the user of the printing progress for the current document.

Parameters:
LabelPercent VT_I2 or Integer Percent value of the printing of the current label.

refCancel VT_I2 or Integer. User must assign this parameter to 1 to abort process.


DocumentProperties Collection

Properties | Methods
Application | Item (Default)
Count |
Parent |

Object Properties

DocumentProperties.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

DocumentProperties.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

DocumentProperties.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

DocumentProperties.Item

VT_DISPATCH or DocumentProperty Item( longIndex ).

Returns a member of a collection, either by position or by name.

Note: If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
longIndex Required VT_VARIANT or Variant or enumBuiltInDocumentProperty.

The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note: If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.DocumentProperties(1)
Object.DocumentProperties.Item(1)


DocumentProperty Object

Properties | Methods
Application | (None)
CauseForApproval |
Parent |
NeedsApproval |
Name |
Type |
Value (Default) |

Object Properties

DocumentProperty.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

DocumentProperty.CauseForApproval

This property returns the cause for approval message.

Access Read/Write.

Type VT_BSTR or String.

DocumentProperty.Name

Returns the name of the property.

Access Read-Only.

Type VT_BSTR or String.

DocumentProperty.NeedsApproval

Controls if the document needs approval.

Access Read-Only.

Type VT_BOOL or Boolean.

DocumentProperty.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

DocumentProperty.Type

Returns the type of the property.

Access Read-Only.

Type VT_I4 or Long or enumProperty type.

DocumentProperty.Value

Returns the current value of the DocumentProperty.

Access Read/Write.

Type VT_VARIANT or Variant.


Enumerated Data Types Appendix

This board defines the Enumerated Data Types.

  • EnumBasicTypes

  • EnumBlockColumn

  • EnumEpcClass

  • EnumErrorCode

  • EnumErrorsHandling

  • enumFieldsStructuresFilter

  • EnumFlipMode

  • EnumLACheckInMode

  • EnumLADocStates

  • EnumLAHistory

  • EnumLanguage

  • EnumMeasureSystem

  • EnumMotionMode

  • EnumMifareClass

  • EnumPrinterParameters

  • EnumRfTagBlockAttribute

  • EnumRfTagBlockDataType

  • EnumRfTagCtrlType

  • EnumRfTagDlg

  • EnumRfTagFieldFilterDOD

  • EnumRfTagFieldFlags

  • EnumRfTagFieldPartition

  • EnumRfTagFieldsStructures

  • EnumRfTagID

  • EnumRfTagPropertyID

  • EnumTagSysClass

  • EnumUCodeClass

  • EnumBasicTypes

EnumBasicTypes :

Long : as a signed 32-bit (4-bytes).

String : as text string.

Variant: : as variant structure.

IUnknown : as an IUnknown interface.

IDispatch : as an IDispatch interface.

Boolean : as numeric value true or false.

OLE_HANDLE : as an unsigned 32-bit (4 bytes).

EnumBlockColumn :

rftagBlockColumnAccess = 8

rftagBlockColumnDatasource = 16 (&H10)

rftagBlockColumnFormat = 32 (&H20)

rftagBlockColumnLock = 128 (&H80)

rftagBlockColumnName = 2

rftagBlockColumnNone = 0

rftagBlockColumnNum = 1

rftagBlockColumnRetries = 256 (&H100)

rftagBlockColumnSize = 64 (&H40)

rftagBlockColumnValue = 4

rftagBlockColumnVerifydata = 512 (&H200)

EnumEpcClass :

rftagEpcAlienClass1_64 = 10 (&HA)

rftagEpcAlienClass1_96 = 11 (&HB)

rftagEpcAlienClass1_128 = 12 (&HC)

rftagEpcAlienClass1_256 = 13 (&HD

rftagEpcMatricsClass0_64 = 1

rftagEpcMatricsClass0_96 = 2

rftagEpcMatricsClass0Plus_64 = 20 (&H14)

rftagEpcMatricsClass0Plus _96 = 21 (&H15)

rftagEpcMatricsClass0Plus _128 = 22 (&H16)

rftagEpcMatricsClass0Plus _256 = 23 (&H17)

rftagEpcPhilipsHf = 0

rftagEpcUCode119_256 = 30 (&H1E)

EnumErrorCode :

rftagErrBlockData = 1

rftagErrFieldData = 2

rftagErrNone = 0

EnumErrorsHandling :

rftagErrErrorPrinter = 2

rftagErrNoAction = 0

rftagErrPausePrinter = 1

enumFieldsStructuresFilter :

rftagFieldsStructureFilterAll = 0

rftagFieldsStructureFilterOnlyEqual = 1

EnumFlipMode :

rftagFlipHorizontal = 1

rftagFlipHorizVert = 3

rftagFlipNone = 0

rftagFlipVertical = 2

EnumLACheckInMode:

lppxLACheckIn = 0

lppxLACheckInSave = 1

lppxLACheckInSaveAs = 2

lppxLACheckInNewVersion = 3

lppxLACheckInPrompt = 4096 (&H1000)

EnumLADocStates :

lppxLADocStates_Draft = 1

lppxLADocStates_Approval = 2

lppxLADocStates_Final = 4

EnumLAHistory :

lppxLAHistoryPrinting = 1

lppxLAHistoryModifications = 2

lppxLAHistoryErrors = 4

lppxLAHistoryWarnings = 8

lppxLAHistoryInformation = 16

EnumLanguage :

rftagArabic = 20 (&H14)

rftagCroatian = 24 (&H18)

rftagCzech = 11

rftagDanish = 6

rftagDutch = 10

rftagEnglish = 1

rftagEstonian = 25 (&H19)

rftagFinnish = 13

rftagFrench = 2

rftagGerman = 3

rftagHebrew = 21 (&H15)

rftagHungarian = 9

rftagItalian = 4

rftagJapanese = 8

rftagKorean = 17 (&H11)

rftagLatvian = 26 (&H1A)

rftagLithuanian = 27 (&H1B)

rftagNorwegian = 12

rftagPolish = 18 (&H12)

rftagPortuguese = 14

rftagPortugueseBrazil = 23 (&H17)

rftagRussian = 22 (&H16)

rftagSimplifiedChinese = 15

rftagSlovene = 28 (&H1C)

rftagSpanish = 5

rftagSwedish = 7

rftagTraditionalChinese = 16 (&H10)

rftagTurkish = 19 (&H13)

EnumMeasureSystem :

rftagDot = 2

rftagInch = 1

rftagMillimeter = 0

EnumMotionMode :

rftagMotionNone = 0

rftagMotionOnRead = 1

rftagMotionOnUniqueID = 4

rftagMotionOnWrite = 2

EnumMifareClass :

rftagMifareStandard1024 = 1

rftagMifareStandard4096 = 2

rftagMifareUltraLight512 = 0

EnumPrinterParameters

lppxVarFieldsOnly = 1

lppxDirectThermal = 2

lppxRibbonSaver = 3

lppxPeelOff = 4

lppxTearOff = 5

lppxRot180 = 6

lppxMirror = 7

lppxCheckPrinter = 8

lppxOverlayInverted = 9

lppxSuppressBackFeed = 10

lppxCutter = 11

lppxCutFinalPiece = 12

lppxPrintSpeed = 13

lppxHeadTemp = 14

lppxPaperFeedMode = 15

lppxBackFeedPos = 16

lppxVerticalPos = 17

lppxHorizontalPos = 18

lppxFeedAfterPrint = 19

lppxFeedBeforePrint = 20

lppxCutPos = 21

lppxInterCut = 22

lppxCountryCode = 23

lppxSupportType = 24

lppxCountryCodeString = 25

lppxUseUnicode = 26

lppxHeadTemp100 = 27

lppxPrintSpeed100 = 28

EnumRfTagBlockAttribute :

rftagBlockLock = 4

rftagBlockNull = 0

rftagBlockRead = 1

rftagBlockRetry = 8

rftagBlockVerifyData = 16 (&H10)

rftagBlockWrite = 2

EnumRfTagBlockDataType :

rftagBlockAnsi = 1

rftagBlockDate = 16 (&H10)

rftagBlockHexa = 32 (&H20)

rftagBlockInteger = 4

rftagBlockNone = 0

rftagBlockReal = 8

rftagBlockStructured = 64 (&H40)

rftagBlockUnicode = 2

EnumRfTagCtrlType :

rftagCtrlCheckButton = 4

rftagCtrlCheckComboList = 5

rftagCtrlComboList = 2

rftagCtrlDlgColor = 16 (&H10)

rftagCtrlDlgFont = 19 (&H13)

rftagCtrlDlgOpenFile = 17 (&H11)

rftagCtrlDlgPathName = 18 (&H12)

rftagCtrlEditBox = 1

rftagCtrlHidden = 32768 (&H8000)

rftagCtrlNone = 0

rftagCtrlSpinButton = 3

EnumRfTagDlg :

rftagDlgBlocks = 1

rftagDlgBlocksEdit = 3

rftagDlgNone = 0

rftagDlgProperties = 2

rftagDlgPropertiesEdit = 4

EnumRfTagFieldFilterDOD :

rftagFieldFilterDODCase = 1

rftagFieldFilterDODPallet = 0

rftagFieldFilterDODUIDItem =2

EnumRfTagFieldFlags :

rftagFieldNone = 0

rftagFieldLock = 1

rftagFieldMaster = 2

rftagFieldSlave = 4

EnumRfTagFieldPartition :

rftagFieldPartition0 = 0

rftagFieldPartition1 = 1

rftagFieldPartition2 = 2

rftagFieldPartition3 = 3

rftagFieldPartition4 = 4

rftagFieldPartition5 = 5

rftagFieldPartition6 = 6

EnumRfTagFieldsStructures :

rftagFieldsStructNone = 0

rftagFieldsStructSGTIN_64 = 2

rftagFieldsStructSSCC_64 = 8

rftagFieldsStructSGLN_64 = 9

rftagFieldsStructGRAI_64 = 10 (&HA)

rftagFieldsStructGIAI_64 = 11 (&HB)

rftagFieldsStructDOD_64 = 206 (&HCE)

rftagFieldsStructSGTIN_96 = 48 (&H30)

rftagFieldsStructSSCC_96 = 49 (&H31)

rftagFieldsStructSGLN_96 = 50 (&H32)

rftagFieldsStructGRAI_96 = 51 (&H33)

rftagFieldsStructGIAI_96 = 52 (&H34)

rftagFieldsStructGID_96 = 53 (&H35)

rftagFieldsStructDOD_96 = 47 (&H2F)

rftagFieldsStructUCodeHsl = 61440 (&HF000)

rftagFieldsStructPicoTag = 61441 (&HF001)

rftagFieldsStructRAW_64 = 61698 (&HF100)

rftagFieldsStructRAW_96 = 61697 (&HF101)

For more information on structures, please go to:

www.acq.osd.mil/log/rfid/supplierguide.htm

www.epcglobalinc.org/standards_technology/specifications.html

EnumRfTagID :

rftagCustom = 0

rftagEpc = 7

rftagICode = 1

rftagICodeSli15693 = 10 (&HA)

rftagInfineon15693 = 4

rftagMifare14443 = 9

rftagPhilips15693 = 5

rftagPicoTag = 3

rftagTI15693 = 6

rftagTagIt = 2

rftagTagSys = 8 (&HB)

EnumRfTagPropertyID :

rftagPropAntennaGap = 21 (&H15) as Long

rftagPropBlocksAccess = 30 (&H1E) as EnumRfTagBlockAttribute (only read or write)

rftagPropBlocksLocked = 29 (&H1D) as Boolean

rftagPropBlocksOutputFormat = 34 (&H 22) as EnumRfTagBlockDataType

rftagPropBlocksRetries = 22 (&H16) as Long

rftagPropClassObject = 258 (&H102) as EnumEpcClass or EnumMifareClass or EnumTagSysClass

rftagPropErrorHandling = 25 (&H19) as EnumErrorsHandling

rftagPropFieldsStructuresFilters = 259 (&H0103) enumFieldsStructuresFilter

rftagPropHeight = 19 (&H13) as Long

rftagPropLabelRetries = 27 (&H1B) as Long

rftagPropLabelVoidPrintoutLength = 32 (&H20) as Long

rftagPropLabelVoidPrintoutText = 33 (&H21) as String

rftagPropLeft = 18 (&H12) as Long

rftagPropLinkedObjectList = 1 as String

rftagPropNone = 0

rftagPropMotionMode = 26 (&H1A) as EnumMotionMode

rftagPropPictureBrightness = 4 as Long

rftagPropPictureContrast = 5 as Long

rftagPropPictureFlip = 6 as EnumFlipMode

rftagPropPictureName = 3 as String

rftagPropReservedBlocks = 257 (&H101) as Long

rftagPropTag = 2 as Variant

rftagPropTop = 17 (&H11) as Long

rftagPropUniqueID = 24 (&H18) as String

rftagPropUniqueIDRetries = 31 (&H1F) as Long

rftagPropVerticalChipOffset = 28 (&H1C) as Long

rftagPropVisibleBlockColumns = 7 as EnumBlockColumn

rftagPropWidth = 20 (&H14) as Long

rftagPropWriteEmptyBlocks = 23 (&H17) as Boolean

EnumTagSysClass :

rftagTagSysC210 = 0

rftagTagSysC220 = 1

rftagTagSysC240 = 2

EnumUCodeClass :

rftagUCodeHsl = 0

rftagUCodeEpc119 = 1

EnumBasicTypes :

Long : as a signed 32-bit (4-bytes).

String : as text string.

Variant: : as variant structure.

Unknown : as an IUnknown interface.

Boolean : as numeric value true or false.

OLE_HANDLE : as an unsigned 32-bit (4 bytes).


Enum Types Appendix

  • enumAlignment

  • enumAnchorPoint

  • enumBarcodeCategory

  • enumBarcodeChecksAvailable

  • enumBuiltInDocumentProperty

  • enumCheckMode

  • enumCounterBase

  • enumDatabaseFind

  • enumDatabaseType

  • enumDataSource

  • enumDateType

  • enumDialogType

  • enumDitherMethod

  • enumDocObject

  • enumEndPrinting

  • enumHRPosition

  • enumImage

  • enumKindOfPrinters

  • enumLanguage

  • enumLayer

  • enumLogFileDataSourceMode

  • enumLogFileFormat

  • enumLogFileOptions

  • enumMeasureSystem

  • enumPausedReasonPrinting

  • enumPreviewFlags

  • enumPrintingOptimizationMode

  • enumProperty

  • enumRotation

  • enumSettingsMode

  • enumShared

  • enumSupportType

  • enumSwitchToExFlags

  • enumSymbology

  • enumTriggerForm

  • enumTriggerMode

  • enumViewMode

  • enumWindowState

enumAlignment

{

lppxAlignLeft = 0,

lppxAlignCenter = 1,

lppxAlignRight = 2,

lppxAlignJustify = 3

};

enumAnchorPoint

{

lppxTopLeft = 1,

lppxTopCenter = 2,

lppxTopRight = 3,

lppxCenterLeft = 4,

lppxCenter = 5,

lppxCenterRight = 6,

lppxBottomLeft = 7,

lppxBottomCenter = 8,

lppxBottomRight = 9

};

enumBarcodeCategory

{

lppxBarcodeCategoryPostal = 0x10

};

enumBarcodeChecksAvailable

{

lppxBarcodeCheckMod10Available = 0x10,

lppxBarcodeCheckMod16Available = Value= 0x20

};

enumBuiltInDocumentProperty

{

lppxPropertyManager = 1,

lppxPropertyCompany = 2,

lppxPropertyCategory = 3,

lppxPropertyTitle = 4,

lppxPropertySubject = 5,

lppxPropertyAuthor = 6,

lppxPropertyKeywords = 7,

lppxPropertyComments = 8

};

enumCheckMode

{

lppxNone = 0,

lppx1Digit = 1,

lppx2Digits = 2,

lppxMod11Mod10 = 3

lppxMod10 = 4,

lppxMod16 = 5

};

enumCounterBase

{

lppxBaseBinary = 2,

lppxBaseOctal = 8,

lppxBaseDecimal = 10,

lppxBaseHexadecimal = 16,

lppxBaseAlphabetic = 26,

lppxBaseAlphaNumeric = 36,

lppxBaseCustom = 255

};

enumDatabaseFind

{

lppxDatabaseFindFirst = 1,

lppxDatabaseFindPrev = 2,

lppxDatabaseFindNext = 3,

lppxDatabaseFindLast = 4

};

enumDatabaseType

{

lppxDatabaseTypeNull = 0,

lppxDatabaseTypeOLEDB = 1,

lppxDatabaseTypeODBC = 2,

lppxDatabaseTypeASCII = 3

};

enumDataSource

{

lppxDataSourceCounter = 1,

lppxDataSourceTableLookup = 2,

lppxDataSourceDate = 3,

lppxDataSourceFormula = 4,

lppxDataSourceFree = 5,

lppxDataSourceForm = 6,

lppxDataSourceDataBase = 7

};

enumdateType

{

lppxSoftwareDate = 0,

lppxPrinterDate = 1,

lppxOptimizedDate = 2

};

enumDialogType

{

lppxPrinterSelectDialog = 1,

lppxOptionsDialog = 2,

lppxFormDialog = 3,

lppxPrinterSetupDialog = 4,

lppxPageSetupDialog = 5,

lppxDocumentPropertiesDialog = 6,

lppxPrintDialog = 7

lppxAddPrinterDialog = 8

lppxLasLogin = 9

lppxLasCheckout = 10

};

enumDitherMethod

{

lppxImageNone = 0,

lppxImageBayer = 1,

lppxImageBurkes = 2,

lppxImageFloyd = 3,

lppxImageGrayscale = 4,

lppxImageFixedpalette = 5,

lppxImageHalftone = 6,

lppxImageThresHold = 7

};

enumDocObject

{

lppxObjectText = 1,

lppxObjectBarCode = 2,

lppxObjectImage = 3,

lppxObjectLine = 4,

lppxObjectRectangle = 5,

lppxObjectEllipse = 6,

lppxObjectPolygon = 7,

lppxObjectOblique = 8,

lppxObjectRoundRect = 9,

lppxObjectOLEObject = 10

};

enumEndPrinting

{

lppxEndOfJob = 1,

lppxCancelled = 2,

lppxSystemFailure = 3

};

enumHRPosition

{

lppxHRNone = 0,

lppxHRBelow = 1,

lppxHRAbove = 2,

lppxHRFree = 3

};

enumImage

{

lppxImageFixedRatio = 2,

lppxImageStrechable = 1,

lppxImageNoneResizable = 0

};

enumKindOfPrinters

{

lppxInternalPrinters = 1,

lppxWindowsPrinters = 2,

lppxAllPrinters = 3

};

enumLanguage

{

lppxEnglish = 1,

lppxFrench = 2,

lppxGerman = 3,

lppxItalian = 4,

lppxSpanish = 5,

lppxDanish = 6,

lppxSwedish = 7,

lppxJapanese = 8,

lppxHungarian = 9,

lppxDutch = 10,

lppxCzech = 11,

lppxNorwegian = 12,

lppxFinnish = 13,

lppxPortuguese = 14,

lppxSimplifiedChinese = 15,

lppxTraditionalChinese = 16,

lppxKorean = 17,

lppxPolish = 18,

lppxTurkish = 19,

lppxArabic = 20,

lppxHebrew = 21,

lppxRussian = 22,

lppxPortugueseBrazil = 23,

lppxEstonian = 24,

lppxLatvian = 25,

lppxLithuanian = 26,

lppxRomanian = 27,

lppxThai = 28,

lppxVietnamese= 29

};

enumLayer

{

lppxLayerNone = 0,

lppxLayerHeader = 1,

lppxLayerBody = 2,

lppxLayerBody2 = 4,

lppxLayerFooter = 0x40000000

};

enumLogFileDataSourceMode

{

lppxDataSourceNone = 0,

lppxDataSourceSelected = 1,

lppxDataSourceAll = 2

};

enumLogFileFormat

{

lppxFileFormatNone = 0,

lppxFileFormatTab = 1,

lppxFileFormatComma = 2

};

enumLogFileOptions

{

lppxIncludeFile = 1,

lppxIncludePrinter = 2,

lppxIncludeCOM = 3,

lppxIncludeQuantity = 4,

lppxIncludeLabelCopy = 5,

lppxIncludePageCopy = 6,

lppxIncludeTotal = 7,

lppxIncludeHeight = 8,

lppxIncludeWidth = 9,

lppxIncludeHeader = 10,

lppxIncludeUser = 11,

lppxIncludeEachLabel = 12,

lppxIncludeDate = 13

};

enumMeasureSystem

{

lppxMillimeter = 0,

lppxInch = 1

};

enumPausedReasonPrinting

{

lppxGenericError = 0,

lppxNoPaper = 2,

lppxNoRibbon = 3,

lppxPortNotAvailable = 4,

lppxPrinterNotReady = 5,

lppxCommunicationError = 6,

lppxHeadLifted = 7

};

enumPreviewFlags

{

lppxPreviewObjectsNone = 0,

lppxPreviewBorder = 1,

lppxPreviewBackground = 2,

lppxPreviewObjectsBefore = 0x0100,

lppxPreviewObject = 0x0200,

lppxPreviewObjectsAfter = 0x0300,

lppxPreviewObjectsAll= 0x0400,

lppxPreviewObjectsMask = 0x0f00,

lppxPreviewOutputWmf = 0x01000,

lppxPreviewOutputEmf = 0x02000,

lppxPreviewOutputMask = 0x0f000

};

enumPrintingOptimizationMode

{

lppxOptimizationNone = 0,

lppxOptimizationThermalPrintersOnly = 1,

lppxOptimizationAllPrinters = 2,

};

enumProperty

{

lppxPropertyTypeNumber = 1,

lppxPropertyTypeBoolean = 2,

lppxPropertyTypeDate = 3,

lppxPropertyTypeString = 4,

lppxPropertyTypeFloat = 5

};

enumRotation

{

lppxNoRotation = 0,

lppx90DegreeRight = 1,

lppxUpSideDown = 2,

lppx90DegreeLeft = 3

};

enumSettingsMode

{

lppxSettingModeGeneric = 0,

lppxSettingModeUser = 1,

lppxSettingModeStation = 2

};

enumShared

{

lppxSharedForm = 1,

lppxSharedFree = 2,

lppxSharedCounter = 0,

lppxSharedList = 3

};

enumSupportType

{

lppxNoSupport = 0 ,

lppxLabelGap = 1, // "With gap"

lppxContinuous = 2, // "Continuous"

lppxLabelMark = 3, // "Marked"

lppxLabelHole = 4, // "With hole"

lppxVarLength = 5, // "With variable length"

lppxLabelMarkAbove = 6, // "Marked above"

lppxLabelMarkBelow = 7, // "Marked below"

lppxLabelNotch = 8, // "With notch"

lppxFanfoldInto = 9, //"Fanfold-Into stacker"

lppxFanfoldOver = 10, // "Fanfold-Over stacker"

lppxLowerDown = 11, // "Lower tray-Face down"

lppxLowerUp = 12, // "Lower tray-Face up"

lppxUpperDown = 13, // "Upper tray-Face down"

lppxUpperUp = 14, // "Upper tray-Face up"

lppxAdvancedGap = 15, // "Advanced Gap"

lppxAdvancedNotch = 16, // "Advanced Notch"

};

enumSymbology

{

lppxCode11 = 49,

lppx25Interleave = 50,

lppxCode39 = 51,

lppxCode49 = 52,

lppxMaxicode = 53,

lppxCode16K = 54,

lppxGermanPostcode = 55,

lppxEAN8 = 56,

lppxUPCE = 57,

lppxBC412 = 58,

lppxMicroPDF = 59,

lppxCode93 = 65,

lppx25Beared = 66,

lppxCode128 = 67,

lppxEAN128 = 68,

lppxEAN13 = 69,

lppxCode39Full = 70,

lppxCode128Auto = 71,

lppxCodablockF = 72,

lppx25Industrial = 73,

lppx25Standard = 74,

lppxCodabar = 75,

lppxLogmars = 76,

lppxMsi = 77,

lppxCodablockA = 78,

lppxPostnet = 79,

lppxPlessey = 80,

lppxCode128SSCC = 81,

lppxUPCExtended = 83,

lppxUPCA = 85,

lppxUPCEXT2 = 86,

lppxUPCEXT5 = 87,

lppxCode25PRDG = 88,

lppxUPCWEIGHT = 89,

lppxUPCEPLUS2 = 97,

lppxUPCEPLUS5 = 98,

lppxUPCAPLUS2 = 99,

lppxUPCAPLUS5 = 100,

lppxEAN8PLUS2 = 101,

lppxEAN8PLUS5 = 102,

lppxEAN13PLUS2 = 103,

lppxEAN13PLUS5 = 104,

lppxITF = 105,

lppx25MatrixEuropean = 106,

lppx25MatrixJapan = 107,

lppxDatamatrix = 120,

lppxItf14 = 121,

lppxPdf = 122,

lppxQrcode = 123,

lppxRss = 124,

lppxComposite = 125,

lppxTLC39 = 126,

lppxCIP = 127,

lppxAztec = 128,

lppxAztecMesa = 129,

lppxEAN14 = 130,

lppxBookland = 131,

lppxPlanet = 132,

lppxPharmacode = 133,

lppxItf16 = 134,

lppxVericode = 135,

lppxCode93i = 136,

lppxRM4SCC= 137,

lppxFIM = 138,

lppxIntelligentMail = 139,

lppxISBN13 = 140,

lppxChineseSensibleCode = 141,

lppxMicroQR = 142,

lppxISBT128= 143,

lppxGS1_128_CC_UPCA= 144,

lppxGS1_128_CC_EAN13= 145,

lppxJapanPost= 146,

lppxKixCode= 147,

lppxAustralianPost= 148,

lppxKoreanPost= 149,

lppxTelepen= 150,

lppxCodeOne= 151

};

enumSwitchToExFlags

{

lppxNull = 0,

lppxCreatePrinterIfNotExist = 1

};

enumTriggerForm

{

lppxNever = 1,

lppxForEachSerie = 2,

lppxForEachLabel = 3

};

enumTriggerMode

{

lppxNumberOfPrintedLabels = 1,

lppxResetOfAnotherCounter = 2

};

enumViewMode

{

lppxViewModeName = 1,

lppxViewModeSize = 2,

lppxViewModeValue = 3,

lppxViewModeForm = 4

};

enumWindowState

{

lppxNormal = 1,

lppxMinimized = 2,

lppxMaximized = 3

};


Format Object

Properties | Methods
Application | Check (out BSTR error)
AutomaticMargins | Papers
AutoSize | SaveStock
Background | Supports
ColumnCount |
Corner |
HorizontalGap |
LabelHeight |
LabelWidth MarginLeft |
MarginTop |
PaperName |
PaperType |
PageHeight |
PageWidth |
Parent |
Portrait |
RowCount StockName StockType SupportName SupportType VerticalGap |

Object Properties

Format.Application

Returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Format.AutomaticMargins

Retrieves or sets the automatic margins.

Access Read/Write.

Type VT_BOOL or Boolean.

Format.AutoSize

Automatically adjusts the page based on the dimension of the label, the number of labels, margins, and the amount of space between labels.

This option is available only for customized page formats. However, it is always possible to disable the automatic option to enter the Height and Width values manually.

Access Read/Write.

Type VT_BOOL or Boolean.

Format.Background

Retrieves or sets the file background.

Access Read/Write.

Type VT_BSTR or String.

Format.ColumnCount

Retrieves or sets the number of labels per row (horizontal count).

Access Read/Write.

Type VT_I4 or Long.

Format.Corner

Retrieves or sets the radius corner of the document (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Format.HorizontalGap

Retrieves or sets the amount of empty space between the columns (Horizontal) of labels on a page. (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Format.LabelHeight

Retrieves or sets the height of the label (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Format.LabelWidth

Retrieves or sets the width of the label (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Format.MarginLeft

Retrieves or sets the left margin of the page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Format.MarginTop

Retrieves or sets the top margin of the page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Format.PageHeight

Retrieves or sets the height of the page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Format.PageWidth

Retrieves or sets the width of the page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Format.PaperName

Retrieves or sets the name of paper use.

Access Read/Write.

Type VT_BSTR or String.

Format.PaperType

Retrieves or sets the paper type identifier.

Access Read/Write.

Type VT_I4 or Long.

See PaperType Appendix for list of identifiers.

Format.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Format.Portrait

Retrieves or sets the orientation of the document.

Access Read/Write.

Type VT_BOOL or Boolean.

Format.StockName

Retrieves or sets the name of the format model, if any.

Access Read/Write.

Type VT_BSTR or String.

Format.StockType

Retrieves or sets the type of the format type, if any.

Access Read/Write.

Type VT_BSTR or String.

Format.SupportName

Retrieves or sets the name of support use.

Access Read/Write.

Type VT_BSTR or String.

Format.SupportType

Sets or returns the Support type :

Access Read/Write.

Type VT_I4 or Long or enumSupportType

Format.RowCount

Retrieves or sets the number of labels per column (vertical count).

Access Read/Write.

Type VT_I4 or Long.

Format.VerticalGap

Retrieves or sets the amount of empty space between the rows (Vertical) of labels on a page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Object Methods
Format.Check (out BSTR error)

Check format and return message error in parameter BSTR.

VT_I2 or Integer.

Format.Papers

Retrieves papers list.

VT_VARIANT or Variant.

Format.SaveStock

VT_NONE Format.SaveStock().

Saves the current stock Name/Type. (In order to reuse it with others documents)

Format.Supports

Retrieves supports list.

VT_DISPATCH or String.


FormatSystem

FormatSystem Object

Properties | Methods
(None) | GetLFM
 | NameList
 | TypeList

Object Methods

FormatSystem.GetLFM

VT_DISPATCH or String

Retrieves interface LfmInfos.

FormatSystem.NameList

VT_DISPATCH or String

Retrieves names list.

FormatSystem.TypeList

VT_DISPATCH or LfmInfos

Retrieves types list.


Formulas Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

Formulas.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Formulas.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Formulas.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Formulas.Add

VT_DISPATCH or Formula Add( strFormulaName ).

Adds a new Formula object to the collection.

Return value: Returns a Formula object.

Parameters:
strFormulaName Optional VT_BSTR or String. The name of the object to add.

Formulas.Item

VT_DISPATCH or Formula Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.Formulas(1)
Object.Formulas.Item(1)

Formulas.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Formula Object

Properties | Methods
Counter object properties | Counter object methods
CounterUse | Test
Expression | DisplayValue
Length |
PadCharacter |
PadLength |

Object Properties

Formula.CounterUse

Activates or not counting on the object.

Access Read/Write.

Type VT_BOOL or Boolean.

Formula.Expression

Sets or retrieves the format of the Formula object.

Access Read/Write.

Type VT_BSTR or String.

Formula.Length

Sets or retrieves the length of the output value.

Access Read/Write.

Type VT_I4 or Long.

Formula.PadCharacter

Sets or retrieves the character used to pad the left of variable value.

Access Read/Write.

Type VT_BSTR or String.

Formula.PadLength

Sets or retrieves the number of characters to pad up to.

Access Read/Write.

Type VT_I2 or Integer.

Object Methods

Formula.Test

VT_BOOL or Boolean Test().

Tests the validity of the formula.

Return value: Returns a boolean which indicate if the Formula object format is valid or not.

Formula.DisplayValue

VT_BSTR (R only)

Returns the display value


FormVariables Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

FormVariables.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

FormVariables.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

FormVariables.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

FormVariables.Add

VT_DISPATCH or Free Add( strFreeName ).

Adds a new Free object to the collection with form attribute.

Return value: Returns a Free object.

Parameters:
strFreeName Optional VT_BSTR or String. The name of the object to add.

FormVariables.Item

VT_DISPATCH or Free Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.FormVariables(1)
Object.FormVariables.Item(1)

FormVariables.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Index Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


FreeVariables Collection

Properties | Methods
Application | Add
Count | item (Default)
Parent | Remove

Object Properties

FreeVariables.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

FreeVariables.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

FreeVariables.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

FreeVariables.Add

VT_DISPATCH or Free Add( strFreeName ).

Adds a new Free object to the collection with no specific attribute.

Return value: Returns a Free object.

Parameters:
strFreeName Optional VT_BSTR or String. The name of the object to add.

FreeVariables.Item

VT_DISPATCH or Free Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.FreeVariables(1)
Object.Freevariables.Item(1)

FreeVariables.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Free Object

Properties | Methods
Counter object properties | Counter object methods
CounterUse | DisplayValue
DisplayInForm |
FileName |
FormOrder |
FormPrompt |
FromAFile |
InputMask |
InputMiniLength |
Length |
LengthAuto |
PadLength |
PickListUse |
PickListUseShared |
PortWatch |
PortWatchDevicesPath |
Required |
RestoreAfterPrinting |
RestoreValue |
Shared |
SkipSpaces |
UpdateFile |
ValueFromPickList |

Object Properties

Free.CounterUse

Activates or not a counter on the object.

Access Read/Write.

Type VT_BOOL or Boolean.

Free.DisplayInForm

Includes or not the current object in the Form grid.

Access Read/Write.

Type VT_BOOL or Boolean.

Free.FileName

Sets or retrieves the file name for the "From a file" option.

Access Read/Write.

Type VT_BSTR or String.

Free.FormOrder

Specifies the order of objects in the Form grid.

Access Read/Write.

Type VT_I2 or Integer.

Free.FormPrompt

Specifies the prompt associated in the Form grid.

Access Read/Write.

Type VT_BSTR or String.

Free.FromAFile

Determines if the data is coming "From a file".

A ccess Read/Write.

Type VT_BOOL or Boolean.

Free.InputMask

Specifies the format prompt associated in the Form grid.

Access Read/Write.

Type VT_BSTR or String.

Free.InputMiniLength

Sets or retrieves the minimum length for the value of the field (value > 0 required is selected otherwise no).

Access Read/Write.

Type VT_I2 or Integer.

Free.Length

Sets or retrieves the length of the output value.

Access Read/Write.

Type VT_I4 or Long.

Free.LengthAuto

This property is related to counting and is available on all variable types supporting counters.

  • If this property is true, the Maximum length property of the variable is disabled, and its value is calculated automatically from other properties.

  • If this property is false, the Maximum length property is enabled, and the user can specify its value manually.

Access Read/Write.

Type VT_I4 or Long.

Free.PadLength

Sets or retrieves the number of characters to pad up to.

Access Read/Write.

Type VT_I2 or Integer.

Free.PickListUse

Determines if the pick list is coming from a pick list.

Access Read/Write.

Type VT_BOOL or Boolean.

Free.PickListUseShared

Returns or sets the PickListUseShared option.

Access Read/Write.

Type VT_BOOL or Boolean.

Free.PortWatch

Sets or retrieves the PortWatch name.

Access Read/Write.

Type VT_BSTR or String.

Note: If the string is empty, PortWatch is disable.

Note: If the PortWatch name exists, the device is activated.

Free.PortWatchDevicesPath

Sets or retrieves the PortWatch path.

Access Read/Write.

Type VT_BSTR or String.

Free.Required

Determines if the data is required.

A ccess Read/Write.

Type VT_BOOL or Boolean.

Free.RestoreAfterPrinting

Determines if the field value is to be reset to its initial value in cases of local/shared. In other cases no effect.

A ccess Read/Write.

Type VT_BOOL or Boolean.

Free.RestoreValue

Returns the restore value after printing.

A ccess Read/Write.

Type VT_VARIANT or Variant.

Free.Shared

Sets or not the Free variable as a shared variable.

Access Read/Write.

Type VT_BOOL or Boolean.

Format.SkipSpaces

Skips the spaces or indicates if spaces are skipped in the value of the variable.

A ccess Read/Write.

Type VT_BOOL or Boolean.

Free.UpdateFile

Determines if the file set in the "From a file" option is to be updated at the end the print process (useful if the option counter is also set to one).

Access Read/Write.

Type VT_BOOL or Boolean.

Format.ValueFromPickList

Sets or returns if the value of the variable comes from the current picklist.

A ccess Read/Write.

Type VT_BOOL or Boolean.

Object Methods

Free.DisplayValue

VT_BSTR (R only)

Returns the display value


Font Object

IFontDisp Object

Properties | Methods
Bold | none
Charset |
HFONT |
Italic |
Name |
OutPrecision |
PitchAndFamily |
Size |
Strikethrough |
Underline |
Weight |
WidthRatio |

Object Properties

IFontDisp.Bold

True if the font is boldfaced.

Access Read/Write.

Type VT_BOOL or Boolean.

IFontDisp.Charset

Sets or retrieves the character set used in the font, such as ANSI_CHARSERT, DEFAULT_CHARSERT, or SYMBOL_CHARSET.

Access Read/Write.

Type VT_I2 or Integer.

IFontDisp.HFONT

Returns or sets the Font Handle used.

Access Read/Write.

Type VT_I4 or Long.

IFontDisp.Italic

True if the font is italicized.

Access Read/Write.

Type VT_BOOL or Boolean.

IFontDisp.Name

Sets or retrieves the name of the font family (for example, the Arial font).

Access Read/Write.

Type VT_BSTR or string.

IFontDisp.OutPrecision

Sets or retrieves the output precision of the font.

Access Read/Write.

Type VT_I2 or integer.

IFontDisp.PitchAndFamily

Sets or retrieves the Pitch and Family of the font.

Access Read/Write.

Type VT_I2 or integer.

IFontDisp.Size

Sets or retrieves the current point size of the font.

Access Read/Write.

Type VT_CY.

IFontDisp.Strikethrough

True if the font is strike-through.

Access Read/Write.

Type VT_BOOL or Boolean.

IFontDisp.Underline

True if the font is underlined.

Access Read/Write.

Type VT_BOOL or Boolean.

IFontDisp.Weight

Sets or retrieves the boldness or the weight of the font.

Access Read/Write.

Type VT_I2 or Integer.

IFontDisp.WidthRatio

Sets or retrieves the font width in percentage of the height.

Access Read/Write.

Type VT_I4 or Long.


Images Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

Images.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Images.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Images.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Images.Add

VT_DISPATCH or Image Add(strImageName).

Adds a new Image object to the collection.

Return value: Returns a Image object.

Parameters:
strImageName Optional VT_BSTR or String. The name of the object to add.

Images.Item

VT_DISPATCH or Image Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note: If the value provided as Index does not match any existing member of the collection, none object returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note: If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. The following two lines of code are equivalent.
Object.Images (1)
Object.Images.Item(1)

Images.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection.

If a numeric expression, index must be a number from 1 to the value of the collection’s Count property.

If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Image Object

Properties | Methods
DocObject object properties | DocObject object methods
AllowSuperimposing | WriteOriginalFile
Brightness |
Contrast |
DefaultFolder |
DefaultFormat |
FileName |
FolderName |
HorzFlip |
Layers |
Method |
Negative |
NumColor |
NumMaxColor |
Picture |
Ratio |
VariableName |
VariableObject |
VertFlip Visible |

Object Properties

Image.AllowSuperimposing

Returns or sets the AllowSuperimposing option.

Access Read/Write.

Type VT_BOOL or Boolean.

Image.Brightness

This adjustment influences the color reduction process.

Access Read/Write.

Type VT_I2 or Integer (between -255 and 255).

Note
0: the image is black
255: original brightness
510: the image is white

Image.Contrast

This adjustment influences the contrast of the image. The value is a percentage of the original contrast level between 0 and 100.

Access Read/Write.

Type VT_I2 or Integer (between 0 and 100).

Note
0: original contrast level
100: high contrast level

Image.DefaultFolder

This adjustment sets or retrieves if the default folder is used to find the variable images..

Access Read/Write.

Type VT_BOOL or Boolean.

Image.DefaultFormat

Retrieves or sets the default extension used with a variable image object, when the variable does not contain the extension of the image file but just the name of the file.

Access Read/Write.

Type VT_BSTR or String.

Image.FileName

Retrieves or sets the filename of the image.

Access Read/Write.

Type VT_BSTR or String.

Image.FolderName

Defines another folder (used in conjunction with the DefaultFolder property).

Access Read/Write.

Type VT_BSTR or String.

Image.HorzFlip

Displays the image as if it is reflected in a mirror.

Reflection axis is horizontal.

Access Read/Write.

Type VT_BOOL or Boolean.

Image.Layers

This property allows to define the layers where the image object is visible.

Access Read/Write.

Type VT_I4 or EnumLayer.

Image.Method

Defines the algorithm of the reduction color palette.

Access Read/Write.

Type VT_I2 or Integer.

Note:
0: none
1: Bayer
2: Burkes
3: Floyd
8: Grayscale

Image.Negative

Prints the image negatively.

Access Read/Write.

Type VT_BOOL or Boolean.

Image.NumColors

Defines the color number of the color palette.

Access Read/Write.

Type VT_I4 or Long (between 2 and 224).

Image.NumMaxColor

Retrieves the maximum number of color supported.

Access Read-Only.

Type VT_I4.

Image.Picture

Sets or retrieves the picture holder.

Access Read/Write.

Type VT_DISPATCH or StdPicture.

Image.Ratio

Sets or retrieves the image resizing ratio.

Access Read-Only.

Type VT_I2 or Integer.

Note:
lppxImageFixedRatio = 0
lppxImageStrechable = 1
lppxImageNoneResizable = 2

Image.VariableName

Retrieves or sets the current variable name associated with the image.

Access Read/Write.

Type VT_BSTR or String.

Image.VariableObject

Retrieves or sets the current Variable object associated with the image.

Access Read/Write.

Type VT_DISPATCH or Variable object.

Image.VertFlip

Displays the image as if it is reflected in a mirror.

Reflection axis is vertical.

Access Read/Write.

Type VT_BOOL or Boolean.

Image.Visible

Allows to have image Visible or Not on the label.

This was made for internal use of Wizard : when you start create an image with the wizard, it is not visible on user interface.

Access Read/Write.

Type VT_BOOL or Boolean.

Object Methods

Image.WriteOriginalFile (FileName as string)

Writes the image that has been included in the image object at her creation.

Access Read/Write.

Type VT_BSTR or String.


LabelArchive

Properties | Methods
Available | CheckOut
Connected | Connect
HistoryMask | Disconnect
Version | GetCategories
WorksOnlyWithLabelArchive |

LabelArchive Properties

LabelArchive.Available

Return TRUE if the LabelArchive connection is still alive.

Access Read.

Type VT_BOOL or Boolean

LabelArchive.Connected

Return TRUE if the connection is valid.

Access Read.

Type VT_BOOL or Boolean

LabelArchive.HistoryMask

Return or set the mask that defines logs that are written.

Access Read/Write.

Type VT_I4 or Long

Note: this property is a combination of values of EnumLAHistory.

LabelArchive.Version

Return the version number of the LabelArchive client.

Access Read.

Type VT_I4 or Long

LabelArchive.WorksOnlyWithLabelArchive

Sets or retrieves the window handle Use in case of print to file.

Access Read/Write.

Type VT_BOOL or Boolean

LabelArchive Methods

LabelArchive.CheckOut

VT_DISPATCH CheckOut (DocName, DocVersion, ReadOnly)

Return an IDocument interface.

Parameters

DocName Required VT_BSTR or String

DocVersion Required VT_I4 or Long

ReadOnly Required VT_BOOL or Boolean

LabelArchive.Connect

VT_BOOL or Boolean Connect (UserName, Password, ClientName, Reserved)

Establishes a connection to the LabelArchive in silent mode.

Parameters

UserName Required VT_BSTR or String

Password Required VT_BSTR or String

ClientName Required VT_BSTR or String

Reserved Required VT_I4 or Long

LabelArchive.Disconnect

VT_BOOL or Boolean Disconnect()

Closes the connection to the LabelArchive.

LabelArchive.GetCategories

VT_VARIANT or Variant GetCategories (Categories, Parent Categories)

Return a SafeArray that have all categories created in the LabelArchive database.

Parameters

Categories Required VT_BSTR or String

Parent Categories Required VT_BSTR or String


LfmInfos

LfmInfos Object

Properties | Methods
AutomaticMargins |
AutoSize |
Background |
ColumnCount |
HorizontalGap |
LabelHeight |
LabelWidth |
MarginLeft |
MarginTop |
Name |
PageHeight |
PageWidth |
PaperType |
Portrait |
RowCount |
SupportType |
Type |
VerticalGap |

Object Properties

LfmInfos.AutomaticMargins

Retrieves or sets the automatic margins.

Access Read/Write.

Type VT_BOOL or Boolean.

LfmInfos.AutoSize

Automatically adjusts the page based on the dimension of the label, the number of labels, margins and the amount of space between labels.

This option is available only for customized page formats.

Access Read/Write.

Type VT_BOOL or Boolean.

LfmInfos.Background

Sets or returns the background file.

Access Read/Write.

Type VT_BSTR or String.

LfmInfos.ColumnCount

Retrieves or sets the number of labels per row (horizontal count).

Access Read/Write

Type VT_I4 or Long.

LfmInfos.HorinzontalGap

Retrieves or sets the amount of empty space between the columns (Horizontal) of labels on a page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

LfmInfos.LabelHeight

Retrieves or sets the height of the label (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

LfmInfos.LabelWidth

Retrieves or sets the width of the label (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

LfmInfos.MarginLeft

Retrieves or sets the left margin of the page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

LfmInfos.MarginTop

Retrieves or sets the top margin of the page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

LfmInfos.Name

Retrieves or sets the name.

Access Read/Write.

Type VT_BSTR or String.

LfmInfos.PageHeight

Retrieves or sets the height of the page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

LfmInfos.PageWidth

Retrieves or sets the width of the page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

LfmInfos.PaperType

Sets or returns the paper type.

Access Read/Write.

Type VT_I4 or Long.

LfmInfos.Portrait

Retrieves or sets the orientation of the document.

Access Read/Write.

Type VT_BOOL or Boolean.

LfmInfos.RowCount

Retrieves or sets the number of labels per column (vertical count).

Access Read/Write.

Type VT_I4 or Long.

LfmInfos.SupportType

Sets or returns the support type.

Access Read/Write.

Type VT_I4 or Long or enumSupportType.

LfmInfos.Type

Retrieve or sets the type.

Access Read/Write.

Type VT_BSTR or String.

LfmInfos.VerticalGap

Retrieves or sets the amount of empty space between the row (Vertical) of labels on a page (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.


LogFile Object

Properties | Methods
DataSourceMode | GetOption
DateCalcul | SetOption
DateFormat |
Editor |
Enable |
FileFormat |
FileName |
PathName |
UseDocumentName |

Object Properties

LogFile.DataSourceMode

Defines or retrieves the DataSource mode used.

Access Read/Write.

Type VT_I4 or EnumLogFileDataSourceMode

LogFile.DateCalcul

Defines or retrieves the date calcul string.

Access Read/Write.

Type VT_BSTR or String.

LogFile.DateFormat

Defines or retrieves the date format string

Access Read/Write.

Type VT_BSTR or String.

LogFile.Editor

Defines or retrieves the editor application name.

Access Read/Write.

Type VT_BSTR or String.

LogFile.Enable

Enables or disables the printing log file.

Access Read/Write.

Type VT_BOOL or Boolean.

LogFile.FileFormat

Defines or retrieves the file format used.

Access Read/Write.

Type VT_I4 or EnumLogFileFormat

LogFile.FileName

Defines or retrieves the filename of the report file.

Access Read/Write.

Type VT_BSTR or String.

LogFile.PathName

Retrieves the current pathname of the report file.

Access Read-Only.

Type VT_BSTR or String.

LogFile.UseDocumentName

If true, the report file name is based on the document name.

Access Read/Write.

Type VT_BOOL or Boolean.

Object Methods

LogFile.GetOption

VT_BOOL or Boolean GetOption( Option as EnumLogFileOption)

Returns the state of the specified option.

LogFile.SetOption

VT_None SetOption( Option as EnumLogFileOption, NewValue as boolean or VT_BOOL )

Sets the state of the specified option.


OLEObjects Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

OLEObjects.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

OLEObjects.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

OLEObjects.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

OLEObjects.Add

VT_DISPATCH or OLEObject Add( strOLEObjectName ).

Adds a new OLEObject object to the collection.

Return value: Returns a OLEObject object.

Parameters:
strOLEObjectName Required VT_BSTR or String. The name of the object to add.

OLEObjects.Item

VT_DISPATCH or OLEObject Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.OLEObjects (1)
Object.OLEObjects.Item(1)

OLEObjects.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


OLEObject Object

Properties | Methods
DocObject object properties | ConnectServer
AllowSuperimposing | CreateFromNativeOLEObject
ConnectedServer | DocObject object methods
Layers | EmbedFile
LinkedFileName | LinkFile
Object |
Visible |

Object Properties

OLEObject.AllowSuperimposing

Returns or sets the AllowSuperimposing option.

Access Read/Write.

Type VT_BOOL or Boolean.

OLEObject.ConnectedServer

Sets or returns the name of the connected server.

Access Read/Write.

Type VT_BSTR or String.

OLEObject.Layers

This property allows to define what are the layer(s) used by an OLE object.

Access Read/Write.

Type VT_I4 or EnumLayer.

OLEObject.LinkedFileName

Sets or returns the name of the linked file.

Access Read/Write.

Type VT_BSTR or String.

OLEObject.Object

Returns directly the IDispatch interface of the object.

Access Read-Only.

Type VT_DISPATCH.

OLEObject.Visible

Allows to have object Visible or Not on the label.

This was made for internal use of Wizard : when you start create an object with the wizard, it is not visible on user interface.

Access Read/Write.

Type VT_BOOL or Boolean.

Object Methods

OLEObject.ConnectServer

VT_BOOL or Boolean ConnectServer( strCLSIDorPROGIDServerName ).

Connects the object to an OLE server (see Insert OLE object dialog box).

Return value: Returns the result of the connection.

Parameters:
strCLSIDorPROGIDServerName Required VT_BSTR or String. The CLSID with brackets or directly the name of the OLE server.

OLEObject.CreateFromNativeOLEObject

VT_BOOL or Boolean CreateFromNativeOLEObject( strFileName).

Export to a file the original OLE object.

Return value: Returns the result

Parameters:

strFileName Required VT_BSTR or String. The name of the filename to save to.

OLEObject.EmbedFile

VT_BOOL or Boolean EmbedFile( strOLEFileNameToConnect ).

Connects the object to a file (see Insert OLE object dialog box).

Return value: Returns the result of the connection.

Parameters:
strOLEFileNameToConnect Required VT_BSTR or String. The name of the filename to connect to.

OLEObject.LinkFile

VT_BOOL or Boolean LinkFile( strOLELinkFileNameToConnect ).

Connects the object to a file (see Insert OLE object dialog box).

Return value: Returns the result of the connection.

Parameters:
strOLELinkFileNameToConnect Required VT_BSTR or String. The name of the linkfilename to connect to.


Options Object

Properties | Methods
AnimateUI | (None)
Application |
AutoSaveTimeout |
CreateBackup |
DefaultDataLinkPath |
DefaultDataPath |
DefaultDescriberPath |
DefaultDocumentPath |
DefaultImagePath |
DefaultLFMsPath |
DefaultPrintOutPath |
DefaultQueryPath |
DefaultSharedVarPath |
DefaultTemplatesPath |
DefaultUserSettingsPath |
DoNotDisplayWarning EnableTestPrinting |
EuroConversionRate |
Font |
HFONT |
Language |
LoadPrinter |
LoadPrinterSetup |
MeasureSystem |
OpenMergeDatabase |
OpenReadOnly |
Parent |
PrintEvalMode |
SharedFileAccessTimeout |
SettingsMode |
TrayNotification |
UpdateDateDuringPrinting |
UseGS1Norm Visible |

Object Properties

Options.AnimateUI

Returns or sets the AnimateUI option.
If this option is checked, animation effects are activated.

Access Read/Write.

Type VT_BOOL or Boolean.

Options.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Options.AutoSaveTimeout

This property sets or retrieves the timeout for auto save document. 0 means that the auto save is not actived.

Access Read/Write.

Type VT_I4.

Options.CreateBackup

Returns or sets the CreateBackup option. (Default: True).

Access Read/Write.

Type VT_BOOL or Boolean.

Options.DefaultDataLinkPath

Returns the DefaultDataLinkPath option.

Access Read-Only

Type VT_BSTR or String.

Options.DefaultDataPath

Returns or sets the Default Path for data files.

Access Read/Write.

Type VT_BSTR or String.

Options.DefaultDescriberPath

Returns or sets the DefaultDescriberPath option.

Access Read/Write.

Type VT_BSTR or String.

Options.DefaultDocumentPath

Sets or returns the default document folder.

Access Read/Write.

Type VT_BSTR or String.

Options.DefaultImagePath

Returns or sets the DefaultImagePath option.

Access Read/Write.

Type VT_BSTR or String.

Options.DefaultLFMsPath

Returns or sets the path for the LFM Files

Access Read/Write.

Type VT_BSTR or String.

Options.DefaultPrintOutPath

Returns or sets the DefaultPrintOutPath option.

Access Read/Write.

Type VT_BSTR or String.

Options.DefaultQueryPath

Returns or sets the DefaultQueryPath option.

Access Read/Write.

Type VT_BSTR or String.

Options.DefaultSharedVarPath

Returns or sets the DefaultSharedVarPath option.

Access Read/Write.

Type VT_BSTR or String.

Options.DefaultTemplatesPath

Returns or sets the path for the templates labels

Access Read/Write.

Type VT_BSTR or String.

Options.DefaultUserSettingsPath

Returns or sets the DefaultUserSettingsPath option.

Access Read/Write.

Type VT_BSTR or String.

Options.DoNotDisplayWarning

Returns or sets the "Do not display warning" option. (Default: False)

Access Read/Write.

Type VT_BOOL

Optiond.EnableTestPrinting

Returns or sets the "Enable test printing" option. (Default: False)

Access Read/Write.

Type VT_BOOL

Options.EuroConversionRate

Returns or sets the EuroConversionRate option. (Default 6.55957).

Access Read/Write.

Type VT_R4 or Single.

Options.Font

Returns or sets the Font Object used in the user interface. This object implements the IFontDisp.

Access Read/Write.

Type VT_DISPATCH or StdFont

Options.HFONT

Returns or sets the Font Handle used in the user interface.

Access Read/Write.

Type VT_I4 or Long.

Options.Language

Returns or sets the Language option.

Access Read/Write.

Type VT_I2 or Integer or enumLanguage type.

Note: Depending on the product, not all languages are available.=

Options.LoadPrinter

Returns or sets the LoadPrinter option. (Default : False).

Access Read/Write.

Type VT_BOOL or Boolean.

Options.LoadPrinterSetup

Returns or sets the LoadPrinterSetup option. (Default : True).

Access Read/Write.

Type VT_BOOL or Boolean.

Options.MeasureSystem

Returns or sets the MeasureSystem option. (Default : lppxMillimeter).

Access Read/Write.

Type VT_I2 or Integer or enumMeasureSystem type.

Note: Using lppxMillimeter unit means that values entered are in Millimeter per cent.
Using lppxInch unit means that values entered are in Inch per thousand.

Options.OpenMergeDatabase

Returns or sets the OpenMergeDatabase option. (Default: False)

Access Read/Write.

Type VT_BOOL or Boolean.

Options.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Options.PrintEvalMode

Allows printing in evaluation mode

Access Read/Write.

Type VT_BOOL or Boolean.

Options.OpenReadOnly

Returns or sets the OpenReadOnly option. (Default : False)

Access Read/Write.

Type VT_BOOL or Boolean.

Options.SharedFileAccessTimeout

Returns or sets the SharedFileAccessTimeout option. (Default: 10000 ms)

Access Read/Write.

Type VT_I4 or Long.

Options.SettingsMode

Sets or retrieves the Settings mode.

Access Read/Write.

Type VT_I2 or integer or enumSettingsMode

Options.TrayNotification

Enables or disables notification of printing in System Tray Bar. (Default: True)

Access Read/Write.

Type VT_BOOL or Boolean.

Options.UpdateDateDuringPrinting

Evaluates the date during the print job if set to True. Or, if set to False, it will evaluate the date before printing.

Access Read/Write.

Type VT_BOOL or Boolean.

Options.UseGS1Norm

Enables control rules for EAN.UCC normalization.

Access Read/Write.

Type VT_BOOL or Boolean.

Options.Visible

True if the Use GS1 norm option is activated.

Access Read/Write.

Type VT_BOOL or Boolean.


PickList Object

Properties | Methods
Application | AddValue
DefaultId | DeleteValue
ForceValueFromList | GetSize
MaxLength | GetValue
MiniLength | SetValue
Name | ShowDialog
Parent |
Shared |

Object Properties

PickList.Application

Retrieves the application.

Access Read only.

Type VT_DISPATCH.

PickList.DefaultId

Sets or retrieves the default ID.

Access Read/Write.

Type VT_I2 or Integer.

PickList.ForceValueFromList

Determines if the data is coming from a "Pick List".

Access Read/Write.

Type VT_BOOL or Boolean.

PickList.MaxLength

Sets or retrieves the maximum length from data issue of the pick list file.

A ccess Read/Write.

Type VT_I2 or Integer.

PickList.MiniLength

Sets or retrieves the minimum length from data issue of the pick list file. (value > 0 required is selected otherwise no).

Access Read/Write.

Type VT_I2 or Integer.

PickList.Name

Sets or retrieves the file name for the "Pick List".

Access Read/Write.

Type VT_BSTR or String.
PrickList.Parent

Retrieves his parent

Access Read only.

Type VT_DISPATCH.

PickList.Shared

Determines if the pick list is shared.

Access Read/Write.

Type VT_BOOL or Boolean.

Object Methods

PickList.AddValue

VT_BOOL AddValue(VT_BSTRsValue)

Adds a value.

PickList.DeleteValue

VT_BOOL DeleteValue(VT_VARIANTvValue)

Deletes a value

PickList.GetSize

VT_I2 GetSize()

Returns the number of value.

PickList.GetValue

VT_BSTR GetValue(VT_I2iId)

Retrieves value from ID.

PickList.SetValue

VT_NONE SetValue(VT_I2ild, VT_BSTRsValue)

Sets value for an ID.

PickList.ShowDialog

VT_BOOL ShowDialog(VT_VARIANTvarParent)

Displays the pick list dialog box with the current free object properties.


Printer Object

Properties | Methods
Application DeviceCodeNames | GetDevMode GetParameter
DeviceFontNames | IsDevice
DriverName | Papers
FullName (Default) | Send
InitialPrinterName | SetDevMode
MarginLeft | SetDevModeA
MarginTop | SetParameter
ModelName | ShowSetup
Name | Supports
Parent | SwichTo
WindowsCodeNames | SwitchToEx
WindowsFontNames |
XDPI |
YDPI |

Object Properties

Printer.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Printer.DeviceCodeNames

Returns the Strings collection that represents all the printer code names.

Access Read-Only.

Type VT_DISPATCH or Strings collection.

Printer.DeviceFontNames

Returns the Strings collection that represents all the printer fonts names.

Access Read-Only.

Type VT_DISPATCH or Strings collection.

Printer.DriverName

Retrieves the name (code) of the driver (example PZ instead of Zebra)

Access Read-Only.

Type VT_BSTR or String.

Printer.FullName

Returns the full name of the pair <Printer, Port>.

Access Read-Only.

Type VT_BSTR or String.

Printer.InitialPrinterName

Returns the initial printer name ("OemName;PortName")

Access Read-Only.

Type VT_BSTR or String.

Printer.MarginLeft

Returns the margin left of the printer (in MeasureSystem unit)

Access Read-Only.

Type VT_R4 or Float.

Printer.MarginTop

Returns the margin top of the printer (in MeasureSystem unit)

Access Read-Only.

Type VT_R4 or Float.

Printer.ModelName

Retrieves the name of the model driver (example Z140)

Access Read-Only.

Type VT_BSTR or String.

Printer.Name

Returns the simple name of the current printer.

Access Read/Write.

Type VT_BSTR or String.

Printer.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Printer.WindowsCodeNames

Returns the Strings collection that represents all the windows code names.

Access Read-Only.

Type VT_DISPATCH or Strings collection.

Printer.WindowsFontNames

Returns the Strings collection that represents all the windows font names.

Access Read-Only.

Type VT_DISPATCH or Strings collection.

Printer.XDPI

Returns the horizontal resolution of the printer (in DPI).

Access Read-Only.

Type VT_I4 or Long.

Printer.YDPI

Returns the vertical resolution of the printer (in DPI).

Access Read-Only.

Type VT_I4 or Long.

Object Methods

Printer.GetDevMode

VT_VARIANT GetDevMode (pDevMode As Variant)

Returns the number of bytes copied into the array pDevMode. If the parameter pDevMode is null, the number of bytes required for copying the data structure is returned.

Printer.GetParameter

VT_BOOL or Boolean GetParameter(var Parameter, varValue).

Gets the current printer settings. See the list.

P arameters:
varParameter Required VT_VARIANT or Variant. Parameter name to use. This variant must be VT_BSTR or String if the Property Name is used or it must be VT_I4 or Integer if Property ID is used.

varValue Required VT_VARIANT or Variant. Value to set. See the list for the correct type.

Printer.IsDevice

VT_BOOL IsDevice ().

Indicates whether the driver is an internal driver or is a windows driver.

Printer.Papers

VT_VARIANT Papers()

Retrieves papers list.

Printer.SetDevMode

VT_VARIANT SetDevMode (DevMode As Variant)

Returns the number of bytes copied from the array pDevMode into the internal DevModeW structure.

If the pDevMode parameter is null, the internal DevMode is reset to the default values.

Printer.SetDevModeA

VT_I4 or Long SetDevModeA(VT_VARIANT As varParent).

Sets the DevMode for the current THT printer.

Return value: size of current devmode.

Parameters:

VT_VARIANT DevMode to be set

Printer.Send

VT_BOOL Send ( strEscapeSequence ).

Sends an escape sequence to the physical device.

Parameters:
EscapeSequence Required VT_BSTR or String. Escape sequence to send.

Printer.SetParameter

VT_BOOL or Boolean SetParameter(var Parameter, varValue).

Sets the current printer settings. To display the list of available settings, click here.

Note
A tool is available on the install CD. It allows you to verify which printer settings are supported by your printer model.

Parameters:

varParameter Required VT_VARIANT or Variant. Parameter name to use. This variant must be VT_BSTR or String if the Property Name is used or it must be VT_I4 or Integer if Property ID is used.

varValue Required VT_VARIANT or Variant. Value to set. See the list for the correct type.

Printer.ShowSetup

VT_I2 ShowSetup().

Prompts the Printer Setup dialog box, in order to change the current printer settings.

Printer.Supports

VT_DISPATCH or Strings

Retrieves supports list.

Printer.SwitchTo

VT_BOOL SwitchTo( strPrinterName, strPortName, boolDirectAccess ).

Changes the current printer.

Return value: True if success

Automatically installs a printer if no printer is already installed. You don’t need to add a printer through the user interface.

Parameters:
strPrinterName Required VT_BSTR or String. Printer ’r;s name to switch to.

strPortName Optional VT_BSTR or String. Port’s name to switch to.

boolDirectAccess Optional VT_BOOL or Boolean. Is the connection of the port direct or not.

Form 1

Printer.SwitchTo(« THTPrinter L-1234 », « LPT1: », FALSE).
Result of this instruction is « THTPrinter L-1234,LPT1: ».

Form 2

Printer.SwitchTo(« THTPrinter L-1234, ->COM3: »).
Result of this instruction is « Copy of THTPrinter L-1234, ->COM3: » because printer’s name is unique.

You can either use form 1 or form 2.

Don't insert spaces between the components in Form 2.

Notice that the names are case sensitive !

Printer.SwitchToEx

VT_BOOL SwitchToEx( strPrinterName, strPortName, boolDirectAccess, Flags ).

Changes the current printer.

Return value: True if success

Automatically installs a printer if no printer is already installed. You don’t need to add a printer through the user interface.

Parameters:
strPrinterName Required VT_BSTR or String. Printer’s name to switch to.

strPortName Optional VT_BSTR or String. Port’s name to switch to.

boolDirectAccess Optional VT_BOOL or Boolean. Is the connection of the port direct or not.

Flags Optional VT_I4 or long or enumSwitchToExFlags . Flag to indicate options.

Example

Printer.SwitchToEx(« THTPrinter L-1234 », « LPT1: », FALSE, 1).

Result of this instruction is « THTPrinter L-1234,LPT1: ».


PrinterSystem Object

Properties | Methods
(None) | Add
 | Families
 | Models
 | Ports
 | PrinterInfos
 | Printers
 | Remove
 | Rename

Object Methods

PrinterSystem.Add

VT_BSTR or String Add (strPrinterName, strPortName, boolDirectAccess)

Installs a new printer and returns the full name assigned to it.

Parameters:
strPrinterName Required VT_BSTR or String. PrinterName to install (got with Printers.InternalPrinters)

strPortName Required VT_BSTR or String. PortName associated with the printer

boolDirectAccess Optional VT_BOOL or Boolean(default value FALSE). Is the port used with direct access or not

Note1: Only internal printers can be installed with this method.

Note2: Returns an empty string if the installation has failed.

Caution: the strPortName must be exact string of the port name (for example ("LPT1:")

PrinterSystem.Families

VT_DISPATCH or Strings Families ()

Retrieves printer families list.

PrinterSystem.Models

VT_DISPATCH or Strings Models ( strFamilyName)

Retrieves models associated with a family.

Parameters:
strFamilyName Optional VT_BSTR or String. It specifies the Family for which the models list is needed. If none, it returns the full models list.

PrinterSystem.Ports

VT_DISPATCH or Strings Ports ().

Retrieves all installed ports on the system.

PrinterSystem.PrinterInfos

VT_VARIANT PrinterInfos(VT_BSTR strPrinterName).

Returns the 2-dimensional array of printer properties (may be cast to String[,]).

Parameters:

VT_BSTR target printer name

Return value type: VT_VARIANT.

PrinterSystem.Printers

VT_DISPATCH or Strings Printers ( intKindOfPrinters)

Retrieves installed printers as string pairs < Printer, Port >.

Parameters:
intKindOfPrinters Optional VT_I2 or Integer or enumKindOfPrinters.(default lppxInternalPrinters).

PrinterSystem.Remove

VT_NONE Remove (strPrinterPortName).

Removes an installed printer.

Parameters:
strPrinterPortName Required VT_BSTR or String. Full name of an installed printer (got with PrinterSystem.Printers(lppxInternalPrinters) method).

Note: Only models can be removed.

If an active document uses this printer, the operation fails.

PrinterSystem.Rename

VT_NONE Rename (strPrinterName, strNewPrinterName).

Renames a model.

Parameters:
strPrinterName Required VT_BSTR or String. Name of the installed printer to rename.

strNewPrinterName Required VT_BSTR or String. New name to assign.

Note: Only models can be renamed.


RecentFiles Collection

Properties | Methods
Application | Add
Count | Item (Default)
Maximum | Clear
Parent | Remove

Object Properties

RecentFiles.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

RecentFiles.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I4 or Long.

RecentFiles.Maximum

Returns or sets the maximum number of items in the specified collection (from 0 to 16).

Access Read/Write.

Type VT_I4 or Long.

RecentFiles.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

RecentFiles.Add

VT_DISPATCH or RecentFile Add(DocumentReference, boolReadOnly).

Adds a document reference to the collection and in the File menu.

Parameters:
DocumentReference Required VT_VARIANT or Variant. This reference must be unique in the collection.

boolReadOnly Optional VT_BOOL or Boolean. If document must be opened, it will be opened with ReadOnly attribute.

RecentFiles.Clear

VT_NONE Clear.

Resets the collection and clears menu.

RecentFiles.Item

VT_DISPATCH or RecentFile Item( intIndex ).

Returns a member of a collection, by position (default method).

Note: I f the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
Index Required VT_I2 or Integer. The index number of a member of the collection.

The index must be a numeric expression (a number from 1 to the value of the collection’s Count property, or a constant.

Note: If the value provided as Index doesn’t match any existing member of the collection, an error occurs.

The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.

Object.RecentFiles(1)
Object.RecentFiles.Item(1)

RecentFiles.Remove

VT_NONE Remove( intIndex ).

Deletes object with intIndex index.

Parameters:
intIndex Required VT_I2 or Integer.


RecentFile Object

Properties | Methods
Application | Open
Parent |
Path |
Name |

Object Properties

RecentFile.Application

Returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

RecentFile.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

RecentFile.Path

Returns the path associated with the current filename (always without « \ » character at the end).

Access Read-Only.

Type VT_BSTR or String.

RecentFile.Name

Returns the name associated with the current filename.

Access Read-Only.

Type VT_BSTR or String.

Object Methods

RecentFile.Open

VT_DISPACTCH or Document Open().

Opens the document associated with the current filename.


RfTag Default Settings Appendix

This board defines the RfTag default settings.

  • Common Settings

  • Philips I-Code

  • Philips I-Code SLI - ISO15693

  • Ti Tag-It

  • Inside Tech - Pico Tag

  • Infineon - ISO 15693

  • Philips - ISO 15693

  • Ti - ISO 15693

  • TagSys

  • MIFARE - ISO 14443

  • EPC

  • UCODE - ISO18000

Common Settings :

Property | Range | Step | Default Value | Hidden | Use global measure unit
Top | 0 &endash; 1000 | 0.1 | 0 |  | Yes
Left | 0 &endash; 1000 | 0.1 | 0 |  | Yes
Height | 0 &endash; 1000 | 0.1 | 30 |  | Yes
Width | 0 &endash; 1000 | 0.1 | 30 |  | Yes
Antenna Gap | 0 &endash; 1000 | 0.1 | 0 | Yes | Yes
Blocks retries | 0 &endash; 10 | 1 | 0 | Yes |
Unique ID retries | 0 &endash; 10 | 1 | 0 | Yes |
Blocks locked | TRUE or FALSE |  | FALSE | Yes |
Block Output Format | Ascii, Hexa |  | Ascii | Yes |
Write empty blocks | TRUE or FALSE |  | FALSE | Yes |
Blocks access | Write or Read |  | Write | Yes |
Error handling | No Action, PausePrinter or ErrorPrinter |  | NoAction | Yes |
Blocks fields structures filters | All, Only equal |  | All | Yes |
Motion Mode | OnRead, OnWrite or OnUniqueID |  | Null | Yes |
Label retries | 0 &endash; 10 | 1 | 0 | Yes |
Label void printout length | 0 &endash; 10 000 | 100 | 0 | Yes |
Label void printout text |  |  | " " | Yes |
Vertical chip offset | 0 &endash; 10 000 | 100 | 0 | Yes |
Unique ID |  |  | " " | Yes |
Linked object list |  |  | " " | Yes |
Tag |  |  | " " | Yes |
Picture name |  |  | " " | Yes |
Picture brightness | -255 &endash; 255 | 10 | 0 |  |
Picture contrast | -255 &endash; 255 | 10 | 0 |  |
Picture flip | Horizontal and/or Vertical |  | None | Yes |
Visible block columns | Num, Name, Value, Access, Datasource, Format, Size, Lock, Retries, Verifydata |  | all without Verifydata | Yes |

Philips I-Code :

Reserved bocks : 3, 4 or 5, default 3.

Block# | Description | Bytes | Supported attributes
0 | Serial Number (write protected) | 4 | Read, retry.
1 | Serial Number (write protected) | 4 | Read, retry.
2 | Write Protect Block | 4 | Read, write, retry.
3 | Special Function Block | 4 | Read, write, lock, retry.
4 | Family Code | 4 | Read, write, lock, retry.
5 | User Data | 4 | Read, write, lock, retry.
6 | User Data | 4 | Read, write, lock, retry.
7 | User Data | 4 | Read, write, lock, retry.
... |  | 4 | Read, write, lock, retry.
13 | User Data | 4 | Read, write, lock, retry.
14 | User Data | 4 | Read, write, lock, retry.
15 | User Data | 4 | Read, write, lock, retry.

Philips I-Code SLI - ISO15693 :

Reserved bocks : 4, default 4.

Block# | Description | Bytes | Supported attributes
0 | Serial Number (write protected) | 4 | Read, retry.
1 | Serial Number (write protected) | 4 | Read, retry.
2 | Write Protect Block | 4 | Read, write, lock, retry.
3 | Special Function Block | 4 | Read, write, lock, retry.
4 | Family Code | 4 | Read, write, lock, retry.
5 | User Data | 4 | Read, write, lock, retry.
6 | User Data | 4 | Read, write, lock, retry.
7 | User Data | 4 | Read, write, lock, retry.
... |  | 4 | Read, write, lock, retry.
29 | User Data | 4 | Read, write, lock, retry.
30 | User Data | 4 | Read, write, lock, retry.
31 | User Data | 4 | Read, write, lock, retry.

TI Tag-It :

Block# | Description | Bytes | Supported attributes
0 | User Data | 4 | Read, write, lock, retry.
1 | User Data | 4 | Read, write, lock, retry.
2 | User Data | 4 | Read, write, lock, retry.
3 | User Data | 4 | Read, write, lock, retry.
4 | User Data | 4 | Read, write, lock, retry.
5 | User Data | 4 | Read, write, lock, retry.
6 | User Data | 4 | Read, write, lock, retry.
7 | User Data | 4 | Read, write, lock, retry.

Inside Tech - Pico Tag :

Reserved bocks : 3, default 3.

Block# | Description | Bytes | Supported attributes
0 | Serial Number (64 bits) | 8 | Read, retry.
1 | Tag configuration | 8 | Read, write.
2 | Application Issuer Area | 8 | Read, write, retry.
3 | Application Area | 8 | Read, write, retry.
4 | Application Area | 8 | Read, write, retry.
5 | Application Area | 8 | Read, write, retry.
6 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
7 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
8 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
9 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
10 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
11 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
12 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
13 | User Data | 8 | Read, write, retry.
... |  | 8 | Read, write, retry.
29 | User Data | 8 | Read, write, retry.
30 | User Data | 8 | Read, write, retry.
31 | User Data | 8 | Read, write, retry.

Infineon - ISO15693 :

Reserved bocks : 3, default 3.

Block# | Description | Bytes | Supported attributes
0 | Unused Area | 8 | Read, retry.
1 | Unused Area | 8 | Read, write.
2 | Unused Area | 8 | Read, write, retry.
3 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
4 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
5 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
6 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
7 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
... |  | 8 | Read, write, lock, retry.
122 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
123 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.
124 | Block Write Lockable Application Area | 8 | Read, write, lock, retry.

Philips - ISO15693 :

Block# | Description | Bytes | Supported attributes
0 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
1 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
2 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
3 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
4 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
5 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
6 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
7 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
... |  | 4 | Read, write, lock, retry.
25 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
26 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
27 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.

TI - ISO15693 :

Block# | Description | Bytes | Supported attributes
0 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
1 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
2 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
3 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
4 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
5 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
6 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
7 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
... |  | 4 | Read, write, lock, retry.
61 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
62 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.
63 | Block Write Lockable Application Area | 4 | Read, write, lock, retry.

TagSys :

Class | Block Range | Size in Bytes | Supported Attributes
C210 | 0 &endash; 0 | 8 | Read, retry.
C220 | 0 &endash; 0 | 16 | Read, write, retry.
C230 | 0 &endash; 7 | 32 | Read, write, retry.

MIFARE - ISO14443 :

Class | Block Range | Size in Bytes | Supported Attributes
Ultra Light | 0 &endash; 15 | 4 | Read, write, retry.
Standard 1k | 0 &endash; 15 | 64 | Read, write, retry.
Standard 4k | 0 &endash; 31 | 64 | Read, write, retry.
 | 32 &endash; 39 | 256 | Read, write, retry.

EPC :

Class | Block size in bytes | Supported attributes
Philips HF | 12 | Read, write, retry.
Matrics Class 0 64 | 8 | Read and retry.
Matrics Class 0 96 | 12 | Read and retry.
Alien Class 1 64 | 8 | Read, write, lock, retry and verify data.
Alien Class 1 96 | 12 | Read, write, lock, retry and verify data.
Alien Class 1 128 | 16 | Read, write, lock, retry and verify data.
Alien Class 1 256 | 32 | Read, write, lock, retry and verify data.
Matrics Class 0 Plus 64 | 8 | Read, write, retry.
Matrics Class 0 Plus 96 | 12 | Read, write, retry.
Matrics Class 0 Plus 128 | 16 | Read, write, retry.
Matrics Class 0 Plus 256 | 32 | Read, write, retry.
UCode EPC 1.19 256 | 32 | Read, write, retry.

UCODE - ISO18000 :

Class | Block Range | Size in Bytes | Supported Attributes
Hsl | 0 &endash; 1 | 4 | Read, retry.
 | 2 | 4 | Read, write, lock and retry.
 | 3 &endash; 55 | 4 | Read, write, lock and retry.
Epc 1.19 | 0 &endash; 7 | 4 | Read, write, lock and retry.


RfTag Event

RfTag Event (See RfTag Default Settings)

Properties | Methods
(None) | GetDataSourceDesc
 | GetDataSourceValue
 | GetSystemInfo
 | SetDataSourceValue
 | SetError

Object Methods

RfTagEvent.GetDataSourceDesc

VT_BSTR or String GetDataSourceDesc(Item As Variant, format As String).

The client returns a string that contains required datasource entries specified by the format string (ie : format is "Name=%s;ID=%d;Size=%d") for the datasource Item (by the name or by ID).

RfTagEvent.GetDataSourceValue

VT_BOOL or Boolean GetDataSourceValue(Item As Variant, ByRef Value As Variant).

Returns TRUE if the client returns the value for the datasource Item (by name or by ID).

RfTagEvent.GetSystemInfo

VT_BSTR or String GetSystemInfo(Group As Long, format As String).

The client returns a string that contains the required system entries specified by the format string (ie : format is "LCID=%d;HFont=%d;UnitText=%s;SpinInc=%d;InputUnitFmt=%s;OutputUnitFmt=%s").

RfTagEvent.SetDataSourceValue

VT_BOOL or Boolean SetDataSourceValue(Item As Variant, Value As Variant).

Returns TRUE if the client sets the value for the datasource Item (by name or by ID).

RfTagEvent.SetError

VT_BOOL or Boolean SetError(Code as EnumErrorCode, Item As Variant, ByRef Value As Variant).

Returns TRUE if the client changes the value for an error correction.


RfTag Object

RfTag Object (See RfTag Default Settings)

Properties | Methods
BlockCount | AppendBlock
BlocksAreWriteOnly | AppendProperty
BlocksValueWithLinkedObject BlocksStoredValuesCount Frequency hWnd ID ISO Language LastDataBlock LinkedObjectNames MeasureSystem Memory Name PropertyCount | BoundingRect ClearAllBlocksStoredValues DeleteProperty EndDialog GetBlock GetLinkedObjectInfo GetProperty GetPropertyID RenameLinkedObject Render StoreBlocksValues Serialize RestoreBlocksValues ShowDialog SourceFile

Object Properties

RfTag.BlockCount

Returns or sets the number of blocks.

Access Read/Write.

Type VT_I4 or Long.

RfTag.BlocksAreWriteOnly

Returns TRUE if all blocks are set with the rftagBlockWrite attribute (see EnumRfTagBlockAttribute).

Access Read-Only.

Type VT BOOL or Boolean.

RfTag.BlocksValueWithLinkedObject (LinkedObjectName As String)

Returns or sets a global string value from each block referenced by the linked object name.

Access Read/Write.

Type VT_BSTR or String.

RfTag.BlocksStoredValuesCount

Returns the count of stored values in a block (it is the same number for all the blocks).

Access Read-Only.

Type VT_I4 or Long.

RfTag.Frequency

Returns the frequency in kHz.

Access Read-Only.

Type VT_I4 or Long.

RfTag.hWnd (Dialog As EnumRfTagDlg)

Returns the window handle for the specified dialogbox identifier.

Access Read-Only.

Type VT_I4 or OLE_HANDLE.

RfTag.ID

Returns the identifier number.

Access Read-Only.

Type EnumRfTagID

RfTag.ISO

Returns the supported list of ISO norm separated by ";" ( "14443","15693","18000","EPC" ).

Access Read-Only.

Type VT_BSTR or String.

RfTag.Language

Returns or sets the language identifier used for the library resources.

Access Read/Write.

Type EnumLanguage

RfTag.LastDataBlock

Returns the index of the last block filled (if all bytes of a block are set to zero, the block is empty).

Access Read-Only.

Type VT_I4 or Long

RfTag.LinkedObjectNames

Returns the list of the linked object names with their EnumRfTagBlockAttribute referenced in all blocks (ie : "name1=attr1;name2=attr2;name3=attr3;".

Access Read-Only.

Type VT_BSTR or String

RfTag.MeasureSystem

Sets or returns the measure system identifier used for metrics conversion.

Access Read/Write.

Type EnumMeasureSystem

RfTag.Memory

Returns the global memory size.

Access Read-Only.

Type VT_I4 or Long

RfTag.Name

Returns or sets the name.

Access Read/Write.

Type VT_BSTR or String

RfTag.PropertyCount

Returns or sets the number of properties.

Access Read/Write.

Type VT_I4 or Long

Object Methods

RfTag.AppendBlock

VT_I4 or Long AppendBlock(Name as String, Size as Long, SupportedAttributes as EnumRfTAgBlockAttribute, SuppportedDataTypes As EnumRfTagBlockDataType, Range As Long).

Append Range blocks at the end of the block array and set for each block Name, Size, SupportedAttibutes and SupportedDataTypes property.

RfTag.AppendProperty

VT_I4 or Long AppendPropery(Name as String, ID as Long, DataType as Long, CtrlType As EnumRfTagCtrlType, Entries as String, Flags As Long, Range As Long).

Append Range properties at the end of the block array and set for each block Name, ID, DataType, CtrlType, Entries and Flags property.

RfTag.BoundingRect

VT_I4 or Long BoundingRect(Rect as Long).

Returns the bounding rectangle for the representation in millimeter unit.

RfTag.ClearAllBlocksStoredValues

ClearAllBlocksStoredValues().

Resets to zero all stored values in each block.

RfTag.DeleteProperty

VT_I4 or Long DeleteProperty(Index as Long, Range as Long).

Deletes Range properties at the Index position and returns the real number of deleted properties.

RfTag.EndDialog

VT_BOOL or Boolean EndDialog(Dialog As EnumRfTagDlg, Result As Long).

Calls the EndDialog to the specified dialogbox, Result can be set to IDOK or IDCANCEL.

RfTag.GetBlock

RfTagBlock or Long GetBlock(Index As Long).

Returns the Block object to the Index position.

RfTag.GetLinkedObjectInfo

VT_BSTR or String GetLinkedObjectInfo(Item As Variant, format As String).

The client returns a string that contains the required datasource entries specified by the format string for the datasource Item, If format is NULL, the default format string is used (see GetDataSourceDesc on the RfTagEvent).

RfTag.GetProperty

RFTagProperty GetProperty(Index As Long).

Returns the Property object to the Index position.

RfTag.GetPropertyID

RFTagPropertyID GetPropertyID(Index As EnumRfTagPropertyID).

Returns the Property object specified by the Index identifier

RfTag.RenameLinkedObject

RenameLinkedObject(OldName As String, NewName As String).

Renames all references of the linked object name OldName used in the RfTag (properties and blocks) by NewName (remove if NewName is empty).

RfTag.Render

VT_BOOL or Boolean Render(hdc As OLE_HANDLE, x As Long, y As Long, cx As Long, cy As Long, rotation As Long).

Draws the RfTag picture in the hdc device context.

RfTag.StoreBlocksValues

VT_BOOL or Boolean StoreBlocksValues(Index As Long).

Stores the current value of each block in the Index memory block.

RfTag.Serialize

VT_BOOL or Boolean Serialize(Stream As Unknown, bStoring As Long).

Serializes object in the IStream interface in XML format (write if bStoring is true or read if is false).

RfTag.RestoreBlocksValues

VT_BOOL or Boolean RestoreBlocksValues(Index As Long).

Restores for each block the stored value memorized in the Index memory block.

RfTag.ShowDialog

VT_I4 or Long ShowDialog(Type As EnumRfTagDlg, Options As Long, Parent As Long).

Shows the dialogbox specified by the Type identifier Options can be set to WS_CHILD.

RfTag.SourceFile

VT_BOOL or Boolean SourceFile(FileName As String, Storing As Long).

Imports or Exports a RfTag description from the referenced FileName in XML format (write if Storing is true or read if false).


RfTagBlock Object

RfTagBlock Object (See RfTag Default Settings)

Properties | Methods
Attributes | GetField
Data Type | Read
FieldCount | ReadHexa
FieldsStructure FieldsStructureSize Index IsEmpty LinkedObjectName MaxDataLength Name Retries Rules Size SupportedAttributes SupportedDataTypes Value ValueEx | Reset Write WriteHexa

Object Properties

RfTagBlock.Attributes

Returns or sets attributes.

Access Read/Write.

Type EnumRfTagBlockAttribute.

RfTagBlock.DataType

Returns or sets the data type (VT_I4, VT_BSTR, VT_R4...).

Access Read/Write.

Type EnumRfTagBlockDataType.

RfTagBlock.FieldCount

Returns the number of fields.

Access Read-Only.

Type VT_I4 or Long.

RfTagBlock.FieldsStructure

Returns or sets the type of structured fields.

Access Read/Write.

Type EnumRfTagFieldsStructures.

RfTagBlock.FieldsStructureSize

Returns the size of all fields in bits unit.

Access Read-Only.

Type VT_I4 or Long.

RfTagBlock.Index

Returns ordinal position.

Access Read/Write.

Type VT_I4 or Long.

RfTagBlock.IsEmpty

Returns TRUE if empty.

Access Read-Only.

Type VT_BOOL or Boolean.

RfTagBlock.LinkedObjectName

Returns or sets the linked object name.

Access Read/Write.

Type VT_BSTR or String.

RfTagBlock.MaxDataLength

Returns the maximum number of characters that can be set in the data (depending on DataType).

Access Read/Write.

Type VT_BSTR or String.

RfTagBlock.Name

Returns or sets the name.

Access Read/Write.

Type VT_BSTR or String.

RfTagBlock.Retries

Returns or sets the retries (for write or read, depending on the attributes property).

Access Read/Write.

Type VT_I4 or Long.

RfTagBlock.Rules

Returns or sets the rules applied for the data block encoding (now only "UCodeEpc119" is available on the Epc tag and "FieldStructure" rule for all blocks that have the rftagBlockStructured data type).

Access Read/Write.

Type VT_BSTR or String.

RfTagBlock.Size

Returns or sets the size in bytes.

Access Read/Write.

Type VT_I4 or Long.

RfTagBlock.SupportedAttributes

Returns or sets supported attributes.

Access Read/Write.

Type EnumRfTagBlockAttribute.

RfTagBlock.SupportedDataTypes

Returns or sets supported data types.

Access Read/Write.

Type EnumRfTagBlockDataType.

RfTagBlock.Value

Returns or sets the value in the current data type format.

Access Read/Write.

Type VT_VARIANT or Variant.

RfTagBlock.ValueEx

VT_BSTR or String ValueEx(DataType as EnumRfTagBlockDataType)

Returns or sets the value converted with the specified datatype format.

Object Methods

RfTagBlock.GetField

BlockField or Long GetField(Index As Long).

Returns the BlockField object at the Index position.

RfTagBlock.Read

VT_I4 or Long Read(Bytes As Long).

Writes block bytes into the Bytes buffer and returns the number of byte copied.

RfTagBlock.ReadHexa

VT_I4 or Long ReadHexa(ByRef Value As String).

Writes block bytes into Value string buffer (converted in the hexadecimal format) and returns the number of characters copied.

RfTagBlock.Reset

VT_BOOL or Boolean Reset().

Resets with the default settings defined at construction (referenced by the clock Index).

RfTagBlock.Write

VT_I4 or Long Write(Bytes As Long).

Fills block bytes with bytes from Bytes buffer and returns the number of bytes filled.

RfTagBlock.WriteHexa

VT_I4 or Long WriteHexa(Value As String).

Fills block bytes with bytes from Value string buffer (converted in the hexadecimal format) and returns the number of bytes filled.


RfTagProperty Object

RfTagProperty Object (See RfTag Default Settings)

Properties | Methods
CtrlType | AddEntry
Entries | DelEntry
Entry ID Index Name Tag Type Value | DelEntryByVal ManageEntries Reset

Object Properties

RfTagProperty.CtrlType

Returns or sets the control type used from the user interface, if rftagCtrlHidden flag is set, the property is not visible.

Access Read/Write.

Type EnumRfTagCtrlType.

RfTagProperty.Entries

Returns a string of specified entries used by the property (ie : "LowerBound=100;UpperBound=100;Step=10;" is currently set with ctrlSpinButton).

Access Read/Write.

Type VT_BSTR or String.

RfTagProperty.Entry (Index As Variant)

Returns or sets a specified entry by its name or index position.

Access Read/Write.

Type VT_VARIANT or Variant.

RfTagProperty.ID

Returns the identifier number.

Access Read-Only.

Type VT_I4 or Long.

RfTagProperty.Index

Returns ordinal position.

Access Read/Write.

Type VT_I4 or Long.

RfTagProperty.Name

Returns or sets the name.

Access Read/Write.

Type VT_BSTR or String.

RfTagProperty.Tag

Returns or sets the Tag property.

Access Read/Write.

Type VT_VARIANT or Variant.

RfTagProperty.Type

Returns or sets the data type (VT_I4, VT_BSTR, VT_R4...).

Access Read/Write.

Type VT_I4 or Long.

RfTagProperty.Value

Returns or sets the value.

Access Read/Write.

Type VT_VARIANT or Variant.

Object Methods

RfTagProperty.AddEntry

VT_BOOL or Boolean AddEntry(Index As Variant, Value As Variant).

Appends or updates an entry, returns true if it is added or false if it is updated.

RfTagProperty.DelEntry

VT_BOOL or Boolean DelEntry(Index As Variant).

Renames an entry by its name or position, returns true if it is removed.

RfTagProperty.DelEntryByVal

VT_BOOL or Boolean DelEntryByVal(Value As Variant).

Renames an entry by its name or position, return true if it is removed.

RfTagProperty.ManageEntries

VT_I4 or Long ManageEntries(List As String, ByVal As Boolean, Keep As Boolean).

The Parameter List is a string that contains names (the parameter ByVal is FALSE) or values (the parameter ByVal is TRUE) separated by a semi colon (ie : "10;5;3;"), if the parameter Keep is TRUE, all others entries or the property are removed and if it is FALSE, all entries of the parameter List are removed and all other preserved. This function returns the count of entries that are preserved or removed.

RfTagProperty.Reset

VT_BOOL or Boolean Reset().

Resets the default settings defined at the construction (referenced by the propery ID).


SelectedDocObjects

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

SelectedDocObjects.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SelectedDocObjects.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

SelectedDocObjects.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

SelectedDocObjects.Add

VT_DISPATCH Add().

Adds a selected object to the collection.

SelectedDocObjects.Item

VT_DISPATCH Item(variant itemkey ).

Returns a member of a collection, either by position or by name.

SelectedDocObjects.Remove

VT_BOOL Remove ( variant ItemKey ).

Removes a member from the collection.


Shapes Collection

Properties | Methods
Application | AddEllipse
Count | AddLine
Parent | AddOblique
 | AddPolygon
 | AddRectangle
 | AddRoundRect
 | Item (Default)
 | Remove

Object Properties

Shapes.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Shapes.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Shapes.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Shapes.AddEllipse

VT_DISPATCH or Shape AddEllipse(longLeft, longTop, longRight, longBottom).

Adds a new Shape object to the collection.

Return value: Returns a Shape object.

Parameters:
longLeft Required VT_I4 or Long. Sets the left corner of the bounding rectangle of the object
(in MeasureSystem unit).

longTop Required VT_I4 or Long. Sets the top corner of the bounding rectangle of the object
(in MeasureSystem unit).

longRight Required VT_I4 or Long. Sets the right corner of the bounding rectangle of the object
(in MeasureSystem unit).

longBottom Required VT_I4 or Long. Sets the bottom corner of the bounding rectangle of the object
(in MeasureSystem unit).

Shapes.AddLine

VT_DISPATCH or Shape AddLine(longLeft, longTop, longRight, longBottom).

Adds a new Shape object to the collection.

Return value: Returns a Shape object.

Parameters:
longLeft Required VT_I4 or Long. Sets the left corner of the bounding rectangle of the object
(in MeasureSystem unit).

longTop Required VT_I4 or Long. Sets the top corner of the bounding rectangle of the object
(in MeasureSystem unit).

longRight Required VT_I4 or Long. Sets the right corner of the bounding rectangle of the object
(in MeasureSystem unit).

longBottom Required VT_I4 or Long. Sets the bottom corner of the bounding rectangle of the object
(in MeasureSystem unit).

Shapes.AddOblique

VT_DISPATCH or Shape AddOblique(longLeft, longTop, longRight, longBottom).

Adds a new Shape object to the collection.

Return value: Returns a Shape object.

Parameters:
longLeft Required VT_I4 or Long. Sets the left corner of the bounding rectangle of the object
(in MeasureSystem unit).

longTop Required VT_I4 or Long. Sets the top corner of the bounding rectangle of the object
(in MeasureSystem unit).

longRight Required VT_I4 or Long. Sets the right corner of the bounding rectangle of the object
(in MeasureSystem unit).

longBottom Required VT_I4 or Long. Sets the bottom corner of the bounding rectangle of the object
(in MeasureSystem unit).

Shapes.AddRectangle

VT_DISPATCH or Shape AddRectangle(longLeft, longTop, longRight, longBottom).

Adds a new Shape object to the collection.

Return value: Returns a Shape object.

Parameters:
longLeft Required VT_I4 or Long. Sets the left corner of the bounding rectangle of the object
(in MeasureSystem unit).

longTop Required VT_I4 or Long. Sets the top corner of the bounding rectangle of the object
(in MeasureSystem unit).

longRight Required VT_I4 or Long. Sets the right corner of the bounding rectangle of the object
(in MeasureSystem unit).

longBottom Required VT_I4 or Long. Sets the bottom corner of the bounding rectangle of the object
(in MeasureSystem unit).

Shapes.AddRoundRect

VT_DISPATCH or Shape AddRoundRect(longLeft, longTop, longRight, longBottom, longCorner).

Adds a new Shape object to the collection.

Return value: Returns a Shape object.

Parameters:
longLeft Required VT_I4 or Long. Sets the left corner of the bounding rectangle of the object
(in MeasureSystem unit).

longTop Required VT_I4 or Long. Sets the top corner of the bounding rectangle of the object
(in MeasureSystem unit).

longRight Required VT_I4 or Long. Sets the right corner of the bounding rectangle of the object
(in MeasureSystem unit).

longBottom Required VT_I4 or Long. Sets the bottom corner of the bounding rectangle of the object
(in MeasureSystem unit).

LongCorner Required VT_I4 or Long. Sets the radius of the corner (distance from bound)
(in MeasureSystem unit).

Shapes.AddPolygon

VT_DISPATCH or Shape AddPolygon(varSafeArrayOfPoints).

Adds a new Shape object to the collection.

Return value: Returns a Shape object.

Parameters:
varSafeArrayOfPoints Required VT_VARIANT/VT_ARRAY or Variant. Sets the list of points of the object
(in MeasureSystem unit).

Note:
It can be a one-dimensional array of values or a two-dimensional array of values.

Shapes.Item

VT_DISPATCH or Shape Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.Shapes(1)
Object.Shapes.Item(1)

Shapes.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Shape Object

Properties | Methods
AllowSuperimposing | Bound
AnchorPoint | Move
Application | SetPoints
BackColor | ShowDialog
ForeColor |
Height |
Layers |
Left |
LineWidth |
Locked |
Name |
Parent |
Rotation |
Top |
Type |
Width Backmode |
Visible |

Object Properties

Shape.AllowSuperimposing

Returns or sets the AllowSuperimposing option.

Access Read/Write.

Type VT_BOOL or Boolean.

Shape.AnchorPoint

Returns or sets the anchor point of the current object.

Access Read/Write.

Type VT_I4 or Long or enumAnchorPoint type.

Shape.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Shape.BackColor

This property returns or sets the backcolor of the shape.

Access Read/Write.

Type VT_I4 or long.

Shape.ForeColor

This property returns or sets the forecolor of the shape.

Access Read/Write.

Type VT_I4 or long.

Shape.Height

Returns or sets the height of the object (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Shape.Layers

T his property allows to define the layers where the shape object is visible.

Access Read/Write.

Type VT_I4 or EnumLayer.

Shape.Left

Returns or sets the distance between the left edge of the anchor point of the object and the left edge of the document (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Shape.LineWidth

Sets or retrieves the thickness of the bounds of the object.

Access Read/Write.

Type VT_I4 or Long.

Shape.Locked

True if the DocObject is locked (False by default).

Access Read/Write.

Type VT_BOOL or Boolean.

Shape.Name

Returns or sets the name of the DocObject.

Access Read/Write.

Type VT_BSTR or String.

Shape.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Shape.Rotation

Sets or retrieves the rotation of the object.

Access Read/Write.

Type VT_I4 or Long.

The value can be one of the following: 0, 900, 1800, 2700.

Shape.Top

Returns or sets the distance between the top edge of the anchor point of the object and the top edge of the document. (in MeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Shape.Type

Returns the type of the object (in enumDocObject type).

Access Read-Only.

Type VT_I2 or Integer.

Shape.Width

Returns or sets the width of the object (in enumMeasureSystem unit).

Access Read/Write.

Type VT_I4 or Long.

Shape.Backmode

Allows for the transparency of the Background

Transparent = 1

Opaque = 2

Shape.Visible

Allows to have object Visible or Not on the label.

This was made for internal use of Wizard : when you start create an object with the wizard, it is not visible on user interface.

Access Read/Write.

Type VT_BOOL or Boolean.

Object Methods

DocObject.Bound

VT_NONE Bound ( longLeftPosition, longTopPosition , longRightPosition , longBottomPosition).

Sets the bounding rectangle of an object.

Parameters:
longLeftPosition Required VT_I4 or Long. Distance between the left edge of an object
and the left edge of the document (in MeasureSystem unit).

longTopPosition Required VT_I4 or Long. Distance between the top edge of an object
and the top edge of the document (in MeasureSystem unit).

longRightPosition Required VT_I4 or Long. Distance between the right edge of an object
and the left edge ofthe document (in MeasureSystem unit).

longBottomPosition Required VT_I4 or Long. Distance between the bottom edge of an object
and the top edge ofthe document (in MeasureSystem unit).

DocObject.Move

VT_NONE Move (longLeftPosition, longTopPosition ).

Moves an object in its window.

Parameters:
longLeftPosition Required VT_I4 or Long. Distance between the left edge of an object
and the left edge of the document (in MeasureSystem unit).

longTopPosition Required VT_I4 or Long. Distance between the top edge of an object
and the top edge of the document (in MeasureSystem unit).

Shape.SetPoints

VT_NONE SetPoints ( varArrayOfPoints ).

Sets all points describing the current object.

Parameters:
varArrayOfPoints Required VT_VARIANT/VT_ARRAY or Variant. An expression that evaluates to an array of points.

Note:
In order to have a closed polygon, last point must match first point.

DocObject.ShowDialog

VT_BOOL ShowDialog(VT_VARIANT varParent).

Displays the Shape dialog box with the current Shape properties.


SharedOwner Collection

SharedOwner

Properties

Application

Counters

Forms

Frees

Lists

Object Properties

SharedOwner.Application

Retrieves the Application object that represents the root object of the hierarchy.

Access Read-only.
Type VT_DISPATCH.

SharedOwner.Counters

Retrieves counters collection

Access Read-only.
Type VT_DISPATCH.

SharedOwner.Forms

Retrieves forms collection

Access Read-only.
Type VT_DISPATCH.

SharedOwner.Frees

Retrieves frees collection

Access Read-only.
Type VT_DISPATCH.

SharedOwner.Lists

Retrieves lists collection

Access Read-only.
Type VT_DISPATCH.

Note: After setting a variable to shared, Refresh() must be called to have it appearing in the collection of shared variables.


SharedCounters

Properties | Methods
Application | Add
Count | Item
 | Refresh
 | Remove
 | ShowDialog
 | Write

Object Properties

SharedCounters.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SharedCounters.Count

This property returns the number of items in the specified collection.

Access Read-Only.

Type VT_I4

Object Methods

SharedCounters.Add

VT_DISPATCH Add(VT_BSTRstrName)

This method adds a new collection object to the collection.

Return value: a SharedCounters collection object.

Parameters: strName

SharedCounters.Item

VT_DISPATCH or Counter Item(VARIANTItemKey)

Returns a member of a collection, either by position or by name.

SharedCounters.Refresh

VT_NONE Refresh()

Updates the collection from the file of shared Counters.

Note: After setting a counter to shared, SharedCounter.Refresh() must be called to have it appearing in the collection of shared counters.

SharedCounters.Remove

VT_BOOL Remove(VARIANTItemkey)

Removes a member of a collection, either by position or by name.

SharedCounters.ShowDialog

VT_BOOL ShowDialog()

Shows collection.

SharedCounters.Write

VT_BOOL Write()

Updates the file of shared counters from the collection.


SharedCounter

Properties | Methods
Application | (none)
Name |
Value |

Object Properties

SharedCounter.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SharedCounter.Name

Returns or sets the name of the SharedCounter object.

Access Read/Write.

Type VT_BSTR or String

SharedCounter.Value

Returns or sets the value of the SharedCounter object.

Access Read/Write.

Type VT_BSTR or String


SharedForms Collection

Properties | Methods
Application | Add
Count | Item
 | Refresh
 | Remove
 | ShowDialog
 | Write

Object Properties

SharedForms.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SharedForms.Count

This property returns the number of items in the specified collection.

Access Read-Only.

Type VT_I4

Object Methods

SharedForms.Add

VT_DISPATCH Add(VT_BSTRstrName)

This method adds a new collection object to the collection.

Return value: a SharedForms collection object.

Parameters:
strName

SharedForms.Item

VT_DISPATCH or Counter Item(VARIANTItemKey)

Returns a member of a collection, either by position or by name.

SharedForms.Refresh

VT_NONE Refresh()

Updates the collection from the file of shared forms.

SharedForms.Remove

VT_BOOL Remove(VARIANTItemkey)

Removes a member of a collection, either by position or by name.

SharedForms.ShowDialog

VT_BOOL ShowDialog()

Shows collection.

SharedForms.Write

VT_BOOL Write()

Updates the file of shared forms from the collection.


SharedForm

Properties | Methods
Application | (none)
Name |
Value |

Object Properties

SharedForm.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SharedForm.Name

Returns or sets the name of the SharedForm object.

Access Read/Write.

Type VT_BSTR or String

SharedForm.Value

Returns or sets the value of the SharedForm object.

Access Read/Write.

Type VT_BSTR or String


SharedFrees

Properties | Methods
Application | Add
Count | Item
 | Refresh
 | Remove
 | ShowDialog
 | Write

Object Properties

SharedFrees.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SharedFrees.Count

This property returns the number of items in the specified collection.

Access Read-Only.

Type VT_I4

Object Methods

SharedFrees.Add

VT_DISPATCH Add(VT_BSTRstrName)

This method adds a new collection object to the collection.

Return value: a SharedFrees collection object.

Parameters:
strName

SharedFrees.Item

VT_DISPATCH or Counter Item(VARIANTItemKey)

Returns a member of a collection, either by position or by name.

SharedFrees.Refresh

VT_NONE Refresh()

Updates the collection from the file of shared frees.

SharedFrees.Remove

VT_BOOL Remove(VARIANTItemkey)

Removes a member of a collection, either by position or by name.

SharedFrees.ShowDialog

VT_BOOL ShowDialog()

Shows collection.

SharedFrees.Write

VT_BOOL Write()

Updates the file of shared frees from the collection.


SharedFree

Properties | Methods
Application | (none)
Name |
Value |

Object Properties

SharedFree.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SharedFree.Name

Returns or sets the name of the SharedFree object.

Access Read/Write.

Type VT_BSTR or String

SharedFree.Value

Returns or sets the value of the SharedFree object.

Access Read/Write.

Type VT_BSTR or String


SharedListsCollection

Properties | Methods
Application | Add
Count | Item
 | Refresh
 | Remove
 | Write

Object Properties

SharedListsCollection.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SharedListsCollection.Count

This property returns the number of items in the specified collection.

Access Read-Only.

Type VT_I4

Object Methods

SharedListsCollection.Add

VT_DISPATCH Add(VT_BSTRstrName)

This method adds a new SharedListsCollection to the collection.

Return value: a SharedListsCollection object.

Parameters:
strName

SharedListsCollection.Item

VT_DISPATCH or Counter Item(VARIANTItemKey)

Returns a member of a collection, either by position or by name.

SharedListsCollection.Refresh

VT_EMPTY Refresh()

Updates the collection from the file of shared lists.

SharedListsCollection.Remove

VT_BOOL Remove(VARIANTItemkey)

Removes a member of a collection, either by position or by name.

SharedListsCollection.Write

VT_BOOL Write()

Updates the file of shared lists from the collection.


SharedLists

Properties | Methods
Application | Add
Count | GetAt
Name | Refresh
 | Remove
 | ShowDialog
 | Write

Object Properties

SharedLists.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SharedLists.Count

This property returns the number of items in the specified collection.

Access Read-Only.

Type VT_I4

SharedLists.Name

Returns or sets the name of the SharedLists.

Access Read/Write.

Type VT_BSTR or String

Object Methods

SharedLists.AddValue

VT_DISPATCH AddValue(VT_BSTRstrName)

Adds a new collection to the lists collection.

SharedLists.DeleteValue

VT_BOOL DeleteValue(VARIANTItemKey)

Delete a collection in the lists collection.

SharedLists.GetAt

VT_DISPATCH GetAt(VT_I4 ikey)

Retrieves a member of a collection by position (ID). Collection starts from 1.

SharedLists.Refresh

VT_EMPTY Refresh()

Updates the collection from the file of shared lists collection.

SharedLists.ShowDialog

VT_BOOL ShowDialog()

Shows collection.

SharedLists.Write

VT_BOOL Write()

Updates the file of shared variables from the collection.


SharedList

Properties | Methods
Application | (none)
DefaultValue |
Value |

Object Properties

SharedList.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

SharedList.DefaultValue

Returns or sets the DefaultValue option.

Access Read/Write.

Type VT_BSTR or String

SharedList.Value

Returns or sets the value of the specified object.

Access Read/Write.

Type VT_BSTR or String


Strings Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

Strings.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Strings.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Strings.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Strings.Add

VT_NONE Add ( strStringValue ).

Adds a new string to the collection.

Parameters:
strStringValue Required VT_BSTR or String. Specifies the string to add.

Strings.Item

VT_BSTR Item( longIndex ).

Returns a member of a collection, either by position.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
longIndex Required VT_14 or Variant. The index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.Strings(1)
Object.Strings.Item(1)

Strings.Remove

VT_NONE Remove ( longIndex ).

Removes a member from the collection.

Parameters:
longIndex Required VT_I4 or Long. The index number of a member of the collection.

Must be a numeric expression (a number from 1 to the value of the collection’s Count property).


TableLookups Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

TableLookups.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

TableLookups.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

TableLookups.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

TableLookups.Add

VT_DISPATCH or TableLookup Add( strLinkedTableName).

Adds a new TableLookup object to the collection.

Return value: Returns a TableLookup object.

Parameters:
strLinkedTableName Optional VT_BSTR or String. The name of the object to add.

TableLookups.Item

VT_DISPATCH or TableLookup Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.TableLookups(1)
Object.TableLookups.Item(1)

TableLookups.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


TableLookup Object

Properties | Methods
Counter object properties | Counter object methods
CounterUse | AddKey
DatabaseSource | Connect
DatabaseType | DeleteKey
FieldSeparator | Disconnect
Keys | DisplayValue
Length |
PadLength |
Query |
RecordSeparator |
RelevantRecords |
ResultField |
TableName |

Object Properties

TableLookup.CounterUse

Activates or not a counter on the object.

Access Read/Write.

Type VT_BOOL or Boolean.

TableLookup.DatabaseSource

Sets or retrieves the data source name of the linked database:

  • in case of ODBC type, the DatabaseSource is the data source name.

  • in case of OLE DB type the DatabaseSource is the connection string.

Access Read/Write.

Type VT_BSTR or String.

TableLookup.DatabaseType

Sets or retrieves the type of data source:

  • _tkwOLEDB

  • _tkxODBC

Access Read/Write.

Type VT_I2 or Integer or enumDatabaseType

TableLookup.FieldSeparator

Sets or retrieves the string that separates each data field.

Access Read/Write.

Type VT_BSTR or String.

TableLookup.Length

Sets or retrieves the length of the output value.

Access Read/Write.

Type VT_I4 or Long.

TableLookup.PadLength

Sets or retrieves the number of characters to pad up to.

Access Read/Write.

Type VT_I2 or Integer.

TableLookup.Query

Sets or retrieves the SQL query, all parameters are automatically analyzed, they must be named in the same way as ''Application.Document.VarName''.

Access Read/Write.

Type VT_BSTR or String.

TableLookup.RecordSeparator

Sets or retrieves the string that separates each record.

Access Read/Write.

Type VT_BSTR or String.

TableLookup.RelevantRecords

Sets or retrieves the number of records used. If RelevantRecords = 0 all dataset records will be used.

Access Read/Write.

Type VT_I4 or Long.

TableLookup.ResultField

Sets or retrieves the name of the linked output field.

Access Read/Write.

Type VT_BSTR or String.

TableLookup.Keys

Returns strings collection for keys ("{FieldName}={VarName}, etc).

Access Read-Only.

Type VT_BSTR or String.

TableLookup.TableName

Sets or retrieves the linked table name of the current data source.

Access Read/Write.

Type VT_BSTR or String.

Object Methods

TableLookup.AddKey

VT_NONE AddKey (strSearchFieldName, strSearchFieldValue).

Adds a pair (<SearchFieldName>,<SearchFieldValue>) in the Search Field List.

Parameters:
strSearchFieldName Required VT_BSTR or String. The field name.

strSearchFieldValue Required VT_BSTR or String. The value of the field (must be the name of an other variable).

TableLookup.Connect

VT_BOOL or Boolean .

Connects to the Database

Return value: Returns a boolean that indicates whether the connection fails or not.

TableLookup.DeleteKey

VT_NONE DeleteKey( strFieldName ).

Deletes the search for the field strFieldName.

Parameters:
StrFieldName Required VT_BSTR or string. Fieldname to delete.

TableLookup.Disconnect

VT_BOOL or Boolean .

Disconnects to the Database

Return value: Returns a boolean that indicates whether the disconnection fails or not.

TableLookup.DisplayValue

VT_BSTR (R only)

Returns the display value


Texts Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Remove

Object Properties

Texts.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Texts.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Texts.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Object Methods

Texts.Add

VT_DISPATCH or Text Add( strTextName ).

Adds a new Text object to the collection.

Return value: Returns a Text object.

Parameters:
strTextName Optional VT_BSTR or String. The name of the object to add.

Texts.Item

VT_DISPATCH or Text Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
I f the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.Texts(1)
Object.Texts.Item(1)

Texts.Remove

VTS_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Text Object

Properties | Methods
Alignment | DocObject object methods
AllowSuperimposing | AppendCRLF
Backmode | AppendString
DocObject Object properties | AppendTextObject
FitToFrame | AppendVariable
FixedHeightAutoWidth | Copy
Font | InsertCRLF
Layers | InsertString
LineCount | InsertTextObject
LineSpacing | InsertVariable
MinWidth | Paste
SelText |
Strings |
Value |
VariableName |
VariableObject |
Visible |
WordHyphenation WordWrap |

Object Properties

Text.Alignment

Sets or retrieves current alignment (in enumAlignment type).

Access Read/Write.

Type VT_I2 or Integer or enumAlignment type.

Text.AllowSuperimposing

Returns or sets the AllowSuperimposing option.

Access Read/Write.

Type VT_BOOL or Boolean.

Text.FitToFrame

Sets or retrieves fit to frame option.

Access Read/Write.

Type VT_BOOL or Boolean.

Text. FixedHeightAutoWidth

Retrieves or sets the Fixed height, adjusted width text paragraph option.

It can be set to True only if the Text.WordWrap option is also set to True.
Access Read/Write.

Type VT_BOOL or Boolean.

Text.Font

Sets or retrieves text font.

Access Read/Write.

Type VT_FONT or StdFont object.

Text.Layers

This property allows to define the layers where the text object is visible.

Access Read/Write.

Type VT_I4 or EnumLayer.

Text.LineCount

Retreives or sets the Number of lines text paragraph option.

It can be set only if the Text.WordWrap and Text.FixedHeightAutoWidth options are set to True.

Access Read/Write.

Type VT_I4 or Long.

Text.LineSpacing

Sets or retrieves the paragraph line spacing.

Access Read/Write.

Type VT_I4 or Long.

Text.MinWidth

Retrieves or sets the Minimum width (%) text paragraph option.

It can be set only if the Text.WordWrap and Text.FixedHeightAutoWidth options are set to True.

Access Read/Write.

Type VT_I4 or Long.

Text.SelText

Retrieves the current selection of text if any.

Access Read-Only.

Type VT_DISPATCH or TextSelection object.

Text.Strings

Returns a TextStrings collection.

Access Read-Only.

Type VT_DISPATCH or TextStrings collection.

Text.Value

Sets or retrieves global value of the object.

Access Read/Write.

Type VT_BSTR or String.

Text.VariableName

Retrieves or sets the current variable name associated with the text.

Access Read/Write.

Type VT_BSTR or String.

Text.VariableObject

Retrieves or sets the current Variable object associated with the text.

Access Read/Write.

Type VT_DISPATCH or Variable object.

Text.Visible

Allows to have object Visible or Not on the label.

This was made for internal use of Wizard : when you start create an object with the wizard, it is not visible on user interface.

Access Read/Write.

Type VT_BOOL or Boolean.

Text.WordHyphenation

Retrieves or sets the WordHyphenation option.

Access Read/Write.

Type VT_BOOL or Boolean.

Text.WordWrap

Retrieves or sets the WordWrap option.

Access Read/Write.

Type VT_BOOL or Boolean.

Shape.Backmode

Allows for the transparency of the Background

Transparent = 1

Opaque = 2

Object Methods

Text.AppendCRLF

VT_NONE AppendCRLF ( fntFont ).

Appends a <CrLf> at the end of the text.

Parameters:
fntFont Optional VT_FONT or StdFont. Font associated with the Carriage return.

Text.AppendString

VT_NONE AppendString( strString, fntFont ).

Appends a string at the end of the text.

Parameters:
strString Required VT_BSTR or String. String to append.

fntFont Optional VT_FONT or StdFont. Font associated with the string.

Text.AppendTextObject

VT_NONE AppendTextObject( objectText ).

Appends a Text object at the end of the text.

Parameters:
objectText Required VT_DISPATCH or Text object. Text object to append.

Text.AppendVariable

VT_NONE AppendVariable( objectVariable, fntFont ).

Appends a Variable object at the end of the text.

Parameters:
objectVariable Required VT_DISPATCH or Variable object. Variable object to append.

fntFont Optional VT_FONT or StdFont. Font associated with the Variable object.

Text.Copy

VT_NONE Copy().

Copies the Text object to the clipboard.

Note:
About «Insert» functions :
Positions starts at 1.
A variable object equals 1 position.
A CarriageReturn field equals 1 position.

Text.InsertCRLF

VT_NONE InsertCRLF ( longPosition, fntFont ).

Inserts a carriage return at the position longPosition.

Parameters:
longPosition Optional VT_I4 or Long. Position to insert CarriageReturn.

fntFont Optional VT_FONT or StdFont. Font associated with the CarriageReturn field.

Text.InsertString

VT_NONE InsertString ( strString, longPosition, fntFont ).

Inserts a string at the position longPosition.

Parameters:
strString Required VT_BSTR or String. String to insert.

longPosition Optional VT_I4 or Long. Position to insert string.

fntFont Optional VT_FONT or StdFont. Font associated with the string.

Text.InsertTextObject

VT_NONE InsertTextObject ( objectText, longPosition ).

Inserts a Text object at the position longPosition.

Parameters:
objectText Required VT_DISPATCH or Text object. Text to insert.

longPosition Optional VT_I4 or Long. Position to insert Text object.

Text.InsertVariable

VT_NONE InsertVariable ( objectVariable, longPosition, fntFont ).

Inserts a Variable object at the position longPosition.

Parameters:
objectVariable Required VT_DISPATCH or Variable object. Variable to insert.

longPosition Optional VT_I4 or Long. Position to insert Variable object.

fntFont Optional VT_FONT or StdFont. Font associated with the Variable object.

Text.Paste

VT_NONE Paste ( ).

Pastes the text from the clipboard.


TextSelection Object

Properties | Methods
BackColor | Copy
Font | Cut
ForeColor | Paste
Value | Select
IsEmpty |

Object Properties

TextSelection.BackColor

Retrieves or sets back color of the selected text if any.

Access Read/Write.

Type VT_I4 or Long.

TextSelection.Font

Retrieves or sets font of the select text if any.

Access Read/Write.

Type VT_DISPATCH or StdFont.

TextSelection.ForeColor

Retrieves or sets fore color of the selected text if any.

Access Read/Write.

Type VT_I4 or Long.

TextSelection.IsEmpty

Tests if the selected text exists.

Access Read-Only.

Type VT_BOOL or Boolean.

TextSelection.Value

Retrieves or sets value of the selected text if any.

Access Read/Write.

Type VT_BSTR or String.

Object Methods

TextSelection.Copy

VT_NONE Copy().

Copies the selected text, if any, to the clipboard.

TextSelection.Cut

VT_NONE Cut().

Cuts the selected text, if any, and copies it to the clipboard.

TextSelection.Paste

VT_NONE Paste().

Pastes the text from clipboard into the current selected text.

TextSelection.Select

VT_NONE Select( longFirstPosition, longLastPosition).

Selects the text from longFirstPosition to longLastPosition.

Parameters:
longFirstPosition Optional VT_I4 or Long. Index of the first position of the text to select (starts with 1).

longLastPosition Optional VT_I4 or Long. Index of the last position of the text to select.

Note:
If longLastPosition is omitted the text selection starts with longFirstPosition and ends with the end of the text.
If longFirstPosition and longLastPosition are omitted, all the text is selected.


TextString Object

Properties | Methods
Font |
ForeColor |
BackColor |
Data VariableName |

Object Properties

TextString.Font

Sets or returns the font used by the string.

Access Read/Write.

Type VT_FONT or StdFont object.

TextString.ForeColor

Sets or returns the fore color of the string.

Access Read/Write.

Type VT_I4 or Long.

TextString.BackColor

Sets or returns the back color of the string.

Access Read/Write.

Type VT_I4 or Long.

TextString.Data

Sets or returns the data for a fixed value.

Access Read/Write.

Type VT_BSTR or String.

TextString.VariableName

Sets or returns the name of the variable for a variable value.

Access Read/Write.

Type VT_BSTR or String.


TextStrings Collection

Properties | Methods
Application | Add
Count | Item
Parent | Remove

Object Properties

TextStrings.Application

Returns the application.

Access Read-Only.

Type VT_DISPATCH or IDispatch.

TextStrings.Count

Returns the number of TextString item in the collection.

Access Read-Only.

Type VT_I2 or Integer.

TextStrings.Parent

Returns the parent of the collection.

Access Read-Only.

Type VT_DISPATCH or IDispatch.

Object Methods

TextStrings.Add

VT_DISPATCH Add(Name As String).

Adds a TextString object to the collection.

TextStrings.Item

VT_DISPATCH Item(Index As Variant).

Returns the member of a collection to the Index position.

TextStrings.Remove

VT_EMPTY Remove(Index As Variant).

Removes the member of a collection to the Index position.


Variables Collection

Properties | Methods
Application | Add
Count | Item (Default)
Parent | Refresh
Counters | Remove
DatabaseVariables |
Dates |
FormVariables |
Formulas |
FreeVariables |
TableLookups |

Object Properties

Variables.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Variables.Count

Returns the number of items in the specified collection.

Access Read-Only.

Type VT_I2 or Integer.

Variables.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Variables.Counters

Returns the Counters collection that represents all the created Counter variables in the document.

Access Read-Only.

Type VT_DISPATCH or Counters collection.

Variables.DatabaseVariables

Returns the DatabaseVariables collection that represents all the created Free variables with database link in the document.

Access Read-Only.

Type VT_DISPATCH or DatabaseVariables collection.

Variables.Dates

Returns the Dates collection that represents all the created Date variables in the document.

Access Read-Only.

Type VT_DISPATCH or Dates collection.

Variables.FormVariables

Returns the FormVariables collection that represents all the created Free variables with form attribute in the document.

Access Read-Only.

Type VT_DISPATCH or FormVariables collection.

Variables.Formulas

Returns the Formulas collection that represents all the created Formula variables in the document.

Access Read-Only.

Type VT_DISPATCH or Formulas collection.

Variables.FreeVariables

Returns the FreeVariables collection that represents all the created Free variables in the document.

Access Read-Only.

Type VT_DISPATCH or FreeVariables collection.

Variables.TableLookups

Returns the TableLookups collection that represents all the created TableLookup variables in the document.

Access Read-Only.

Type VT_DISPATCH or TableLookups collection.

Object Methods

Variables.Add

VT_DISPATCH or Variable Add( VariableDataSource, strVariableName).

Adds a new Variable object to the current document.

Return value: Returns a Variable object.

Parameters:
strVariableDataSource Required VT_I4 or Long or enumDataSource.

strVariableName Optional VT_BSTR or String. The name of the variable to add.

Variables.Item

VT_DISPATCH or Variable Item( varIndex ).

Returns a member of a collection, either by position or by name.

Note:
If the value provided as Index does not match any existing member of the collection, no object is returned.

Parameters:
varIndex Required VT_VARIANT or Variant. The name or index number of a member of the collection.

The index can be a numeric expression (a number from 1 to the value of the collection’s Count property), a constant, or a string.

Note:
If the value provided as Index doesn’t match any existing member of the collection, an error occurs.
The Item method is the default method for collections. Therefore, the following two lines of code are equivalent.
Object.Variables(1)
Object.Variables.Item(1)

Variables.Refresh

VT_EMPTY Remove ().

Refreshes the display value from all variables.

Variables.Remove

VT_NONE Remove ( varIndex ).

Removes a member from the collection.

Parameters:
varIndex Required VT_VARIANT or Variant. An expression that specifies the position of a member of the collection. If a numeric expression, index must be a number from 1 to the value of the collection’s Count property. If a string expression, index must correspond to the key argument specified when the member referred to was added to the collection.


Variable Object

Properties | Methods
Application | ShowDialog
AutoLength |
DataSource |
Name |
Parent |
DisplayValue |
Value (Default) |

Object Properties

Variable.Application

This property returns the Application object that represents the root object of the hierarchy.

Access Read-Only.

Type VT_DISPATCH or Application object.

Variable.AutoLength

Sets or retrieves the Automatic Maximum Length option when variable is a counter.

Access Read-Only.

Type VT_BOOL or Boolean.

Variable.DataSource

Returns the kind of data source of the variable (enumDatasource type).

Access Read-Only.

Type VT_I2 or Integer or enumDataSource type.

Variable.Name

Returns the name of the variable.

Access Read/Write.

Type VT_BSTR or String.

Variable.Parent

Returns the parent object of the specified object.

Access Read-Only.

Type VT_DISPATCH.

Variable.DisplayValue

VT_BSTR (R only)

Returns the display value

Variable.Value

Returns the current value of the variable.

Access Read/Write.

Type VT_BSTR or String.

Object Methods

Variable.ShowDialog

VT_BOOL ShowDialog(VT_VARIANT varParent).

Displays the Variable dialog box with the current variable properties.


Information on Visual C++ Data Type

This section provides information on the data type used with Visual C++.

For more information, refer to the Microsoft Visual C++ 6.0 documentation.

VARENUM usage key,
[V] - may appear in a VARIANT
[T] - may appear in a TYPEDESC
[P] - may appear in an OLE property set
[S] - may appear in a Safe Array

Item | [V] | [T] | [P] | [S] | Value
VT_EMPTY | * |  | * |  | nothing
VT_NUL | * |  | * |  | SQL style Null
VT_I2 | * | * | * | * | 2 byte signed int
VT_I4 | * | * | * | * | 4 byte signed int
VT_R4 | * | * | * | * | 4 byte real
VT_R8 | * | * | * | * | 8 byte real
VT_CY | * | * | * | * | currency
VT_DATE | * | * | * | * | date
VT_BSTR | * | * | * | * | OLE Automation string
VT_DISPATCH | * | * | * | * | IDispatch
VT_ERROR | * | * | * | * | SCODE
VT_BOOL | * | * | * | * | True=-1, False=0
VT_VARIANT | * | * | * | * | VARIANT
VT_UNKNOWN | * | * |  | * | IUnknown
VT_DECIMAL | * | * |  | * | 16 byte fixed point
VT_RECORD | * |  | * | * | user defined type
VT_I1 | * | * | * | * | signed char
VT_UI1 | * | * | * | * | unsigned char
VT_UI2 | * | * | * | * | unsigned short
VT_UI4 | * | * | * | * | unsigned short
VT_I8 |  | * | * |  | signed 64-bit int
VT_UI8 |  | * | * |  | unsigned 64-bit int
VT_INT | * | * | * | * | signed machine int
VT_UINT | * | * |  | * | unsigned machine int
VT_VOID |  | * |  |  | C style void
VT_HRESULT |  | * |  |  | Standard return type
VT_PTR |  | * |  |  | pointer type
VT_SAFEARRAY |  | * |  |  | (use VT_ARRAY in VARIANT)
VT_CARRAY |  | * |  |  | C style array
VT_USERDEFINED |  | * |  |  | user defined type
VT_LPSTR |  | * | * |  | null terminated string
VT_LPWSTR |  | * | * |  | wide null terminated string
VT_FILETIME |  |  | * |  | FILETIME
VT_BLOB |  |  | * |  | Length prefixed bytes
VT_STREAM |  |  | * |  | Name of the stream follows
VT_STORAGE |  |  | * |  | Name of the storage follows
VT_STREAMED_OBJECT |  |  | * |  | Stream contains an object
VT_STORED_OBJECT |  |  | * |  | Storage contains an object
VT_BLOB_OBJECT |  |  | * |  | Blob contains an object
VT_CF |  |  | * |  | Clipboard format
VT_CLSID |  |  | * |  | A Class ID
VT_VECTOR |  |  | * |  | simple counted array
VT_ARRAY | * |  |  |  | SAFEARRAY*
VT_BYREF | * |  |  |  | void* for local use
VT_BSTR_BLOB |  |  |  |  | Reserved for system use


TkxOleCtrlEx control

OCX (Object component exchange) is an ActiveX control.

An OCX is an Object Linking and Embedding (OLE) custom control, a special-purpose program that can be created for use by applications running on Microsoft's Windows systems. OCXs provide such functions as handling scroll bar movement and window resizing.

For full information on TkxOleCtrlEx control, consult the TkxOleCtrlEx control Help available from the control.


DocObjectProperty Object

Properties | Methods
Name | (none)
DataType |
Value |
ID |
Entries |
Locked |

Object Properties

DocObjectProperty.Name

Returns or sets the name.

Access Read/Write.

Type VT_BSTR or String.

DocObjectProperty.DataType

Returns or sets the data type stored in the property value (VT_I4, VT_BSTR...).

Access Read/Write.

Type VT_I4 or Long.

DocObjectProperty.Value

Returns or sets the value.

Access Read/Write.

Type VT_VARIANT or Variant.

DocObjectProperty.ID

Returns the unique identifier.

Access Read-Only.

Type VT_I4 or Long.

DocObjectProperty.Entries

Returns or sets the extended entries.

Access Read/Write.

Type VT_BSTR or String.

DocObjectProperty.Locked

Returns or sets the locked attribute used to enable or disable the setting in the user interface.

Access Read/Write.

Type VT_BOOL or Boolean.


PaperType Appendix

Constant | Value | Meaning
DMPAPER_LETTER | 1 | US Letter 8 1/2 x 11 in
DMPAPER_LETTERSMALL | 2 | US Letter Small 8 1/2 x 11 in
DMPAPER_TABLOID | 3 | US Tabloid 11 x 17 in
DMPAPER_LEDGER | 4 | US Ledger 17 x 11 in
DMPAPER_LEGAL | 5 | US Legal 8 1/2 x 14 in
DMPAPER_STATEMENT | 6 | US Statement 5 1/2 x 8 1/2 in
DMPAPER_EXECUTIVE | 7 | US Executive 7 1/4 x 10 1/2 in
DMPAPER_A3 | 8 | A3 297 x 420 mm
DMPAPER_A4 | 9 | A4 210 x 297 mm
DMPAPER_A4SMALL | 10 | A4 Small 210 x 297 mm
DMPAPER_A5 | 11 | A5 148 x 210 mm
DMPAPER_B4 | 12 | B4 (JIS) 250 x 354
DMPAPER_B5 | 13 | B5 (JIS) 182 x 257 mm
DMPAPER_FOLIO | 14 | Folio 8 1/2 x 13 in
DMPAPER_QUARTO | 15 | Quarto 215 x 275 mm
DMPAPER_10X14 | 16 | 10 x 14 in
DMPAPER_11X17 | 17 | 11 x 17 in
DMPAPER_NOTE | 18 | US Note 8 1/2 x 11 in
DMPAPER_ENV_9 | 19 | US Envelope #9 3 7/8 x 8 7/8
DMPAPER_ENV_10 | 20 | US Envelope #10 4 1/8 x 9 1/2
DMPAPER_ENV_11 | 21 | US Envelope #11 4 1/2 x 10 3/8
DMPAPER_ENV_12 | 22 | US Envelope #12 4 \276 x 11
DMPAPER_ENV_14 | 23 | US Envelope #14 5 x 11 1/2
DMPAPER_CSHEET | 24 | C size sheet
DMPAPER_DSHEET | 25 | D size sheet
DMPAPER_ESHEET | 26 | E size sheet
DMPAPER_ENV_DL | 27 | Envelope DL 110 x 220mm
DMPAPER_ENV_C5 | 28 | Envelope C5 162 x 229 mm
DMPAPER_ENV_C3 | 29 | Envelope C3 324 x 458 mm
DMPAPER_ENV_C4 | 30 | Envelope C4 229 x 324 mm
DMPAPER_ENV_C6 162 mm | 31 | Envelope C6 114 x
DMPAPER_ENV_C65 | 32 | Envelope C65 114 x 229 mm
DMPAPER_ENV_B4 | 33 | Envelope B4 250 x 353 mm
DMPAPER_ENV_B5 | 34 | Envelope B5 176 x 250 mm
DMPAPER_ENV_B6 | 35 | Envelope B6 176 x 125 mm
DMPAPER_ENV_ITALY | 36 | Envelope 110 x 230 mm
DMPAPER_ENV_MONARCH | 37 | US Envelope Monarch 3.875 x 7.5 in
DMPAPER_ENV_PERSONAL | 38 | 6 3/4 US Envelope 3 5/8 x 6 1/2 in
DMPAPER_FANFOLD_US | 39 | US Std Fanfold 14 7/8 x 11 in
DMPAPER_FANFOLD_STD_GERMAN | 40 | German Std Fanfold 8 1/2 x 12 in
DMPAPER_FANFOLD_LGL_GERMAN | 41 | German Legal Fanfold 8 1/2 x 13 in
DMPAPER_ISO_B4 | 42 | B4 (ISO) 250 x 353 mm
DMPAPER_JAPANESE_POSTCARD | 43 | Japanese Postcard 100 x 148 mm
DMPAPER_9X11 | 44 | 9 x 11 in
DMPAPER_10X11 | 45 | 10 x 11 in
DMPAPER_15X11 | 46 | 15 x 11 in
DMPAPER_ENV_INVITE | 47 | Envelope Invite 220 x 220 mm
DMPAPER_RESERVED_48 | 48 | RESERVED--DO NOT USE
DMPAPER_RESERVED_49 | 49 | RESERVED--DO NOT USE
DMPAPER_LETTER_EXTRA | 50 | US Letter Extra 9 \275 x 12 in
DMPAPER_LEGAL_EXTRA | 51 | US Legal Extra 9 \275 x 15 in
DMPAPER_TABLOID_EXTRA | 52 | US Tabloid Extra 11.69 x 18 in
DMPAPER_A4_EXTRA | 53 | A4 Extra 9.27 x 12.69 in
DMPAPER_LETTER_TRANSVERSE | 54 | Letter Transverse 8 \275 x 11 in
DMPAPER_A4_TRANSVERSE | 55 | A4 Transverse 210 x 297 mm
DMPAPER_LETTER_EXTRA_TRANSVERSE | 56 | Letter Extra Transverse 9\275 x 12 in
DMPAPER_A_PLUS | 57 | SuperA/SuperA/A4 227 x 356 mm
DMPAPER_B_PLUS | 58 | SuperB/SuperB/A3 305 x 487 mm
DMPAPER_LETTER_PLUS | 59 | US Letter Plus 8.5 x 12.69 in
DMPAPER_A4_PLUS | 60 | A4 Plus 210 x 330 mm
DMPAPER_A5_TRANSVERSE | 61 | A5 Transverse 148 x 210 mm
DMPAPER_B5_TRANSVERSE | 62 | B5 (JIS) Transverse 182 x 257 mm
DMPAPER_A3_EXTRA | 63 | A3 Extra 322 x 445 mm
DMPAPER_A5_EXTRA | 64 | A5 Extra 174 x 235 mm
DMPAPER_B5_EXTRA | 65 | B5 (ISO) Extra 201 x 276 mm
DMPAPER_A2 | 66 | A2 420 x 594 mm
DMPAPER_A3_TRANSVERSE | 67 | A3 Transverse 297 x 420 mm
DMPAPER_A3_EXTRA_TRANSVERSE | 68 | A3 Extra Transverse 322 x 445 mm
DMPAPER_DBL_JAPANESE_POSTCARD | 69 | Japanese Double Postcard 200 x 148 mm
DMPAPER_A6 | 70 | A6 105 x 148 mm
DMPAPER_JENV_KAKU2 | 71 | Japanese Envelope Kaku #2
DMPAPER_JENV_KAKU3 | 72 | Japanese Envelope Kaku #3
DMPAPER_JENV_CHOU3 | 73 | Japanese Envelope Chou #3
DMPAPER_JENV_CHOU4 | 74 | Japanese Envelope Chou #4
DMPAPER_LETTER_ROTATED | 75 | Letter Rotated 11 x 8 1/2 11 in
DMPAPER_A3_ROTATED | 76 | A3 Rotated 420 x 297 mm
DMPAPER_A4_ROTATED | 77 | A4 Rotated 297 x 210 mm
DMPAPER_A5_ROTATED | 78 | A5 Rotated 210 x 148 mm
DMPAPER_B4_JIS_ROTATED | 79 | B4 (JIS) Rotated 364 x 257 mm
DMPAPER_B5_JIS_ROTATED | 80 | B5 (JIS) Rotated 257 x 182 mm
DMPAPER_JAPANESE_POSTCARD_ROTATED | 81 | Japanese Postcard Rotated 148 x 100 mm
DMPAPER_DBL_JAPANESE_POSTCARD_ROTATED | 82 | Double Japanese Postcard Rotated 148 x 200 mm
DMPAPER_A6_ROTATED | 83 | A6 Rotated 148 x 105 mm
DMPAPER_JENV_KAKU2_ROTATED | 84 | Japanese Envelope Kaku #2 Rotated
DMPAPER_JENV_KAKU3_ROTATED | 85 | Japanese Envelope Kaku #3 Rotated
DMPAPER_JENV_CHOU3_ROTATED | 86 | Japanese Envelope Chou #3 Rotated
DMPAPER_JENV_CHOU4_ROTATED | 87 | Japanese Envelope Chou #4 Rotated
DMPAPER_B6_JIS | 88 | B6 (JIS) 128 x 182 mm
DMPAPER_B6_JIS_ROTATED | 89 | B6 (JIS) Rotated 182 x 128 mm
DMPAPER_12X11 | 90 | 12 x 11 in
DMPAPER_JENV_YOU4 | 91 | Japanese Envelope You #4
DMPAPER_JENV_YOU4_ROTATED | 92 | Japanese Envelope You #4 Rotated
DMPAPER_P16K | 93 | PRC 16K 146 x 215 mm
DMPAPER_P32K | 94 | PRC 32K 97 x 151 mm
DMPAPER_P32KBIG | 95 | PRC 32K(Big) 97 x 151 mm
DMPAPER_PENV_1 | 96 | PRC Envelope #1 102 x 165 mm
DMPAPER_PENV_2 | 97 | PRC Envelope #2 102 x 176 mm
DMPAPER_PENV_3 | 98 | PRC Envelope #3 125 x 176 mm
DMPAPER_PENV_4 | 99 | PRC Envelope #4 110 x 208 mm
DMPAPER_PENV_5 | 100 | PRC Envelope #5 110 x 220 mm
DMPAPER_PENV_6 | 101 | PRC Envelope #6 120 x 230 mm
DMPAPER_PENV_7 | 102 | PRC Envelope #7 160 x 230 mm
DMPAPER_PENV_8 | 103 | PRC Envelope #8 120 x 309 mm
DMPAPER_PENV_9 | 104 | PRC Envelope #9 229 x 324 mm
DMPAPER_PENV_10 | 105 | PRC Envelope #10 324 x 458 mm
DMPAPER_P16K_ROTATED | 106 | PRC 16K Rotated
DMPAPER_P32K_ROTATED | 107 | PRC 32K Rotated
DMPAPER_P32KBIG_ROTATED | 108 | PRC 32K(Big) Rotated
DMPAPER_PENV_1_ROTATED | 109 | PRC Envelope #1 Rotated 165 x 102 mm
DMPAPER_PENV_2_ROTATED | 110 | PRC Envelope #2 Rotated 176 x 102 mm
DMPAPER_PENV_3_ROTATED | 111 | PRC Envelope #3 Rotated 176 x 125 mm
DMPAPER_PENV_4_ROTATED | 112 | PRC Envelope #4 Rotated 208 x 110 mm
DMPAPER_PENV_5_ROTATED | 113 | PRC Envelope #5 Rotated 220 x 110 mm
DMPAPER_PENV_6_ROTATED | 114 | PRC Envelope #6 Rotated 230 x 120 mm
DMPAPER_PENV_7_ROTATED | 115 | PRC Envelope #7 Rotated 230 x 160 mm
DMPAPER_PENV_8_ROTATED | 116 | PRC Envelope #8 Rotated 309 x 120 mm
DMPAPER_PENV_9_ROTATED | 117 | PRC Envelope #9 Rotated 324 x 229 mm
DMPAPER_PENV_10_ROTATED | 118 | PRC Envelope #10 Rotated 458 x 324 mm


Particularity about access rights

Certain versions of the labeling software include a User manager module. This module controls access to certain functions of the labeling software.

For example, if calling a function through your ActiveX interface fails, verify your rights in the User manager module.

An error message is displayed and provides information about the nature of the error (see Error code table).


SetParameter list

Get - Set Parameter list

varParameter |  | varValue |
Property Name as VT_BSTR or String | Properties ID as VT_I4 or Integer | Type | Definition
VAR_FIELDS_ONLY | PROP_VAR_FIELDS_ONLY= 1 | VT_BOOL | When this option is selected, the program sends all fixed label elements to the printer when printing is first launched. For subsequent printruns in a given series, only variable elements are sent.
DIRECT_THERMAL | PROP_DIRECT_THERMAL = 2 | VT_BOOL | To enable if you are printing directly onto the print media. To disable if you are using an ink ribbon (thermal transfer).
RIBBON_SAVER | PROP_RIBBON_SAVER = 3 | VT_BOOL | This option interrupts the ribbon advance when the label contains an area in which there is nothing to be printed.
PEEL_OFF | PROP_PEEL_OFF = 4 | VT_BOOL | Enables the printer's peel-off function. This pauses the printer while the label is peeled off.
TEAR_OFF | PROP_TEAR_OFF = 5 | VT_BOOL | Allows you to position the label to tear off in a predefined place.
ROT180 | PROP_ROT180 = 6 | VT_BOOL | The label is not modified but comes out of the printer rotated by 180°.
MIRROR | PROP_MIRROR = 7 | VT_BOOL | Specifies whether printing should be carried out in mirror image. When this function is enabled, a mirror image of your document will be printed by inverting the horizontal coordinates.
CHECK_PRINTER | PROP_CHECK_PRINTER = 8 | VT_BOOL | Allows to get the printer status.
OVERLAY_INVERTED | PROP_OVERLAY_INVERTED = 9 | VT_BOOL | By default, placing a line on top of another object will not affect its appearance. Enabling this function inverts the color of the overlayed object (XOR function).
SUPPRESS_BACKFEED | PROP_SUPPRESS_BACKFEED = 10 | VT_BOOL | This command deletes the withdrawal action of paper before printing when the printer is in Tear Off or Cutter mode.
CUTTER | PROP_CUTTER = 11 | VT_BOOL | Allows to activate the cutter.
CUT_FINAL_PIECE | PROP_CUT_FINAL_PIECE = 12 | VT_BOOL | With this option, only the last printed label is cut.
PrintSpeed | PROP_PRINTSPEED = 13 | VT_I2 | Allows to select the printer speed.
HeadTemp | PROP_HEADTEMP = 14 | VT_I4 | Allows to select the printing temperature.
PaperFeedMode | PROP_PAPERFEEDMODE = 15 | VT_I2 | Allows you to select a paper feed mode.
BackFeedPos | PROP_BACKFEEDPOS = 16 | VT_I4 | Allows you to select a paper feed mode.
VerticalPos | PROP_VERTICALPOS = 17 | VT_I4 | Allows you to enter the vertical adjustment value for all objects included in the label.
HorizontalPos | PROP_HORIZONTALPOS = 18 | VT_I4 | Allows you to enter the horizontal adjustment value for all objects included in the label.
FeedAfterPrint | PROP_FEEDAFTERPRINT = 19 | VT_I4 | Allows you to set the position of the media after printing the last label.
FeedBeforePrint | PROP_FEEDBEFOREPRINT = 20 | VT_I4 | Allows you to set the position of the media before printing the first label.
CutPos | PROP_CUTPOS = 21 | VT_I4 | Allows you to adjust the position of the media before it is cut
InterCut | PROP_INTERCUT = 22 | VT_I4 | Enter the number of labels you wish to print between each pause/cut.
CountryCode | PROP_COUNTRYCODE = 23 | VT_I2 | Allows you to configure international character sets. Select the country code corresponding to your system in order to manage the printer fonts correctly.
UseUnicode | PROP_USE_UNICODE = 26 | VT_BOOL | Allows to send data to the printer in Unicode format